5.1 audio over built-in RealTek optical output (1 Viewer)

HTPCSourcer

MP2 Product Manager
  • Team MediaPortal
  • May 16, 2008
    11,431
    2,333
    Germany Germany
    Country flag
    OK, that's a different issue. Then you have not configurated your Windows correctly.

    Talking from memory now: you need to configure the "Digital" device as output. Forget about anything with loudspeakers or similar. Check out the mixer and go to its properties where you can configure the play device. Watching TV now, but if you don't get it working I will have a look at my own setup tomorrow.[DOUBLEPOST=1416164848][/DOUBLEPOST]Ac3 filter should not be needed when using spdif. At worst you would get no sound at all. Not withstanding, playing for example a DVD with MediaPlayer and only getting PCM is a clear sign of audio device misconfiguration.
     

    Stéphane Lenclud

    Development Group
  • Team MediaPortal
  • April 29, 2013
    2,563
    1,288
    Germany Germany
    Country flag
    My Teufel DecoderStation 7 is back in its box as I'm getting it swapped. I've plugged my 5.1 speakers directly to my SoundBlaster ZxR. The SoundBlaster ZxR daughter board is not installed that's why I was using optical out from the motherboard RealTek.
    Now despite that sound card being supposedly top quality I can hear my hard drive in my center speaker but lets leave that one aside :)

    Now PowerDVD playing a BD does work nicely with my 5.1 speakers I get the surround working eventually, analog rocks :)
    MP playing an AC3 rip of that same BD only uses my front speakers however so surround is not working there, any tip to get that one working?
    I'm using the default LAV filters.
     

    HTPCSourcer

    MP2 Product Manager
  • Team MediaPortal
  • May 16, 2008
    11,431
    2,333
    Germany Germany
    Country flag
    MP playing stero only is subject to codec settings. AC3 is a Dolby Digital format and you now have the reverse problem from above. LAV should be possible to be configured to decode AC3 to a 5.1 setup. Yovain's suggestion with AC3 filter should also give you what you want.
     

    Stéphane Lenclud

    Development Group
  • Team MediaPortal
  • April 29, 2013
    2,563
    1,288
    Germany Germany
    Country flag
    Ok I found that 5.1 option in the 32bits Mixing settings for LAV filter and that did get my 5.1 analog setup working. I'm guessing my issue with optical could have been similar since I was trying to change the settings in the x64 LAV settings.

    Why is it that I need to setup the filters for 5.1 when my Windows/Drivers are already setup for 5.1?
     

    HTPCSourcer

    MP2 Product Manager
  • Team MediaPortal
  • May 16, 2008
    11,431
    2,333
    Germany Germany
    Country flag
    Because MePo plays audio strictly according to codec definition and settings. Switch to MS-DTV and the correct sound device and no further setting will be necessary.
     
    Last edited:

    HTPCSourcer

    MP2 Product Manager
  • Team MediaPortal
  • May 16, 2008
    11,431
    2,333
    Germany Germany
    Country flag
    Microsoft Digital TV filter. Since you are using Win 7, those should be selectable in the MePo codec page. I prefer them over lav because they use less CPU and the picture us better, IMHO.
     

    Stéphane Lenclud

    Development Group
  • Team MediaPortal
  • April 29, 2013
    2,563
    1,288
    Germany Germany
    Country flag
    Thanks for the tip, I'll us them then. Do I need to switch all audio and video filters in MP config to us MS-DTV then?
     

    HTPCSourcer

    MP2 Product Manager
  • Team MediaPortal
  • May 16, 2008
    11,431
    2,333
    Germany Germany
    Country flag
    You don't need, yet I would suggest to do so in a first step. You can always make a different selection later if you get undesired results - wouldn't know what that could be though.
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    Golf4 TV-Records werden als Audio-Files importiert ? Allgemeines Support- und Diskussionsforum 0
    W [solved] Incorrect audio being reported Moving Pictures 4
    404 [solved] Live TV...video and audio freeze General Support 20
    ninja 12 Audio dropouts with Dolby / DTS watch/edit Videos 12
    bta489 [solved] DVB-T2 Recordings: Sometimes no Audio after muxing with mkvmerge Tools and other software 2
    T [solved] MP2 Switch off visualisation when listening to audio....PLEASE!!! General 23
    azzuro [fixed] [WIP MP2.3] - Audio files not imported to MP MediaPortal 2 18
    S Remote button to change audio and subtitle on / off General 10
    F Audio render and font error in my logs General Support 2
    R [solved] Command / Shortcut for changing subtitles or audio Archive 5
    K Multichannel audio and subtitles for TV not properly supported General Support 4
    Glith Audio out of sync after pause. Rewind 15sec gets it into sync again. MediaPortal 1 Talk 0
    C ARC Audio Renderer Changer: wo kann man es konfigurieren? Video & DVD 15
    joecrow No Audio after MP Start/Resume from Sleep General Support 0
    C Ability to browse videos and audio by folder General 2
    Lichloathe Offline audio content General 9
    G How best to get cover art for tracks to show up on the Audio Menu (Latest Added, Unplayed)? General 9
    Ralph Holmes Wrong audio source in TV General 1
    CyberSimian [Proposal] Audio description MediaPortal 1 10
    ge2301 [fixed] [MP2-807] Problem when switching player in PiP mode with audio files MediaPortal 2 32
    cladinshadows85 [solved] Audio playing mutiple times over video and crashing General 8
    H Live TV info OSD not displaying number of audio channels General Support 3
    T Moving Pictures...seem to have 'lost' ability to display Movie info. (eg Resolution/Audio) Moving Pictures 2
    N [fixed] [MP2-786] Cannot play audio playlist with >=1000 entries 2.2 Archive 36
    B Media info shows audio is 5.1 MP shows 2.0 Watch / Listen Media 2
    Similar threads

























    Top Bottom