MP2 - V2.1 - 500 movies missing | Page 2

Discussion in 'Older releases' started by JSchuricht, March 11, 2017.

Thread Status:
Not open for further replies.
  1. breese
    • Team MediaPortal

    breese Retired Team Member

    Joined:
    July 11, 2011
    Messages:
    3,903
    Likes Received:
    325
    Gender:
    Male
    Occupation:
    Sr. Systems Engineer
    Location:
    Arlington Heights, Illinois
    Ratings:
    +768 / 0
    Home Country:
    United States of America United States of America
    Show System Specs
    I have used tt#### in the file names forever... I was one of the orig testers to help make this happen and work.
    Still use it today with great results.



    moviename tt####.mkv type naming.
    You can also do moviename [tt####].mkv and it works
    I am using mkv just as an example
     
  2. Google AdSense Guest Advertisement



    to hide all adverts.
  3. JSchuricht
    • Premium Supporter

    JSchuricht MP Donator

    Joined:
    January 13, 2009
    Messages:
    149
    Likes Received:
    12
    Occupation:
    Silicon wafer manufacturing
    Ratings:
    +23 / 0
    Home Country:
    United States of America United States of America
    Show System Specs
    henso I am baffled. The three primary systems I use or have installed are missing the code in NfoMetadataExtractors. Two test systems that I built to test this issue are missing the code. Somehow, today on a third test system when I tried fresh installs with zero configuration or previous installs using 2.1 pre2, 2.1 pre and spring 16 both as a server and client & server together the code is there. I even tried fresh copies from sourceforge, copies of the installer I already downloaded and summer 15 just to make sure it wasn't present. On a hunch I tried to install 2.1 pre2 without a internet connection but apparently that isn't possible. The only theory I have which is a guess not knowing how setup is done is possibly NfoMetadataExtractors is being downloaded during install with a round robbin between a few servers that aren't in sync.

    breese using the tt number in the file name has a few issues. The main one for me is it isn't realistic. Renaming 7,000 ish movies across multiple systems would take too much time and cause a reimport loosing watched flags. The second major issue is the tt numbers aren't working all that well, I have tested a few movies where the tt number can't be found but naming the movie just right with the year works.

    I had a chance to see how the import went with the NfoMetadataExtractors code fix and enabling OMBBAPI.com and Fanart.tv for online sources. That brought the movies up to 1626 from 1590 of 2080 movies with tt numbers on the system which MP 1 with moving pictures could see. The issue I am seeing is the input sources are missing a bunch of tt numbers preventing imports. Cannot extract metadata; Imdb-ID: 'tt1355631' could not be found or does not represent a movie on TheMovieDb.com is what I see over and over with no mention of OMBBAPI.com or Fanart.tv. Thats from NfoMovieMetadataExtractorDebug.log.
     
    Last edited: March 24, 2017
  4. breese
    • Team MediaPortal

    breese Retired Team Member

    Joined:
    July 11, 2011
    Messages:
    3,903
    Likes Received:
    325
    Gender:
    Male
    Occupation:
    Sr. Systems Engineer
    Location:
    Arlington Heights, Illinois
    Ratings:
    +768 / 0
    Home Country:
    United States of America United States of America
    Show System Specs
    Every movie I have with a tt### is 100% found on imdb.com
    In your sample of tt355631, imdb.com finds it as The Infiltrator (2016)

    The installer uses the internet connection to make sure all the proper packages are installed.
    Dokan is one that is checked and pulled down if not already found on your system or is an older version than is now supported.
    There are also windows packages.....
     
  5. JSchuricht
    • Premium Supporter

    JSchuricht MP Donator

    Joined:
    January 13, 2009
    Messages:
    149
    Likes Received:
    12
    Occupation:
    Silicon wafer manufacturing
    Ratings:
    +23 / 0
    Home Country:
    United States of America United States of America
    Show System Specs
    Yes, all the movies with a tt number I have tried work on imdb, its MP 2.1 that doesn't see them.
     
  6. HTPCSourcer
    • Team MediaPortal
    • Administrator

    HTPCSourcer MP2 Product Manager

    Joined:
    May 16, 2008
    Messages:
    10,584
    Likes Received:
    1,110
    Gender:
    Male
    Ratings:
    +2,384 / 21
    Home Country:
    Germany Germany
    Show System Specs
    How do you know that? Did you disassemble the code ;)?

    I can assure you that this si not the case. No such package is downloaded during the installation process.

    If some systems work and others don't, I would suggest that you uninstall MP2 on the non-working systems and then install MP 2.1pre2. Your data will not be affected and you can continue using the systems in the same state they were before you uninstalled.
     
  7. JSchuricht
    • Premium Supporter

    JSchuricht MP Donator

    Joined:
    January 13, 2009
    Messages:
    149
    Likes Received:
    12
    Occupation:
    Silicon wafer manufacturing
    Ratings:
    +23 / 0
    Home Country:
    United States of America United States of America
    Show System Specs
    Its not that hard to look inside NfoMetadataExtractors with a text editor. On the left is the one test system I haven't fixed yet, it has mp 2.1 pre2 which was a fresh install a few weeks ago. On the right is a fresh install of mp 2.1 pre2 from yesterday.

    upload_2017-3-25_4-18-24.png


    The download during install was just a guess because I have no idea why the file is different on some systems.

    Reinstalling is something I have done on a few systems, the one that prompted this thread was a reinstall several times while troubleshooting along with deleting all files including the database. It was missing the code in NfoMetadataExtractors after the reinstall until I stopped the service and put the code in.
     
  8. HTPCSourcer
    • Team MediaPortal
    • Administrator

    HTPCSourcer MP2 Product Manager

    Joined:
    May 16, 2008
    Messages:
    10,584
    Likes Received:
    1,110
    Gender:
    Male
    Ratings:
    +2,384 / 21
    Home Country:
    Germany Germany
    Show System Specs
    You refer to the settings file - not the actual software code.

    My settings file does contain the ImdbIdRegex piece that you claim is not there in some of your installs. So 2.1pre and pre2 are installing this correctly.

    Given your incomplete settings file, reinstalling will not help unless you delete the setting file before attempting to reinstall.
     
  9. HTPCSourcer
    • Team MediaPortal
    • Administrator

    HTPCSourcer MP2 Product Manager

    Joined:
    May 16, 2008
    Messages:
    10,584
    Likes Received:
    1,110
    Gender:
    Male
    Ratings:
    +2,384 / 21
    Home Country:
    Germany Germany
    Show System Specs
    @JSchuricht , I have no explanation why the nfo settings file is incomplete on some of your systems. Did you maybe try weekly's in the past and then kept the settings when installing new versions?

    I understand that manually adding the missing lines cures your issue. In essence, I don't think that there is a fundamental problem with the package that we are deploying.
     
Loading...
Thread Status:
Not open for further replies.

Users Viewing Thread (Users: 0, Guests: 0)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
  • About The Project

    The vision of the MediaPortal project is to create a free open source media centre application, which supports all advanced media centre functions, and is accessible to all Windows users.

    In reaching this goal we are working every day to make sure our software is one of the best.

             

  • Support MediaPortal!

    The team works very hard to make sure the community is running the best HTPC-software. We give away MediaPortal for free but hosting and software is not for us.

    Care to support our work with a few bucks? We'd really appreciate it!