[solved] - A warning to anyone using a NAS for storing TV Recordings

Discussion in 'Television (MyTV frontend and TV-Server)' started by robbo100, September 27, 2015.

  1. robbo100
    • Premium Supporter

    robbo100 Retired Team Member

    Joined:
    May 5, 2009
    Messages:
    1,291
    Likes Received:
    285
    Gender:
    Male
    Occupation:
    Herding Cats
    Location:
    UK
    Ratings:
    +322 / 1
    Home Country:
    United Kingdom United Kingdom
    Show System Specs
    Hi all.

    I wanted to post my recent experience with my TV Server/NAS setup which caused me huge problems last week. Hopefully, by posting this, I will help someone else in the future having similar problems.

    I have my system setup with the TV Server configured to record everything to one of the volumes on my NAS (D-Link Share Centre DNS-345). Last week, my TV Server PC seemed to completely grind to a halt, taking ages to boot up and hanging when the TV Service tried to start. I initially thought this was a problem with the TV Service databases, but the logs weren't showing any exceptions and when I tried to open Windows 7 File Manager, it would also hang and File Manager just showed a blank window.

    This strange behaviour made me think that it was a hardware problem or a virus on the TV Server PC. So I spent ages doing memory check, virus checks (which showed nothing) and eventually did a complete reinstallation of Windows 7. Everything seemed to work really well, however, shortly after setting up MediaPortal again, I had the same problem!

    Anyway, to cut a long story short, it turned out that my NAS volume that holds the TV Recording was completely full. It seems that Linux (the OS that the NAS is based upon) doesn't cope with full volumes particularly gracefully and it was causing any attempts to access the volume to hang. Hence the failure of File Manager (because I had setup mapped drives) and TV Server to fail at startup when it tried to connect to the full volume.

    So, I wanted to post this to the community - if any of you are using a NAS for your recordings, please ensure you always keep a bit of space free, otherwise you may hit the same problem. This is obviously good house keeping, but I didn't realise the significant consequences of not doing so.

    As a side note, the web based NAS management system also completely stopped working because of the full volume, so I couldn't remove any content from the volume to fix the problem. Unfortunately, the linux file system used by the NAS "EXT2" isn't accessible natively from Windows, so you have two ways to resolve the problem:



    1) Remove the full disc from the NAS and put it into a linux machine (noting that since Linux won't deal with it gracefully, it still may be difficult to delete files from it).

    2) Remove the full disc from the NAS and put it into a Window PC, then install Ext2FSD which will allow you to access the volume (this was the route I took).​

    Cheers

    Robbo100[DOUBLEPOST=1443354668][/DOUBLEPOST]P.S. is it worth making this a sticky?
     
    • Informative Informative x 1
Loading...

Users Viewing Thread (Users: 0, Guests: 0)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
  • About The Project

    The vision of the MediaPortal project is to create a free open source media centre application, which supports all advanced media centre functions, and is accessible to all Windows users.

    In reaching this goal we are working every day to make sure our software is one of the best.

             

  • Support MediaPortal!

    The team works very hard to make sure the community is running the best HTPC-software. We give away MediaPortal for free but hosting and software is not for us.

    Care to support our work with a few bucks? We'd really appreciate it!