AC3/DTS through spdif possible w/ analog through line-out? (1 Viewer)

hansdegit

Portal Pro
May 18, 2005
200
0
48
Schagen, The Netherlands
Netherlands Netherlands
DMAN,

thanks for your patience.

My problem is that I am unsuccesful in pushing AC3 through spdif using iviaudio.ax, because "spdif" is grayed out in the codec properties page (via Radlight Filter Mgr). Should I care?

Therefore, I take it that I have to make these registry settings to enable SPDIF:

[HKEY_CURRENT_USER\Software\InterVideo\Common\AudioDec\MediaPortal]
"AUDIOCHAN"=dword:00000007
"AUDIO"=dword:00000006


Do I also need this one? Probably not, just to double-check.
[HKEY_USERS\S-1-5-21-(...)\Software\Intervideo\Common\AudioDec\MediaPortal]
"AUDIO"=dword:00000001
 

hansdegit

Portal Pro
May 18, 2005
200
0
48
Schagen, The Netherlands
Netherlands Netherlands
Hmm, the digital stream arrives at my receiver now. But no stereo output from the line-out.

I'll doublecheck whether ffdshow still has AC3 passtrough enabled.

[EDIT]
And it still had....

But, still no output on line-out. WTF am I doing wrong?
 

hansdegit

Portal Pro
May 18, 2005
200
0
48
Schagen, The Netherlands
Netherlands Netherlands
A brief history

OK, what have I tried?

- installed windvd7
- made a registry setting:[HKEY_CURRENT_USER\Software\InterVideo\Common\AudioDec\MediaPortal]
"AUDIOCHAN"=dword:00000007
"AUDIO"=dword:00000006
- installed and registered mpgaudio.ax (although that's not necessaryfor watching DVD's)
- disabled ffdshow codecs for EVERY audio-related feature (I'm very close to uninstalling ffdshow)
- instructed MP to use intervideo codecs for audio and navigation and dscaler for video.

And all I get is DTS through spdif, no sound through line-out.
Could this be a limitation of Realtek's ALC850 chipset?

More suggestions please!? This is driving me nuts..
 

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

Top Bottom