[Alpha 0.0.1.2] MPMovieInfo (1 Viewer)

H

hansenfred

Guest
Hello a tous , je suis un nouvel utilisateur de Media portal depuis quelques jours j'installe petit a petit ma divxbox ,
Je trouve Media portal vraiment super aucun problemes dans les modules de musique , photos , radios ....
le seul probleme que je rencontre c'est avec le nodule video , en fait pour tous les films que j'ai sur le disque dur pas de soucis ..
par contre j'ai de nombreux films en dvd et divx sur disque et ils sont tous actuellement chargé dans ant movie (j'avais avant basedivx mais il semble que cetait impossible de les integrer dans MP)
Donc j'ai tous mes titres de dvd et divx complets avec jacquette résumé etc....
J'ai essayé plusieurs fois d'enregistrer ma base en XML et avec MP movie info les intégrer dans MP !
J'ai essayé plusieurs fois avec la version 0.0..1.2 alpha en suivant le procédure suivante <a href="http://wiki.mediaportal-fr.com/doku.php?id...ces:mpmovieinfo" target="_blank">http://wiki.mediaportal-fr.com/doku.php?id...ces:mpmovieinfo</a>

J'ai bien pour commencer modifié le fichier MPMovieInfo.xml comme il est demandé , puis chargé le fichier XML via : fichier / Charger le catalogue XML , après ca il me dis que le catalogue a été bien chargé .

Puis je suis allé dans : outils / parametrage XML et j'ai bien mes fichiers de ma base Ant movie.
J'ai modifié juste la lectre de lecteur puis validé avec OK.

La je n 'ai toujours pas mes films de ma base dans l'interface de base , et je sais pas si c est normal , alors dans le doute j'ai quand meem continué en fesant : outils / Matchs files il m 'indique catalogue chargé , mais je n'ai toujours pas mes films affichés ?

J'ai ensuite sauvé la base er regardé dans MP si je voyais du changement et la aucun changement j'ai juste mes films en local sur mon disque dur ?

Quelqun a deja reussi a effectuer cette manipulation avec MP , MP movie info et Ant movie !
Ou dans me procédure j'ai oublié quelque chose ?

C'est le seul problème que j'ai rencontré avec MP si vous aviez une idée ou une piste merci d'avance .
 
H

hansenfred

Guest
Originally posted by Acteo@13 Oct 2005, 22:27
J'ai suivi le wiki. Faites l'essai et posez vos questions ici, j'essaierai de vous aider.
En gros :
1 - Configurer le fichier MPMovieInfo.xml suivant le type de catalogue
2 - renseigner un chemin et nom de fichier dans la base (obligatoire!)
3 - enregistrer le catalogue en xml
4 - importer dans MPMovieInfo
5 - faire coïncider les champs catalogue avec ceux de MPMovieInfo
6 - "matches files'
7 - enregister la base

a vous de jouer !
<div align="right"><{POST_SNAPBACK}>
[/quote]

Je me demandais a quelle manipulation correpondait ta phase 2 : Renseigner un chemin et nom de fichier dans la base ?
C est dans Ant movie ou c est MP movie info , c est peut etre ca qui me manque ??
 

Acteo

Portal Pro
August 15, 2005
203
14
43
Echiré, France
France France
Quand tu fais match files, tu devrais voir ta base se remplir.

Dans paramétrage xml, il faut faire correspondre les champs MP avec les champs AMC (par exemple : jaquette = picture, id = medialabel, synopsis = description...)

En effet ça vient peut être de l'étape 2 : dans AMC il faut mettre le chemin vers le fichier (soit sur disque dur C:/films/film.avi soit sur CD D:/film.avi...).
Personnellement j'ai choisi le champ résolution pour mettre cette info. Ensuite, dans MPMovieInfo/parametrage xml spécifier que le 'lien fichier'=resolution
 

Acteo

Portal Pro
August 15, 2005
203
14
43
Echiré, France
France France
Originally posted by dragon45@5 Nov 2005, 23:26
elle est super cette appli 


En suivant le wiki, tous se passe nickel pour importer une base MovieCollection le seul petit hic c'est que j'ai un bo message d'erreur quand je veux sauvegarder ma base

Aurais-je oublier quelque chose ?

<div align="right"><{POST_SNAPBACK}>
[/quote]

Alors que je disais (il y a quelques temps) que ça marchait impec chez moi, me voilà avec ce même message d'erreur (très explicite
)
J'ai eu une fois un coup de chance (en supprimant 1ou2 fiches qui avaient posé problème / message d'erreur) ça a fonctionné. Le lendemain j'ai rajouté un film et depuis la sauvegarde de la base plante sur ce message.

Je me demande si je ne vais pas passer à Movie Collection (un plugin vient de sortir).
 

Acteo

Portal Pro
August 15, 2005
203
14
43
Echiré, France
France France
Bonjour,
J'ai quand même continué mes investigations après le message d'erreur (j'aime pas que la machine gagne !
).
J'ai importé un peu moins de fiches...ça a marché.
Au fur et à mesure j'en ai rajouté..jusqu'à ce que ça plante.
En regardant le dernier film chargé j'ai pu identifier celui qui posait problème.

Il semble que MPMovieInfo n'aime pas trop les "-" et les noms trop longs (de fichiers ou de titres). Et quand une fiche avait planté, elle continuait à planter même une fois avec des noms + courts. Donc j'ai refait les fiches à problèmes sur un nouveau numéro en partant de rien et avec les corrections.
Et voilà j'ai tout réussi à charger !

Une remarque utile : vu que j'ai chargé, fait RAZ et sauvé la base de nombreuses fois, plus ça allait, plus MPMovieInfo ramait. En désinstallant et réinstallant ça résout ce problème.
 
F

fmelle

Guest
Originally posted by Acteo+19 Jan 2006, 13:35 --><div class='quotetop'>CITATION(Acteo @ 19 Jan 2006, 13:35 )</div>
<!--QuoteBegin-carreno
@23 Dec 2005, 00:23
Le dévellopement de ce logiciel continut-il?


<div align="right"><{POST_SNAPBACK}>
pareil !


les résultats de la Todo list m'intéresse au plus au point (pb des DVD)...
<div align="right"><{POST_SNAPBACK}></div>
[/b][/quote]

Bonjour à tous, je suis un des 2 développeurs qui a repris cet été le programme de yiark-yiark pour le porter vers le schéma de base de MP 1.3.

Au delà de ce portage, nous en avons profité pour faire qqs modifs afin de corrgier des bugs que nous avons identifiés sur notre type d'utilisation :
- AMC catalogue nos divx
- les divx sont sur disque
- on les importe dans la base MP

A ce jour, MPMovieInfo continue à fonctionner par rapport à notre utilisation avec la 2.0RC2. Aussi, nous n'avons pas de volonté de développer d'avantage de fonctionnalités.

Par contre, on pourrait (si yiark-yiark est OK) créer un site sourceforge pour y mettre MPMovieInfo et voir si d'autres développeurs veulent se mettre au développement sur les modules que nous n'utilisons pas :
- référencement de divx sur CDs/DVDs
- compatibilité DVD profiler

etc ...
 

Acteo

Portal Pro
August 15, 2005
203
14
43
Echiré, France
France France
Bonjour,

Merci pour ces précisions ! Et bravo pour cette application.
Est-ce que ça veut dire que vous ne corrigerez pas le bug (cf message d'erreur ci-dessus) ? Comme je l'ai dit plus haut j'ai fini par en venir à bout... mais ça reste rebutant pour un néophyte et cela limite l'utilisation de MPMovieInfo à un petit nombre de personnes. Ce qui est vraiment dommage.

L'idée de tendre la perche à d'autres développeurs est bonne !
 

Acteo

Portal Pro
August 15, 2005
203
14
43
Echiré, France
France France
Bonjour,
MPMovieInfo ne fonctionne plus depuis que j'ai installé la CVS d'hier soir. Il démarre mais de nombreux messages d'erreur s'affichent et la base est vide.
Les messages sont du genre : unable to write on a readonly database...
Quelqu'un a-t'il le même problème ?
 

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

Top Bottom