Another can't start Media Portal Post (1 Viewer)



Ok, I cant seem to figure it out. Just like the other posts that discuss startup issues, I get as far as "initializing directx" then nothing else comes up. Task manager shows that Media Portal is running.

In checking the other posts where this issue existed I have found the fix for them was reinstalling directx 9c or the .NET framwork (or that they didnt have it to start with). I have tried reinstallations to no avail (directx 9c reinstall takes like 1 sec.).

I have Windows XP sp2, a radeon 9800 graphics card (newest 5.1 catalist drivers-tried previous drivers as well) and hauppauge pvr150 tv card, on an AMD 2600 machine. Directx 9c 4.09.0000.0904 (verified by dxdiag) and .NET with Sp1 are installed as well as ffdshow, vobsub and other codecs and software that would be useful if I could get that far. OH yea, I have also tried reinstalling Media Portal

Here is what the Log says (I have never seen an error message):

1/29/2005 12:05:41 AM MediaPortal stopped due 2 an exception Object reference not set to an instance of an object. Microsoft.DirectX.Direct3D at Microsoft.DirectX.Direct3D.Manager.get_AdapterCount()
at Microsoft.DirectX.Direct3D.Manager.get_Adapters()
at MediaPortal.D3DEnumeration.Enumerate()
at MediaPortal.D3DApp.CreateGraphicsSample()
at MediaPortalApp.Main()

Obviously this is a Directx issue but as I said a reinstall does not seem to do anything and microsoft isnt exactally friendly about uninstalling directx so that it can be rinstalled and I dont really want to try 3rd party unstall utilities until I am out of other options.

Any ideas out there?



Retired Team Member
  • Premium Supporter
  • July 28, 2004
    Home Country
    New Zealand New Zealand

    1. Deleting MediPortal.xml file and then re-configure.
    2. Uninstalling the DirectX SDK if it is on your machine.
    3. Downloading the 'full' version of DirectX 9.0c and installing
    4. Try re-installing SP2 (again download the full version)



    Flip - The Resolution I use for my normal desktop on an HDTV is 856x480p @540p timings. If you have another recomended resolution, let me know and I'll just set up powerstrip for the resolution. I have also tried both windowed and full screen startup and same results with each.

    DMAN - Let me try your recos and I'll get back to the board on the results.



    Ok. I tried deleting and reconfiguring mediaprotal.xml - no change. Directx SDK is not on my machine (at least not in add/remove programs or regeditor) - strike two. The "full" version of directx 9c is what I had been using to reinstall but what the heck I tried it again - strike 3. Tried reinstalling "full" version of sp2, microsoft says it is the same version and would shut down the installer. Now I remember that my xp version already has it on the cd and does not allow an uninstall of sp2 as it is not listed in the add/remove programs and there is not a $uninstallsp2 folder to get to the uninstall wizard. I tried "fixing" xp with the installation disk but of course this led to the computer not even starting back up. Doing a little bit more research I found that the xp disk I had had only a beta version of sp2 on it (dont ask) so this may not of worked anyway.

    So, I am going to take some time to reinstall a fresh version of xp (after I extract my config files for some programs) and add a dedicated drive for media files. I'll be back to try Media Portal again. I cant stand the idea of using the "one size fits all" MCE program. Ive tried Meedio, and although it installs and runs without problem, I find it difficult to accept that I need to use plugins to do things the core program should handle. Thanks for the support so far.



    Alright. Media Portal works now. I installed MCE 2005 but am using it mainly for the wiindows xp operating system. Now I can compare Media Portal to MCE whenever I want. Thanks


    Portal Member
    March 6, 2006
    I have this problem as well, am attempting to update my directx to fix it... my issue with this problem is the way Media Portal handles it... ie very poorly.

    * I start up Media Portal's config, no mention of not meeting any reqirements.
    * I finish the config and start Media Portal to be greeted by the startup little splash thing, which says 'Initializing Directx', however then a popup with I assume an error message appears... except that it's UNDER the splash, and unable to be dragged into view. So I can't tell what the issue is at all.
    * I click the exposed OK button on the popup (all you can see of it), and another popup comes up UNDER the the splash. This one is large enough that the top is able to be grabbed and so you can pull it from under the splash and read that it's saying something along the lines that it's going to be using a software renderer and all is going to be bad.
    * Click ok to that and it says it's initializing the recorder (of which I don't have one)... and there it stays... no way to quit, and it's already removed my taskbar... such that when I kill the process from Task Manager I still have no taskbar until I restart the PC.

    Pretty darn terrible welcome to the program.

    I really hope it gets better... as it looks good from all accounts.


    Retired Team Member
  • Premium Supporter
  • February 23, 2005
    Home Country
    Australia Australia
    spoco2 said:
    ... as it looks good from all accounts.
    It is good - and it certainly isn't as difficult to install as you have encountered...

    If you are still having issues, please use the Support Template and post your MediaPortal.log file. There will be somebody in this wonderful MediaPortal community who will be able to help you.... :)


    Retired Team Member
  • Premium Supporter
  • December 7, 2004
    Adelaide, Australia
    Home Country
    spoco2, youll need to use the support template as it very much sounds like you either dont have the required hardware (gpu) or there is a mismatch of software installed.

    Users who are viewing this thread

    Top Bottom