Audio Delay Option stuttering issue (1 Viewer)

morpheus_xx

Lead Dev MP2
  • Team MediaPortal
  • March 24, 2007
    11,478
    7,014
    Germany Germany
    Country flag
    I've thought about doing something like that, but I'd prefer to do something 'automatic' that would work for other decoders/renderers as well (just haven't thought of a way to do it yet ;))

    @Eggert - attached is a new version of TsReader.ax, with automatic handling of the audio delay compensation - could you give it a try please ?

    (No need to change any registry settings - just replace the current TsReader with it)
    Please let me know when I should create an updated NuGet package. Should I try the new version inside MP2?
     

    Owlsroost

    Development Group
  • Team MediaPortal
  • October 28, 2008
    5,540
    5,038
    Cambridge
    United Kingdom United Kingdom
    Country flag
    I've thought about doing something like that, but I'd prefer to do something 'automatic' that would work for other decoders/renderers as well (just haven't thought of a way to do it yet ;))

    @Eggert - attached is a new version of TsReader.ax, with automatic handling of the audio delay compensation - could you give it a try please ?

    (No need to change any registry settings - just replace the current TsReader with it)
    Please let me know when I should create an updated NuGet package. Should I try the new version inside MP2?

    It should work OK in MP2 (so please try it).

    There is a small problem with it I know of, so you might want to hold off packaging it for MP2 at the moment, but it's up to you really - if you are happy with it that's fine with me :)
     

    morpheus_xx

    Lead Dev MP2
  • Team MediaPortal
  • March 24, 2007
    11,478
    7,014
    Germany Germany
    Country flag
    There is a small problem with it I know of, so you might want to hold off packaging it for MP2 at the moment, but it's up to you really - if you are happy with it that's fine with me :)
    I have this TsReader build running for some weeks now. I have some random stalls at beginning of playback and some sync issues that I could solve by seek back/forward. I'm not sure if the problems come from this build, but I will try to bundled one in next days.

    There is a small problem with it I know of, so you might want to hold off packaging it for MP2 at the moment, but it's up to you really - if you are happy with it that's fine with me
    Did you make more changes?
     

    Eggert

    MP Donator
  • Premium Supporter
  • May 23, 2005
    70
    6
    Hi Owlsroost,

    I just wanted to let you know that I updated my MP from 1.0.8 to 1.0.12 today and had the stuttering issue again even with a 50ms delay setting.
    I replaced the TsReader.ax with the file you posted here and it again fixed the issue.
    Has the fix not been implemented into the actual TsReader.ax version?

    Thanks!
    Eggert
     

    Owlsroost

    Development Group
  • Team MediaPortal
  • October 28, 2008
    5,540
    5,038
    Cambridge
    United Kingdom United Kingdom
    Country flag
    Hi Owlsroost,

    I just wanted to let you know that I updated my MP from 1.0.8 to 1.0.12 today and had the stuttering issue again even with a 50ms delay setting.
    I replaced the TsReader.ax with the file you posted here and it again fixed the issue.
    Has the fix not been implemented into the actual TsReader.ax version?

    Thanks!
    Eggert
    No, it hasn't yet (for various reasons).

    The v3.x.x.x versions of TsReader are not compatible with MP 1.11 and later versions - they may work but it's just luck...

    The latest dev version of TsReader for MP 1.12 (v4.1.0.15) is linked from the post here - https://forum.team-mediaportal.com/...tv-playback-rate-matching-for-testing.130394/
     

    Eggert

    MP Donator
  • Premium Supporter
  • May 23, 2005
    70
    6
    Hi,

    I updated to 4.1.0.15 now. Thanks for the hint. No stuttering issue. Great, thanks! :)

    Eggert
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    Sebastiii [WiP] Audio delay when using LAV Audio codec Area 51 - Testing Area 6
    Stephen O'Kane [SOLVED] TV Stream stuttering - both Video and Audio Watch / Listen Media 14
    M.Hulot MP plays in Internal Blu-ray-Player-mode always first audio stream not the one I chosen in settings General Support 1
    Golf4 TV-Records werden als Audio-Files importiert ? Allgemeines Support- und Diskussionsforum 0
    W [solved] Incorrect audio being reported Moving Pictures 4
    404 [solved] Live TV...video and audio freeze General Support 20
    ninja 12 Audio dropouts with Dolby / DTS watch/edit Videos 12
    bta489 [solved] DVB-T2 Recordings: Sometimes no Audio after muxing with mkvmerge Tools and other software 2
    T [solved] MP2 Switch off visualisation when listening to audio....PLEASE!!! General 23
    azzuro [fixed] [WIP MP2.3] - Audio files not imported to MP MediaPortal 2 18
    S Remote button to change audio and subtitle on / off General 10
    F Audio render and font error in my logs General Support 2
    R [solved] Command / Shortcut for changing subtitles or audio Archive 5
    K Multichannel audio and subtitles for TV not properly supported General Support 4
    Glith Audio out of sync after pause. Rewind 15sec gets it into sync again. MediaPortal 1 Talk 0
    C ARC Audio Renderer Changer: wo kann man es konfigurieren? Video & DVD 15
    joecrow No Audio after MP Start/Resume from Sleep General Support 0
    C Ability to browse videos and audio by folder General 2
    Lichloathe Offline audio content General 9
    G How best to get cover art for tracks to show up on the Audio Menu (Latest Added, Unplayed)? General 9
    Ralph Holmes Wrong audio source in TV General 1
    CyberSimian [Proposal] Audio description MediaPortal 1 10
    ge2301 [fixed] [MP2-807] Problem when switching player in PiP mode with audio files MediaPortal 2 32
    cladinshadows85 [solved] Audio playing mutiple times over video and crashing General 8
    H Live TV info OSD not displaying number of audio channels General Support 3
    Similar threads

























    Top Bottom