Audio dropouts watching live TV....perhaps with micro freezing of pic....?

Discussion in 'Television (MyTV frontend and TV-Server)' started by tonewheelkev, November 13, 2016.

  1. tonewheelkev

    tonewheelkev Portal Pro

    Joined:
    February 10, 2012
    Messages:
    355
    Likes Received:
    14
    Location:
    Leeds
    Ratings:
    +23 / 2
    Home Country:
    United Kingdom United Kingdom
    Show System Specs
    Running 1.15 final.....and very few oproblems for a while now.

    But....frequently noticing short audio dropout, perhaps accompanied by some picture freeze....but this is hard to see/confirm!!
    (AV processor momentarilly reverts to PCM)



    I've attached logs....perhaps someone has an idea.

    Kev
     
  2. Google AdSense Guest Advertisement



    to hide all adverts.
  3. mm1352000
    • Team MediaPortal

    mm1352000 Development Group

    Joined:
    September 1, 2008
    Messages:
    21,541
    Likes Received:
    4,752
    Ratings:
    +8,220 / 17
    Home Country:
    New Zealand New Zealand
    Hi Kev

    TsReader log says:
    [2016-11-13 00:26:07,355] [ 74d02f8] [23a8] - audPin : Audio to render late= 0.195
    [2016-11-13 00:26:07,674] [ 74d02f8] [23a8] - audPin : Audio to render late= 0.197
    [2016-11-13 00:26:07,978] [ 74d02f8] [ 77c] - Pause 195 mS renderer clock to match provider/RTSP clock, A/V = 0/18

    Bunch of questions...

    1. Does the problem only occur with TV?

    2. If yes, does the problem only affect certain channels?

    3. In your LAV audio codec settings, have you enabled the "auto A/V sync correction" setting?

    4. Have you tried increasing the buffering delay?
    https://forum.team-mediaportal.com/threads/experimental-tsreader-development.102693/#post-811296
    5. Have you tried this?
    https://forum.team-mediaportal.com/...tv-playback-rate-matching-for-testing.130394/

    6. Have you tried using UNC paths instead of RTSP?
    http://wiki.team-mediaportal.com/1_...ation/22_TV/Advanced_Options#Multi-seat_setup
     
  4. tonewheelkev

    tonewheelkev Portal Pro

    Joined:
    February 10, 2012
    Messages:
    355
    Likes Received:
    14
    Location:
    Leeds
    Ratings:
    +23 / 2
    Home Country:
    United Kingdom United Kingdom
    Show System Specs
    Thanks.....
    1.(...and 2.) Have only noticed problem on TV.....and only use HD channels!
    3. "auto A/V sync correction".....yes....enabled

    .....will take some time to look at 4., 5., and 6. though!!
     
  5. mm1352000
    • Team MediaPortal

    mm1352000 Development Group

    Joined:
    September 1, 2008
    Messages:
    21,541
    Likes Received:
    4,752
    Ratings:
    +8,220 / 17
    Home Country:
    New Zealand New Zealand
    Well, please try SD channels to get more information... and also try alternative audio streams (eg. stereo, surround, hearing impaired or description) if your channels have multiple audio streams.

    Another question...
    Has this problem been happening for some time?
    Problems don't just start for no reason. If you can remember when the problem started, that information may help to identify the cause.
     
  6. tonewheelkev

    tonewheelkev Portal Pro

    Joined:
    February 10, 2012
    Messages:
    355
    Likes Received:
    14
    Location:
    Leeds
    Ratings:
    +23 / 2
    Home Country:
    United Kingdom United Kingdom
    Show System Specs
    Went straight to 6., and deselected RTSP........20 minutes ago, and no probs so far!
    Don't recall why I ticked that option in the 1st place.....:oops:

    Problem had been occurring for some weeks now.....and was increasing in frequency.....sorry to admit that I can't recall starting point.

    I've attached fresh logs.....
     
  7. mm1352000
    • Team MediaPortal

    mm1352000 Development Group

    Joined:
    September 1, 2008
    Messages:
    21,541
    Likes Received:
    4,752
    Ratings:
    +8,220 / 17
    Home Country:
    New Zealand New Zealand
    RTSP is the default.

    In the interests of ensuring MP works with default options, we'd really appreciate it if you could try going back to RTSP and trying suggestion 5.
     
  8. tonewheelkev

    tonewheelkev Portal Pro

    Joined:
    February 10, 2012
    Messages:
    355
    Likes Received:
    14
    Location:
    Leeds
    Ratings:
    +23 / 2
    Home Country:
    United Kingdom United Kingdom
    Show System Specs
    Will do........looks complicated at 1st viewing.....but will have a go!

    Thanks:)
     
  9. mm1352000
    • Team MediaPortal

    mm1352000 Development Group

    Joined:
    September 1, 2008
    Messages:
    21,541
    Likes Received:
    4,752
    Ratings:
    +8,220 / 17
    Home Country:
    New Zealand New Zealand
    Cheers. :)
    It's not as complicated as it looks.
     
    • Like Like x 1
Loading...

Users Viewing Thread (Users: 0, Guests: 0)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
  • About The Project

    The vision of the MediaPortal project is to create a free open source media centre application, which supports all advanced media centre functions, and is accessible to all Windows users.

    In reaching this goal we are working every day to make sure our software is one of the best.

             

  • Support MediaPortal!

    The team works very hard to make sure the community is running the best HTPC-software. We give away MediaPortal for free but hosting and software is not for us.

    Care to support our work with a few bucks? We'd really appreciate it!