Audio issues with MKV Playback in MP2.1.3 (1 Viewer)

osre

Retired Team Member
  • Premium Supporter
  • December 14, 2014
    766
    386
    Germany Germany
    Country flag
    Hi,

    I have issues when I playback mkv files in MP2.1.3.
    The mkv files are created eather with MakeMKV as rips from DVD or BD with DD 5.1 or DTS 5.1, or created with VideoReDo from wtv (WMC SD and HD recordings) files without transcoding (except for the cuts).
    The files play fine with VLC player.
    But when I play them in MP2 on the same machine, I only hear sound from the center speaker (5.1 audio system is connected via toslink, Realtek onboard audio)
    I tried switching from LAV to MS video codecs and tried some different splitter options, but this does not make any difference.
    Sound in live TV in MP2 is also fine.

    Any ideas what could be wrong here, or what I can try?

    OS is WIn10x64 Fall Creators update, a relatively fresh install, where no other Software was installed before.
    MP2 isalso installed fresh, no other version was installed before.

    Thanks in advance,
    Reinhard.
     

    ge2301

    MP2 Design
  • Team MediaPortal
  • January 11, 2014
    6,703
    2,416
    Stuttgart
    Germany Germany
    Country flag
    I just realized, that I gave a “creative” rating for previous post. I never did that :confused: perhaps wrong click on mobile phone ...
     

    ge2301

    MP2 Design
  • Team MediaPortal
  • January 11, 2014
    6,703
    2,416
    Stuttgart
    Germany Germany
    Country flag
    Can you not pass the audio directly to receiver via HMDI? I understood you use onboard 5.1. I did that also once and had only trouble.
    As the codec makes no difference you could try to change the device in settings or install another driver. With Windows 10 MS found a way to kill drivers with every update, it’s worse than all things they did earlier ...
     

    osre

    Retired Team Member
  • Premium Supporter
  • December 14, 2014
    766
    386
    Germany Germany
    Country flag
    I just realized, that I gave a “creative” rating for previous post. I never did that :confused: perhaps wrong click on mobile phone ...
    And I was wondering what you ment :)
     

    osre

    Retired Team Member
  • Premium Supporter
  • December 14, 2014
    766
    386
    Germany Germany
    Country flag
    Next step is to pass Audio to TV via HDMI, and then from TV to receiver by TosLink, because for some reason my TV does not accept my receiver as Audio target via HDMI, even I used the ACR port on both !? 2nd TosLink cable is already on my desk, just need some time again.
     
    Last edited:

    osre

    Retired Team Member
  • Premium Supporter
  • December 14, 2014
    766
    386
    Germany Germany
    Country flag
    So I switched from PC/realtek->TosLink->Receiver
    to PC->HMDI->TV->TosLink->Receiver and now sound works as expected.
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    Cowboy [solved] MP1.20 issue with HD audio stream (not all media) watch/edit Videos 6
    Stephen O'Kane [SOLVED] TV Stream stuttering - both Video and Audio Watch / Listen Media 14
    M.Hulot MP plays in Internal Blu-ray-Player-mode always first audio stream not the one I chosen in settings General Support 1
    Golf4 TV-Records werden als Audio-Files importiert ? Allgemeines Support- und Diskussionsforum 0
    W [solved] Incorrect audio being reported Moving Pictures 4
    404 [solved] Live TV...video and audio freeze General Support 20
    ninja 12 Audio dropouts with Dolby / DTS watch/edit Videos 12
    bta489 [solved] DVB-T2 Recordings: Sometimes no Audio after muxing with mkvmerge Tools and other software 2
    T [solved] MP2 Switch off visualisation when listening to audio....PLEASE!!! General 23
    azzuro [fixed] [WIP MP2.3] - Audio files not imported to MP MediaPortal 2 18
    S Remote button to change audio and subtitle on / off General 10
    F Audio render and font error in my logs General Support 2
    R [solved] Command / Shortcut for changing subtitles or audio Archive 5
    K Multichannel audio and subtitles for TV not properly supported General Support 4
    Glith Audio out of sync after pause. Rewind 15sec gets it into sync again. MediaPortal 1 Talk 0
    C ARC Audio Renderer Changer: wo kann man es konfigurieren? Video & DVD 15
    joecrow No Audio after MP Start/Resume from Sleep General Support 0
    C Ability to browse videos and audio by folder General 2
    Lichloathe Offline audio content General 9
    G How best to get cover art for tracks to show up on the Audio Menu (Latest Added, Unplayed)? General 9
    Ralph Holmes Wrong audio source in TV General 1
    CyberSimian [Proposal] Audio description MediaPortal 1 10
    ge2301 [fixed] [MP2-807] Problem when switching player in PiP mode with audio files MediaPortal 2 32
    cladinshadows85 [solved] Audio playing mutiple times over video and crashing General 8
    H Live TV info OSD not displaying number of audio channels General Support 3
    Similar threads

























    Top Bottom