audio not synced, stutter problems when refreshrate is 24hz (1 Viewer)

fanoI

Portal Pro
December 26, 2006
121
1
I hoped it was (miraculously) solved in the new version... but nothing :rolleyes:

What we have to do, now?

I'm using reclock to do PAL-spedup but it's pretty stupid having a 24p TV :D
 

nickyat

Portal Member
April 19, 2008
8
1
Kursk
Russian Federation Russian Federation
TV-Server Version: 1.0.1 Disaster Edition
MediaPortal Version: 1.0.1 Disaster Edition
MediaPortal Skin: Blue 3 Wide
Windows Version: Windows XP SP3
CPU Type: AMD CPU Athlon 64 X2 4850E
HDD: 2xWD 1Tb GP+4Gb NAS,Memory: SEC 2 GB, PC6400, 800 MHz
Motherboard: GIGABYTE GA-MA78GM-S2H
Video Card: ATI ASUS 4350
Video Card Driver: 9.3
Sound Card: Integrated
Sound Card AC3: Integrated
MPEG2 Video Codec: Cyberlink PowerDVD 8
MPEG2 Audio Codec: AC3Filter
h.264 Video Codec: Cyberlink PowerDVD 8,CoreAVC, MPC
TV Card: SkyStar S2-3200
Renderer: VMR9
TV: Sharp LC-37XL8RU via 3m HDMI noname cable
+Ext Reciver Pioneer VSX-417 via TOS link
+Epson EMP-680 720p projector

I not have any problems with a/v sync in all 24p content I have (over 3Tb);
I use ATI profiles for switch refresh rate as external cmd
Just for informaton.
 

lldaedalusll

Portal Member
April 29, 2009
5
0
Germany Germany
Hi all,

all of you say, that the 24 fps (or 23,976) problems are gone if you no more have 24hz. But when I switch to 50hz and play my 23,976fps files, they are still out of sync when using MP. I do not use any speedup tools like reclock or whatever and I do not expect 23,976 fps material to be smooth without stutter at 50hz, but it should be in sync, doesn't it?

Right now I got the idea, that I did not try 60hz with my 23,976fps material (60hz seems to be the "safe" mode here), but 50hz should work to I think.

MP 1.0.1
Renderer: EVR
Video Filter: ffdshow
Audio Filder: ffdshow
Audio output: direct sound
Vista SP1 x64
Athon X2 5050e
ATI HD 3200
 

sintei

Portal Member
December 13, 2007
39
2
radeon 3200HD integrated
Projector capable of 24Hz
Output is spdif
Vista SP1 x32
Renderer EVR

When i set desktop to 24Hz the projector switches mode and displays 24Hz.
Starting MP 1.0.1.0 in 24Hz mode makes everyting stutter. Even live TV is stuttering (and very Jumpy)
Setting desktop to 60Hz makes everything smooth again (projector switches mode and displays 60Hz).
Using "shift+1" MP reports correct Hz as above.
Using the refreshrate changer doesnt change anything. Even if i use force. It will still use desktop refreshrate.
However, it "feels" like the refreshrate changer makes 24Hz movies play smoother in 60Hz if its on versus its off (!).

tested codecs: Microsofts mpeg, mpc, ffdshow, powerdvd9, coreavc
 

CypherMK

Test Group
  • Team MediaPortal
  • March 11, 2009
    1,735
    617
    Netherlands Netherlands
    Country flag
    This is really the biggest problem imo. I hope it gets fixed soon. If this is solved, mediaportal is almost perfect!! I'm running 1.02.
     

    tourettes

    Retired Team Member
  • Premium Supporter
  • January 7, 2005
    17,301
    4,800
    This is really the biggest problem imo. I hope it gets fixed soon. If this is solved, mediaportal is almost perfect!! I'm running 1.02.
    I still haven't received any 24Hz display device as a donation so it's not possible at least for me to debug the issue :p (no, I won't even think about using the HTPC + beamer combination to debug...).
     

    tourettes

    Retired Team Member
  • Premium Supporter
  • January 7, 2005
    17,301
    4,800
    When i set desktop to 24Hz the projector switches mode and displays 24Hz.
    Starting MP 1.0.1.0 in 24Hz mode makes everyting stutter. Even live TV is stuttering (and very Jumpy)
    Of course the live tv wills stutter with 24hz, I know no country where the tv stream would be 24hz. So you will be getting stuttering as source material fps and display device hz doesn't match.
     

    seco

    Development Group
  • Team MediaPortal
  • August 7, 2007
    1,580
    1,236
    Finland Finland
    Country flag
    Greetings.

    I just got 1.0.2 running fine and noticed this problem too.

    I've been using refresh rate changer and 24Hz mode before but audio is out of with MPC Homecinema H.264 decoder. I only play .mkv movies.

    With CoreAVC I haven't had any stuttering or out of sync problems but I had to turn Aero ON, otherwise I get really massive stuttering about 15 seconds interval.

    My system specs are on the left.
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    Glith Audio out of sync after pause. Rewind 15sec gets it into sync again. MediaPortal 1 Talk 0
    A Audio sync problems on LAV filters 1.21 Pre Release 31
    Stephen O'Kane [SOLVED] TV Stream stuttering - both Video and Audio Watch / Listen Media 14
    M.Hulot MP plays in Internal Blu-ray-Player-mode always first audio stream not the one I chosen in settings General Support 1
    Golf4 TV-Records werden als Audio-Files importiert ? Allgemeines Support- und Diskussionsforum 0
    W [solved] Incorrect audio being reported Moving Pictures 4
    404 [solved] Live TV...video and audio freeze General Support 20
    ninja 12 Audio dropouts with Dolby / DTS watch/edit Videos 12
    bta489 [solved] DVB-T2 Recordings: Sometimes no Audio after muxing with mkvmerge Tools and other software 2
    T [solved] MP2 Switch off visualisation when listening to audio....PLEASE!!! General 23
    azzuro [fixed] [WIP MP2.3] - Audio files not imported to MP MediaPortal 2 18
    S Remote button to change audio and subtitle on / off General 10
    F Audio render and font error in my logs General Support 2
    R [solved] Command / Shortcut for changing subtitles or audio Archive 5
    K Multichannel audio and subtitles for TV not properly supported General Support 4
    C ARC Audio Renderer Changer: wo kann man es konfigurieren? Video & DVD 15
    joecrow No Audio after MP Start/Resume from Sleep General Support 0
    C Ability to browse videos and audio by folder General 2
    Lichloathe Offline audio content General 9
    G How best to get cover art for tracks to show up on the Audio Menu (Latest Added, Unplayed)? General 9
    Ralph Holmes Wrong audio source in TV General 1
    CyberSimian [Proposal] Audio description MediaPortal 1 10
    ge2301 [fixed] [MP2-807] Problem when switching player in PiP mode with audio files MediaPortal 2 32
    cladinshadows85 [solved] Audio playing mutiple times over video and crashing General 8
    H Live TV info OSD not displaying number of audio channels General Support 3
    Similar threads

























    Top Bottom