Audio Renderer Changer | Page 31

Discussion in 'MediaPortal 1 Plugins' started by Thor2605, May 19, 2010.

  1. sover

    sover Portal Pro

    Joined:
    April 11, 2008
    Messages:
    163
    Likes Received:
    12
    Gender:
    Male
    Ratings:
    +24 / 1
    Home Country:
    Russian Federation Russian Federation
    1.13 of course ))



    I have the same action to change renderer of media and bass engine (ACTION_SHOW_VOLUME)
    Please show me your settings, maybe problem is my setup
     
  2. Google AdSense Guest Advertisement



    to hide all adverts.
  3. mm1352000
    • Team MediaPortal

    mm1352000 Development Group

    Joined:
    September 1, 2008
    Messages:
    21,518
    Likes Received:
    4,729
    Ratings:
    +8,195 / 17
    Home Country:
    New Zealand New Zealand
    You said "MP1.3" in your previous post. I guessed that was a mistake, but I had to double check.

    Please provide full debug log files:
    1. Use the MP Watchdog tool with option 2 ("report a bug to a plugin developer or skin designer") to start MP.
    2. Reproduce whatever problem you have using the OV plugin.
    3. Close MediaPortal.
    4. Attach the zip file created by the Watchdog tool.
     
  4. sover

    sover Portal Pro

    Joined:
    April 11, 2008
    Messages:
    163
    Likes Received:
    12
    Gender:
    Male
    Ratings:
    +24 / 1
    Home Country:
    Russian Federation Russian Federation
    Thank you. I'll do this later at home and post log files.
     
  5. sover

    sover Portal Pro

    Joined:
    April 11, 2008
    Messages:
    163
    Likes Received:
    12
    Gender:
    Male
    Ratings:
    +24 / 1
    Home Country:
    Russian Federation Russian Federation
    Here i am ) with logs
     

    Attached Files:

    • arc.jpg
      arc.jpg
      File size:
      122.4 KB
      Uploaded:
      January 28, 2016
      Views:
      73
  6. mm1352000
    • Team MediaPortal

    mm1352000 Development Group

    Joined:
    September 1, 2008
    Messages:
    21,518
    Likes Received:
    4,729
    Ratings:
    +8,195 / 17
    Home Country:
    New Zealand New Zealand
    To me it looks like your first problem is with OV. From the MPUrlSourceSplitter log:
    Same for both videos.
     
    Last edited: January 28, 2016
  7. mm1352000
    • Team MediaPortal

    mm1352000 Development Group

    Joined:
    September 1, 2008
    Messages:
    21,518
    Likes Received:
    4,729
    Ratings:
    +8,195 / 17
    Home Country:
    New Zealand New Zealand
    ...and for the BASS problem, I think your ARC config is wrong. You need to use a different action/key configuration for DirectShow and BASS. Can't use ACTION_SHOW_VOLUME for both.
     
  8. sover

    sover Portal Pro

    Joined:
    April 11, 2008
    Messages:
    163
    Likes Received:
    12
    Gender:
    Male
    Ratings:
    +24 / 1
    Home Country:
    Russian Federation Russian Federation
    Thanks for reply
    May be problem with the latest version of OnlineVideos with my setup (Win10) - i`ll try to test another (older) version of OV
    I have tried to use different actions for BASS and DShow with no effect. When i press button while playing music MP freeze at 2-3 seconds but sound not go to next renderer.
    Please post the screenshot of your working settings for ARC
     
  9. mm1352000
    • Team MediaPortal

    mm1352000 Development Group

    Joined:
    September 1, 2008
    Messages:
    21,518
    Likes Received:
    4,729
    Ratings:
    +8,195 / 17
    Home Country:
    New Zealand New Zealand
    Well, this is different (better?) than in the previous log files, which show that ARC was not trying to change the renderer at all.
    Please provide new log files showing what happens when you define a different action.
     
    • Like Like x 1
  10. sover

    sover Portal Pro

    Joined:
    April 11, 2008
    Messages:
    163
    Likes Received:
    12
    Gender:
    Male
    Ratings:
    +24 / 1
    Home Country:
    Russian Federation Russian Federation
    Hi. I have done some test on weekend and resolve my problem with ARC and BASS engine.
    To correct renderer change it migt be different actions (SHOW_OSD and SHOW_VOLUME in my case) and right settings of MCE remote.
    Thanks all for advice.
    Bug with stopping playback on render change in OnlineVideos is not gone. But this is no ARC bug.
    upload_2016-2-1_9-20-15.png
     
  11. mrspock

    mrspock Portal Pro

    Joined:
    September 14, 2008
    Messages:
    124
    Likes Received:
    20
    Gender:
    Male
    Location:
    Madrid
    Ratings:
    +33 / 0
    Home Country:
    Spain Spain
    Show System Specs
    Hi. Thanks to @Nephilim for keep updating this plugin.
    I wish to give another try to this plugin... but again, not luck :(
    Now, the last version does run in MP 1.13, and it does change devices (both video and bass). My devices are HDMI and SPDIF.
    BUT when playing a video with AC3 sound, it does not output Dolby Digital 5.1 sound through SPDIF but stereo. o_O
    (Changing the device in Windows I do obtain 5.1 sound.)

    BTW, when changing the device, the OSD always says the same device, regardless the device used to output the sound.

    I have tried different configurations with no success.

    I'm attaching logs and a copy of my configuration. The steps were: Start MP and go to videos, select a 5.1 sound movie, play it during about 10s through HDMI, then pressed key to get sound trough SPDIF during 10s (stereo, no DD5.1), and then back to HDMI, stop video and exit MP.

    Thanks
     

    Attached Files:

    • ARCcfg.png
      ARCcfg.png
      File size:
      96.7 KB
      Uploaded:
      February 14, 2016
      Views:
      78
Loading...

Users Viewing Thread (Users: 0, Guests: 0)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
  • About The Project

    The vision of the MediaPortal project is to create a free open source media centre application, which supports all advanced media centre functions, and is accessible to all Windows users.

    In reaching this goal we are working every day to make sure our software is one of the best.

             

  • Support MediaPortal!

    The team works very hard to make sure the community is running the best HTPC-software. We give away MediaPortal for free but hosting and software is not for us.

    Care to support our work with a few bucks? We'd really appreciate it!