Aufnahmen in Mepo fehlerhaft, bin am verzweifeln, bitte bitte helft mir... (1 Viewer)

mp739em2q

Portal Member
January 6, 2012
7
0
Hi Leute, ich habe vor 6 Jahren mit Mepo angefangen, es hat nie zu 100% geklappt. Seit einem Jahr arbeite ich intensiv daran, dass alles funktioniert. Tut es auch so gut wie, nur meine Aufnahmen sind ständig fehlerhaft (schneide mit VideoRedo und nach einem Quickstream werden einem die Fehler angezeigt).

Zunächst bin ich deswegen von DVB-T auf DVB-S umgestiegen. Was ich allerdings nicht wieder rückgängig machen will. Aber keine Besserung.

Dann habe ich angefangen an Hand vielfacher Beiträge hier im Forum meine Einstellungen in Mepo zu verändern: andere Codecs probiert, sämtliche Codeceinstellungen ausprobiert, RTSP über debugoptions getestet, und was es sonst noch alles zu verstellen gibt. Keine Besserung.

Danach habe ich angefangen das Problem in Windows zu suchen: Firewall, Bitdefender, WindowsSearch, Indexsuche ausgeschaltet, unnötige Aufgabenplanungen gelöscht, usw. Keine Besserung.

Dann bin ich etwas tiefer ins System gegangen und habe mein Betriebssystem von IDE auf AHCI umgestellt, weil ich nun die Festplatte in Verdacht hatte. Keine Besserung.

Als nächstes hätte ich mir eine neue Festplatte kaufen wollen, da hier im Forum von Problemen mit den Wester Digital Cavier Greens berichtet wird.

Aber dann dachte ich mir jetzt teste ich mal eine Zeit lang, ob die Aufnahmen auch fehlerhaft sind, wenn ich über die mitgelieferte Software aufnehme (TBSViewer) und nicht mit MediaPortal. Und seither - ca. 1 Woche - keine Fehler mehr in Aufnahmen :) Dann muss das Problem doch irgendwie, irgendwo in MePo liegen oder? Ich würde nur ungern auf Mepo verzichten, vorallendingen weil jetzt ansonsten alles super läuft, aber die Aufnahmen sind mit Mepo für mich unbrauchbar.

Leute könnt ihr mir sagen wodran es liegen könnte? Es hat nämlich inzwischen schon viiiiel zu viel Zeit gekostet. Ich hoffe dass es bald funktioniert...

Vielen, vielen Dank, an diejenigen die sich darauf einlassen mir Hilfestellung zu geben :)
und auch ein Dank an die Entwickler die so viel Arbeit in dieses Projekt stecken ;-)

PS.: Heute die 1.3.0 RC installiert leider auch keine besserung.
 

Holzi

Super Moderator
  • Team MediaPortal
  • April 21, 2010
    7,934
    2,235
    Ba-Wü
    Home Country
    Germany Germany
    Was genau bedeutet fehlerhaft? Habe auch manchmal kleine Bildfehler in den Aufnahmen (ca. 2 pro Stunde), komischerweise bei anderen Aufnahmen aber auch wieder nicht. Bei LiveTV ist alles top.
    Stört mich aber auch nicht sonderlich da ich die Aufnahmen meist sowieso gleich nach dem anschauen wieder lösche und nichts archivieren will. Nutze DVB-C mit USB TV Karte.
     

    HTPCSourcer

    Retired Team Member
  • Premium Supporter
  • May 16, 2008
    11,419
    2,337
    Home Country
    Germany Germany
    VideoRedo findet praktisch immer Fehler in den Aufnahmen. Du solltest in den Optionen von VideoRedo auf jeden Fall "ignorieren" von Audio/Video-Fehlern anklicken. Tust du das nicht, schneidet VideoRedo riesige Stücke aus dem File heraus: das Resultat ist absolut unbrauchbar.

    Die Aufnahmen von MePo sind nichts anderes als ein Mitschneiden des von der TV-Karte gelieferten MPEG-Streams. Es findet dabei keine Verarbeitung statt, so daß alle "Fehler" bereits vom Rohsignal geliefert werden. Ein absolut fehlerfreier Stream ist mir bisheer nur selten begegnet. In der Praxis ist das aber nicht relevant - man sieht sie nicht. Was Quickstream dir hier auswirft, ist eine Verschlimmbesserung. Lass dich also nicht von den wenigen gefundenen Audio/Video-Sync-fehlern im Summary-Screen von VideoRedo beeindrucken, sondern stelle in den Einstellungen "ignorieren" ein.

    Gruß, HTPC_Sourcer
     
    Last edited:

    radical

    Portal Pro
    December 16, 2010
    1,466
    191
    Home Country
    Germany Germany
    Hallo Leidensgenosse.
    Ja, die TBS-Karten sind im Zusammenhang mit Mediaportal ganz schön zickig.
    Mir sind öfters Discontinuities im Ts-Writer.log bei dir aufgefallen. Meiner Meinung nach, sind diese zum Teil auf andere gleichzeitig laufende Windows-Programme oder Prozesse zurückzuführen.
    Als Beispiel nenne ich jetzt mal die Unterbrechungen um 22:56 als TV-Movie-Clickfinder die aktuellen EPG-Daten aus dem Internet geladen hat.
    Selbst die Nutzung des zweiten Tuners, scheint solche Unterbrechungen hervorzurufen.
    Ähnliches konnte ich auch bei mir häufiger beobachten. Ob ich da vielleicht zuviel hineininterpretiere, müssen andere TBS-Kartenbesitzer (im speziellen die 6981) beurteilen.
    Vielleicht äußert sich @D3ltoroxp mal dazu ob er ähnliches bei sich feststellen kann.

    Für mich steht jedenfalls fest, wenn eine Aufnahme fehlerfrei bleiben soll, muss ich die Finger vom TV-Server lassen. Was in deinem Fall als Single-Seat warsscheinlich schwierig sein dürfte.

    Leider kann ich als Lösung nicht mehr anbieten. Weder unterschiedliche Treiber, div. alternative DLL's die hier für die TBS Karten angeboten werden noch Konfigurationsanpassungen haben dieses Verhalten beendet. Höchstens abgeschwächt.
     

    The_Stig

    Retired Team Member
  • Premium Supporter
  • April 5, 2005
    2,176
    428
    Ja, die TBS-Karten sind im Zusammenhang mit Mediaportal ganz schön zickig.
    Das ist dann doch ein bisschen sehr verallgemeinert. Meine TBS 6981 läuft sowas von stabil und schnell, ohne jegliche Probleme und das ohne besondere Patches, seit 1.3 Beta und RC (vorher hatte ich sie auch nicht, daher kann ich 1.2-er MP-Version nicht beurteilen).
     

    radical

    Portal Pro
    December 16, 2010
    1,466
    191
    Home Country
    Germany Germany
    Auch wenn es so klang, ich wollte nicht der TV-Karte den "Schwarzen Peter" zuschieben, deswegen auch der folgende Hinweis:
    Ob ich da vielleicht zuviel hineininterpretiere, müssen andere TBS-Kartenbesitzer (im speziellen die 6981) beurteilen.
    Es mag auch an einer allgemeinen instabilität in meinem System liegen.
    Ich wollte jedoch nur drauf hinweisen, dass ich im meinem Fall Unterbrechungen im Stream immer auf andere laufende Prozesse zurückführen kann. Vielleicht ist es beim Threadersteller ähnlich.
     

    HTPCSourcer

    Retired Team Member
  • Premium Supporter
  • May 16, 2008
    11,419
    2,337
    Home Country
    Germany Germany
    Im Ereignisprotokoll fehlen Discontinuities des Streams - der ist also m. E. OK. Das scheint, wenn überhaupt, eher mit der Festplatte und dem Timeshift-File zusammenzuhängen. Die üblichen Verdächtigen scheinen ja abgeschaltet zu sein.

    Man kann versuchen, den Dingen auf die Spur zu kommen, in dem MP im Fenstermodus ausgeführt wird, während daneben der Ressourcenmonitor mitläuft. Taucen die Probleme denn auch im Live-TV auf? Wenn nein, wäre das noch unverständlicher, denn es gibt eigentlich keinen Unterschied zwischen einer Aufnahme und dem Anschauen des Timeshift-Files.
     

    radical

    Portal Pro
    December 16, 2010
    1,466
    191
    Home Country
    Germany Germany
    Vorm Schneiden unterziehe ich meine HD-Aufnahmen immer einer Behandlung durch den TS-Doctor

    Danke, ich weiß es ist ein gut gemeinter Rat, hat aber mit dem eigentlichen Problem nix zu tun.

    @HTPC_Sourcer
    Sorry wenn ich blöd nachfrage, aber wo außer im TSWriter-File findet man noch Discontinuities aufgeführt?
     

    HTPCSourcer

    Retired Team Member
  • Premium Supporter
  • May 16, 2008
    11,419
    2,337
    Home Country
    Germany Germany
    Normalerweise im Ereignis-Protokoll von Windows. Da steht aber nichts. Ins TSWriter hatte ich vorhin aber nicht reingeschaut, muss ich nochmal gucken...
     

    Users who are viewing this thread

    Top Bottom