Automatically start/stop your Yamaha AVR with Mediaportal (1 Viewer)

allanp81

Portal Pro
October 24, 2006
917
41
Just tried this and although it switches my amp off (RX-V673) it doesn't seem to want to turn it on for some reason.
 

Terra

Portal Pro
August 25, 2009
230
56
Austria Austria
Country flag
Just tried this and although it switches my amp off (RX-V673) it doesn't seem to want to turn it on for some reason.
Have you enabled the Network Standby on your Receiver? This only works if this function is switched on and the receiver waits for commands in standby
 

allanp81

Portal Pro
October 24, 2006
917
41
I haven't shall try it now...

Works! thanks! Now to work out how to make it switch off when I shutdown my htpc...
 

Terra

Portal Pro
August 25, 2009
230
56
Austria Austria
Country flag
I haven't shall try it now...

Works! thanks! Now to work out how to make it switch off when I shutdown my htpc...
Good to hear :)
I have never trie this, but according to some pages you need to put a script in this folder o_O
%SYSTEMROOT%\System32\GroupPolicy\Machine\Scripts\Shutdown
 

AdmiralRaccoon

New Member
November 22, 2011
5
0
31
Hi, I stumbled over this threat when I was searching exactly for something like this.
I wonder if it´s possible add the functionality to set an specific Input channel (AV1, AV2, etc) when starting up?
 

Terra

Portal Pro
August 25, 2009
230
56
Austria Austria
Country flag
Hi,

It is definitely possible. Basically everything you can do in the Smartphone App can be send as a command to the Receiver. Actually I wanted to create a plugin for MP to control all those actions put I could not find the time. The SOAP request you want to send for setting the input looks like this:

<?xml version="1.0" encoding="utf-8"?>
<YAMAHA_AV cmd="PUT"><Main_Zone><Input><Input_Sel>AV1</Input_Sel></Input></Main_Zone></YAMAHA_AV>

Terra
 

nabbwp

New Member
May 2, 2017
1
0
Australia Australia
Hi Terra,

I have tried your script for turn on my Yamaha V481 receiver and it worked with minor changing but it is not working for turning off my amp??

Could you please help me.

I have feeling that I am missing something there.

Please check the files attached.

Thanks,
Nabeel
 

Attachments

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

OP Similar threads Forum Replies Date
S TV-Server MP1 - Automatic search doesn't work Installation, configuration support 2
vapourEyes Automatically Re-Tune Periodically Improvement Suggestions 1
vapourEyes Automatically Tune to Strongest Duplicate Channel Improvement Suggestions 106
W [solved] [FIXED] Survivor season 40 not automatically matching My TVSeries 1
G Switch to new channel at begining of program automatically Feature Requests 0
C How do I get MediaPortal to separate recording files by channel and month? General 2
H MP1.21F video database scan, can it be scheduled to automatically run in background General Support 5
Steve.Rayner61 Online Videos - Automatic Updates fails 'Automatic update disabled. Check your internet connection' OnlineVideos 10
greybox 1.20 final does not update video duration automatically 1.20 10
greybox 1.20 final does not update video duration automatically 1.20 Pre Release 1
D Getting Started General Support 30
horned_reaper [Music] 5012: Start current music track from the beginning Improvement Suggestions 37
T [solved] Green Button start MP not working....but box ticked in config. General Support 1
W [solved] MP suddenly Crashes when starting live TV on most channels and on recordings from the same channels General Support 20
W [solved] MP suddenly Crashes when starting live TV on some channels and on some recordings Television (MyTV frontend and TV-Server) 1
vvulture UNKNOWN ERROR when starting live TV General Support 6
ajs Trakt error when start with MP crash Trakt 1
F Recording starts at second time only MediaPortal 1 Talk 6
tano_grasa Movie cover not showing when starting a movie aMPed 0
ajs [solved] 4982: Why this error hard stop when Mediaportal start? MediaPortal 1 3
joecrow AMD Radeon Settings app. won't start after hibernation. General Support 0
Icaro Close MP when the external player is started General Support 13
M MP1 stops responding after Starting Plugins General Support 14
joecool70 Fehlermeldung Error invoking action "Start Timeshift" Allgemeines Support- und Diskussionsforum 1
P MP2 TV Server crashes when starting - throws error remoting exception General 2
Similar threads

























Top Bottom