BBC iPlayer (UK) (1 Viewer)

joecrow

Test Group
  • Team MediaPortal
  • August 9, 2012
    1,639
    1,233
    Germany Germany
    Country flag
    Confirm ITV Live is working again and the logos are back.:)(y)(y)(y)

    Many thanks
     
    Last edited:

    dr_torch

    Portal Member
    October 10, 2007
    48
    14
    Ottawa, ON
    Canada Canada
    Country flag
    @joecrow @dr_torch
    I have pushed a partial fix for ITV Player and fixed the channel logos.
    There are a few videos here and there that don't seem to have a playable rtmp stream, so they won't work...yet.
    Thank you. I can confirm that some videos are working, but others are still failing. I have not had a chance to look at the logs yet, but I can pull them for you later tonight if that would help you?
     

    Brownard

    Development Group
  • Team MediaPortal
  • March 21, 2007
    1,953
    1,307
    United Kingdom United Kingdom
    Country flag
    Yes can do if you want. It seems that they are phasing out the old flash/rtmp streams as ITV just returns a 'content not available on this platform' message for some videos.
    Hopefully I can get the iPad streams to work as these still seem to be available for all videos.
     

    dr_torch

    Portal Member
    October 10, 2007
    48
    14
    Ottawa, ON
    Canada Canada
    Country flag
    Yes can do if you want. It seems that they are phasing out the old flash/rtmp streams as ITV just returns a 'content not available on this platform' message for some videos.
    Hopefully I can get the iPad streams to work as these still seem to be available for all videos.
    Yes, certainly I can do that. I do not think we are in the same timezone. I'm in UTC-5, across the pond in Canada. I'm going to assume you are in the UK?

    I'm just letting you know as it will be quite late your time by the time I get the logs.

    And before somebody asks the obvious question - I have a VPN link back to a UK IP.
     

    dr_torch

    Portal Member
    October 10, 2007
    48
    14
    Ottawa, ON
    Canada Canada
    Country flag
    Here you go

    [05-02 18:39:56,303] [OnlineVideos] [DEBUG] GetWebData-GET: 'Coronation Street - Wednesday 11 Apr 7.30pm'
    [05-02 18:39:56,455] [OnlineVideos] [DEBUG] ITVPlayer: Found production id '1/0694/9427#001'
    [05-02 18:39:57,453] [OnlineVideos] [DEBUG] ITVPlayer: Playlist response:
    <s:Envelope xmlns:s="http://schemas.xmlsoap.org/soap/envelope/"><s:Body><GetPlaylistResponse xmlns="Bing"><GetPlaylistResult><Fault xmlns=""><faultcode>InvalidEntity</faultcode><faultstring>Video production has no renditions for DotCom platform.</faultstring></Fault></GetPlaylistResult></GetPlaylistResponse></s:Body></s:Envelope>
    [05-02 18:39:57,454] [OnlineVideos] [WARN ] ITVPlayer: Could not find video entry
    [05-02 18:39:57,469] [MPMain ] [DEBUG] Removed invalid url: ''
    [05-02 18:40:07,892] [OVLatest ] [INFO ] LatestVideosManager getting new data from SiteUtils.
    [05-02 18:40:07,892] [OVLatest ] [INFO ] LatestVideosManager found 0 videos from 0 SiteUtils.
     

    joecrow

    Test Group
  • Team MediaPortal
  • August 9, 2012
    1,639
    1,233
    Germany Germany
    Country flag
    @Brownard Having trouble again with ITV, see attached screenshots for Live, I get one or the other on 1,2&3:( but ITV 4 and all the catchup I've tested so far play OK. Live ITV 1,2&3 play without problems via my browser. Hope you can help.
    itv.jpg itv3.jpg
     

    joecrow

    Test Group
  • Team MediaPortal
  • August 9, 2012
    1,639
    1,233
    Germany Germany
    Country flag
    I'm now getting "Unable to play video. No URL" on all live ITV channels:oops: though catchup is still OK.
    Could be problems at ITV as I'm also having difficulties via browser, ITV2 and 3 won't play but others are OK. Can you try it out at your end and let me know?
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    Top Bottom