Black screen after channel change... (1 Viewer)

jhb

Portal Pro
September 19, 2006
121
2
Gothenburg
Sweden Sweden
TV-Server Version: 1.0 Final
MediaPortal Version: 1.0 Final
MediaPortal Skin: Blue3 Wide
Windows Version: Vista Home Basic (32b)
CPU Type: AMD 2800+
HDD: ?
Memory: 1.5GB
Motherboard: Gigabyte GA-MA78GM-S2H 780G, AM2+ mATX
Video Card: ATI HD3200 (bult in on MB)
Video Card Driver: ATI Catalyst 8.11
Sound Card: Leadtek
Sound Card AC3: Leadtek
Sound Card Driver: Leadtek
1. TV Card: FloppyDTV
1. TV Card Type: DVB-T + CAM
1. TV Card Driver:
2. TV Card: Leadtek DVB 1000s
2. TV Card Type: DVB-T (no CAM)
2. TV Card Driver:
MPEG2 Video Codec: PowerDVD8 HW Accelerated (doesn't matter the error is there independent of codec)
MPEG2 Audio Codec: PowerDVD8 (doesn't matter the error is there independent of codec)
h.264 Video Codec: PowerDVD8 HW Accelerated
Satelite/CableTV Provider: Boxer (Sweden)
HTPC Case:
Cooling:
Power Supply:
Remote: MCE
TV:
TV - HTPC Connection: DVI+SPDIF

Hi, as I wrote in another thread (that was closed, see the messages included below) that I have problems with the screen going black at channel change. It is not happening every time, but often and I think it is related to the problems some people have with MPEG4. In my case it is ordinary MPEG2 DVB-T and it always works after restarting the MP application. I never had this problem until I made a clean install of 1.0 final..

Yesterday night I thought that everything was working fine, since it worked for a couple of hours after removing the CCCP codec pack and rebooting. However this morning the problem suddenly appeared again (after the client had been in standby over the night, but I tried standby yesterday without any problems also). I have activated restart after standby because I have problems reconnecting streaming

Before (that worked):
- Vista Home Basic
- CCCP codecs (in practice FFDshow was used both for audio and video, but I changed FFDshow video to MPV because I had problems with audio for some TV-shows and that problem disappeared when changing video codec)
- dual seat client/server TV with MPEG2 only
- Mediaportal 1.0RC4

After (that is not working):
- Vista Home Basic
- PowerDVD8 codecs and/or CCCP codecs
- dual seat client/server TV with MPEG2 only
- same HW
- Mediaportal 1.0

I have tested to have a lot of different codec combinations, e.g.:
- MPV for mpeg2-video, FFDShow for audio
- MPV for mpeg2-video, PowerDVD8 for audio
- PowerDVD8 for mpeg2-video, FFDShow for audio
- PowerDVD8 for mpeg2-video, PowerDVD8 for audio
- FFDShow for mpeg2-video, FFDShow for audio
- FFDShow for mpeg2-video, PowerDVD8 for audio

I have also tried to completely uninstall all other Codecs when using FFDshow codecs only (both audio and video) and the same for PowerDVD8, but that didn't help either...

Nothing helps. I have no issues when not watching TV, so I am pretty sure that the problem lies in the built in TS-reader. Whenever the screen has gone black, the only way to get video-decoding to work is to restart Mediaportal (client application only).

The next step will tonight be to try to install RC4 again and see if that resolves things...

On my other HTPC client (my childrens TV) that is running MP1.0RC4 on XP, I have no problems...

Please help me - If you can...
...my wife is soon going to killing me because the TV isn't working any more...

br/ jhb


Initial post
Hi,
I have exactly this setup in my HTPC client and have the same problems with ffwd/rew. Furthermore after the official 1.0 release I've started to get a lot of problems when switching TV channel. I had everything working just fine with RC4, but last weekend I had to re-install the computer after a harddrive crash and with 1.0 I can't get it to work. Most times when doing a channel change the screen goes black and sound continues.

I've tried several different codec combinations for video and audio and no progress. Neither with ffwd/rew problem, nor with channel switching problems...

I have a dual seat configuration with a dedicated TV server and two dedicated clients. The XP-based client is still running RC4 towards the 1.0 final release server without any problems. The failing client has Windows vista home basic (that worked with RC4).

Next post
This drives me crazy. Now it seems to be working. What I did was to uninstall the CCCP-codec pack entirely, including the ffdshow codecs. I then set MP to use the Powerdvd codecs for both audio and video and now everything seems to work...
...but it didn't immidiately...
...when I uninstalled ffdshow it seemed like the SPDIF out configurations were lost in the audio config. Before I changed that, I still had problems with video disappering. Now I can't reproduce that problem...
...what is happening???

I'm continuing my quest for truth. Now I'm going to reinstall CCCP, but not change anything and see if it works then...

Edit: OK, so now I tried to add CCCP again. Everything works fine. I can even use the FFDSHOW codecs, unless for MPEG2, where there seems to be some issues, but when reconfiguring PowerDVD everything works again. There must have been some issue regarding that CCCP was installed before PowerDVD? Or something that had to do with the MPV codec being installed twice (MP & CCCP, but only one showed). After removing CCCP, I had only the PowerDVD-codecs for MPEG2...


I don't know, but now I can't seem to reproduce the problems. In my previous installation I had exactly the same codecs except for another free MPEG2-codec that I was not using...
...strange, but symptom solved at lest (even though the problem isn't).
 

frenzy

Portal Pro
April 29, 2008
228
10
France France
Country flag
Sometimes if you mess with the order of the filters in ffdshow, it crashes.
Depending on graphics drivers,filters in graph and OS some colorspaces in FFDshow give you black screen.
Some settings in 8.11 result in black screen videos.
Installing and uninstalling codecs and especially codec packs is bound to leave you with a couple of problems
But since you figured it out don't mess with it till next time.
 

jhb

Portal Pro
September 19, 2006
121
2
Gothenburg
Sweden Sweden
Hi and thanks,
but I thought I had figured it out, but then the problem came back again this morning...

The only reason I started to fiddle with teh codecs was because I have this problem...
...the first few channel changes often work, but then suddenly one is not working and then I need to restart MP to get it working again. It is only the TV-picture that gets black. All menues and overlays are working as they should (even though the end-time in the show-duration bar at the top is misplaced, one row to low, when this has happened). This definitely makes me suspect that this is a MP bug and not a codec bug...

I am going to try RC4 and see it that helps (never had any problems with that release, I only moved to 1.0 because I had to reinstall the OS). If not, it seems like a clean install of the OS is the only way out (if that helps). Or are there any other proposals?
 

jhb

Portal Pro
September 19, 2006
121
2
Gothenburg
Sweden Sweden
Issue solved.

Reinstalled with RC4, did not help.

Reinstalled Vista and did not install CCCP(FFDSHOW, but installed powerdvd8 only. Now it works. So the problem was that FFDShow/CCCP messed something up in the codec handling...
 

jhb

Portal Pro
September 19, 2006
121
2
Gothenburg
Sweden Sweden
And 33 hours later the problem is back! Happened two times within 15 minutes a couple of minutes ago, after working like a charm for several hours yesterday doing at least 50 channel switches...

This must be an MP bug with video rendering on Vista, or maybe TS-reader related! At least as far as I can understand...

I will try to get some graphstudio pictures and Mediaportal logs on this. But it is hard, since it has a tendency to happen when my wife or children are to use the TV, but when I have time to test the application it rarely happens... :-(

But in short:
- problem only appears when having dual seat MP and changing channel. Haven't been able to trigger it on single seat at least...
- Ethernet 100Mbps between server and client. Problem appears even if the server and the clients are the only computers on the network.
- I have DVB-T with MPEG2 only.
- black screen for TV, but overlays like the on-display info works like it should. Menues are working just fine.
- playing a local divx-file from MP works like a charm, even if TV is not working.
- restarting MP client solves the problem.
- Vista home basic. Whether VMR9 or EVR is used does not matter. The problem is still there. I have no issues on my other computer that runs an MP 1.0 RC4 client on XP...


This is driving me crazy...
...expecially since it seems like the problem comes and goes. I have lately had some disturbancies in the DVB-T signal. Could it be that malformed frames could trigger a bug in the TV-processing?
 

jhb

Portal Pro
September 19, 2006
121
2
Gothenburg
Sweden Sweden
Managed to collect logs

OK, now I have a log. Taken directly after a channel change that gave black screen, but with audio still working.

I really hope this can be solved...
...or at least identified...

View attachment 34043
 

Union

MP Donator
  • Premium Supporter
  • January 23, 2009
    6
    0
    United Kingdom United Kingdom
    I have this same problem…….My setup comprises of a dedicated server with up to four clients running XP with Mediaportal setup with default parameters (Standard Codec's and *.ts recordings) they are all a little dated now but in most other respects work very well.
    Server
    Athlon XP 2600+
    1GB RAM
    1TB HDD
    Hauppauge Nova-S plus
    Hauppauge Nova-T
    Client
    Athlon XP 2600+
    1GB RAM
    Nivida MSI FX5200

    I started using Mediaportal at RC2 and then upgraded to RC3, RC4 and now use 1.0. With RC2, RC3, and RC4 I had a problem that accrued occasionally when changing channel the video and audio stream would stop working, picking a different channel would not work no on screen messages, to fix this problem it required Mediaportal to be restarted on the client, I recall looking at the client logs and it said something like TVStream failed to start. However this problem appears to have gone away with version 1.0 but has been replaced by an audio stream with no video when changing channel especially from a DVB-T source to a DVB-S source the new channel starts audio appears but no video is displayed. The only way I can get it to work again is to restart Mediaportal on the client, I have four clients all have the same motherboard and graphics card therefore I cant rule out a hardware incompatibility issue.

    Note I have tried the latest SVN and it has the same problem as version 1.0. I have done a clean install and don't have any anti virus software running. Next month I intend to buy a new graphics card (probably ATI) however I am limited to AGP cards, I am building a spare server to assist with my testing but this new server will still only be an Athlon XP 3000+ however the FSB will go from 333Mhz to 400Mhz, I intend to try this server as a client with to see if that fixes this problem.
     

    jhb

    Portal Pro
    September 19, 2006
    121
    2
    Gothenburg
    Sweden Sweden
    Interesting...

    I had the same problem as you describe earlier also and I also have restart enabled to recover from it. I especially had the problem after recovering from stand-by...

    This has to be a bug!

    I have tried several different codec-packs and a multitude of codec combinations to see if that had something to do with the problem. The only thing that I have noticed is that depending on how I combine different codecs the problem is more or less frequent. With some combinations I get black screen almost every time (e.g. ffdshow audio and powerDVD8, another combination that is almost as bad is powerdvd8 audio and ffdshow video).

    I am now 100% sure that this is a bug (probably in the TS reader), maybe the same bug as some others see when using ffdshow video with live TV. We however have it much more frequent for some reason, the question is why?

    I read in another thread that there was a problem with sub-second stops in the picture once in a while when using the ffdshow audio codec. I have had that problem also, but it is not present now that I have the powerdvd8 audio codec instead...
     

    Union

    MP Donator
  • Premium Supporter
  • January 23, 2009
    6
    0
    United Kingdom United Kingdom
    I have 4 clients, 2 off are the kids pc’s in there bedrooms and have anti virus software and lots of other junk, the other 2 are dedicated MP machines under each tv these are quite clean, one has had RC2,3,4 then V1 installed, the other one had a complete clean rebuild for V1 this pc operates much better then the rest regarding blank video.

    Once this problem is triggered by changing channel, then when I try to play a recording screen is blank, and sometimes this problem can be triggered by selecting a recording to play. How do your recordings behave?

    All my clients have the same hardware, the blank video problem is random on my pc’s also I can’t find a consistent way to cause the problem.

    I don’t use HD and I use all the standard MP supplied codec’s.

    Because no one else appears to be having this problem I guessed it was hardware related.

    There are lots of differences between mine and your setup. All my pc’s run xp.

    As I said in my previous post I intend to try some different hardware as a client, then maybe look at my network try to split my tv’s and server off the main network and maybe create fixed ip addresses.

    The other problem I have with my system is a 2 second pause maybe ever 15 minutes but this appears common and lots of people talking about that. Again this is inconsistent and maybe related to the time shift buffer files!!!

    Maybe you could try going back to basics- clean windows build, new MP install without any codec’s.

    My client motherboards are Asrock 1600+ with MSI FX5200, my network switch is negear, my server motherboard is gigabyte 2600+.

    Maybe there is something we both have in common???
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    G [solved] Black Screen on all videos after upgrading to either 1.23 or 1.24 from 1.22 General Support 4
    H random black screen live tv and videos (amended) General Support 0
    G Occasional Black screen on Live TV and Recorded TV Watch / Listen Media 5
    doskabouter Black screen while watching some iptv streams General Support 2
    T frequent black screen no audio on playback NOT from beginning Watch / Listen Media 0
    C video wont open, screen goes black and reverts to video menu General Support 3
    A MP2 Black Screen General 6
    Terra some H265 videos stay black, audio is playing General Support 4
    G MadVR, black TV Picture 1.20 Pre Release 1
    C Black Gold Tuner Support General 4
    J Blue Screen Error Submit: Bug Reports 0
    azzuro [fixed] 5011: Version label in Splash screen - pos, size from skin MediaPortal 1 61
    F After resume, TV Server connection screen is shown General Support 4
    M [Duplicate] Always enter full screen when entering TV from main Menu Feature Requests 1
    M Change size of the splash screen Skins and Plugins Installer (MPEI) 2
    T Animated circular icon persists in centre of screen. General 10
    P MP2 Client Screen Flickering on Resume General 2
    Rob Hexenmeister Work arounds for an alternative home screen General Support 3
    lisag Can I get MP1 to open in the Recorded TV screen? MediaPortal 1 Talk 2
    R Media portal resumes with wrong screen resolution General Support 3
    N [Finished] [MP2-806] Playing a recorded radio program does not show screen to allow skipping forward, etc MediaPortal 2 141
    N [Finished] MP2-803 - Delete full series doesn't work when viewing a program in the extended schedule screen MediaPortal 2 12
    morpheus_xx [Finished] [MP2-802] TV-Settings availability in all TV screens MediaPortal 2 12
    G How to access Scheduled Recordings without going through TV Home screen General Support 3
    Rob Hexenmeister Radio Guide descriptions in myradio.xml (screen 30) MediaPortal 1 Skins 3
    Similar threads

























    Top Bottom