1.16.0 Blu-rays / Blu-ray ISO files always play the first audio track no matter which language is selected (1 Viewer)

M.Hulot

Portal Pro
April 23, 2017
195
25
50
Germany Germany
Country flag
There seems to be a huge Bug in MP 1.16.0: When playing Blu-rays or Blu-ray-ISO-Files always the first audio track is played. In most cases this is English. But because I'm from Germany, I'd like to hear the German dubbed versions.
No matter what settings I change, wether in the video-, blu-ray- or DVD-menu in MediaPortal Configuration - in every possible menu "german" is checked. But always every movie starts with the first listed audio track. Sure I can change it when the movie is running. But that's not as it should be.
Could anyone check this? Maybe there is another way to solve this problem, but I don't know it. Maybe it's a bug.
I'm looking forward to your answers.

EDIT
@mm1352000: What specs do you need?
 
Last edited:

M.Hulot

Portal Pro
April 23, 2017
195
25
50
Germany Germany
Country flag
Is there a chance to disable the audio type selection or do I have to select one of the following formats: ac3, ac3+, dts, dts hd, dts hd master, lpcm, true hd. Because if I choose dts master hd and the german track is just dts hd, will MePo automatically go to the first audio stream?
That would mean, that I have to select the correct audio type for the german track every time before I play the Blu-ray-ISO-file. And that would be much more cumbersome than select the correct audio stream while watching the movie.
If one hadn't to choose at all which audio type should be played preferentially the problem would vanish - possibly.
 

mm1352000

Development Group
  • Team MediaPortal
  • September 1, 2008
    21,571
    8,218
    New Zealand New Zealand
    Country flag
    What specs do you need?
    Provide log files please. Log files are required for bug reports.
    Provide all log files. Please use the Watchdog tool with option 1 ("report a bug...") to reproduce the problem. It will collect all the log files into a convenient zip file for you to attach. This is what we expect for all bug reports and support requests.
     

    mm1352000

    Development Group
  • Team MediaPortal
  • September 1, 2008
    21,571
    8,218
    New Zealand New Zealand
    Country flag
    Thanks :)

    First, I can see that you played two Blu-Rays - Whiplash and Vom Winde verweht. The log files only show me details for the second one.

    I can see that you've configured MP's Blu-Ray audio settings as follows:
    Code:
    <section name="bdplayer">
      <entry name="audiolanguage">German</entry>
      <entry name="subtitlelanguage">German</entry>
      <entry name="audiotype">DTS-HD Master</entry>
    These are passed to libbluray when the test BR (Vom Winde verweht) is started:
    04-05-2017 19:22:25.912 [ 2588]CLibBlurayWrapper - Settings: Audio(deu), Menu(deu), Sub(deu), Ctry(de), Reg(2), Prtl(99)

    Initially I can see that the German audio is selected:
    04-05-2017 19:22:26.082 [ 2588]Playlist Manager new Playlist 0 clip 0 start 4198.000 clipOffset 4198.000 Audio 1 duration 13994.272
    04-05-2017 19:22:26.082 [ 2588] Video [4113] VC1
    04-05-2017 19:22:26.082 [ 2588] Audio #0:[4352] eng TrueHD 5
    04-05-2017 19:22:26.082 [ 2588] Audio #1:[4353] fra AC3 5
    04-05-2017 19:22:26.082 [ 2588] Audio #2:[4354] deu AC3 5
    04-05-2017 19:22:26.083 [ 2588] Audio #3:[4355] ita AC3 5
    04-05-2017 19:22:26.083 [ 2588] Audio #4:[4356] spa AC3 5
    04-05-2017 19:22:26.083 [ 2588] Audio #5:[4357] spa AC3 1
    04-05-2017 19:22:26.083 [ 2588] Audio #6:[4358] por AC3 1
    04-05-2017 19:22:26.083 [ 2588] Audio #7:[4360] eng AC3 2
    04-05-2017 19:22:26.084 [ 2588] Audio #8:[4361] eng AC3 1
    04-05-2017 19:22:26.084 [ 2588]demux: ParseAudioStreams - Audio track #2 selected

    However, later I see:
    04-05-2017 19:22:27.570 [ 2588]demux: SetAudioStream : 0 - no change

    In other words, the English Dolby TruHD audio stream is selected.

    Currently I can't see why the selection changes.

    Please:
    1. Open MP Configuration.
    2. Go to the "General" section.
    3. Select log verbosity "debug".
    4. Click OK to save and close.
    5. Use the Watchdog to collect new log files for the same Vom Winde verweht BR.
    Hopefully this will enable us to see what's going on.
     

    daWooky

    MP Donator
  • Premium Supporter
  • April 3, 2012
    779
    868
    Germany Germany
    Country flag
    hi, i assume that u simply want the germany audio stream as default...
    try lav settings with deu,ger,eng
    Unbenannt.JPG
     

    M.Hulot

    Portal Pro
    April 23, 2017
    195
    25
    50
    Germany Germany
    Country flag
    Yes. Thank you. I tried it, but still the english stream is played.
     

    daWooky

    MP Donator
  • Premium Supporter
  • April 3, 2012
    779
    868
    Germany Germany
    Country flag
    strange... full debug logs pls :sneaky:
    and do u set that dts-ma at audio type on purpose? if not, try reverting back on ac3
     

    M.Hulot

    Portal Pro
    April 23, 2017
    195
    25
    50
    Germany Germany
    Country flag
    I did that, but have to wait til evening, before I can proceed. Then I will change as suggested :)
    Thank you so far
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    Top Bottom