1.16.0 - Blu-rays / Blu-ray ISO files always play the first audio track no matter which language is selected | Page 2

Discussion in 'Archive' started by M.Hulot, May 4, 2017.

  1. mm1352000
    • Team MediaPortal

    mm1352000 Development Group

    Joined:
    September 1, 2008
    Messages:
    21,498
    Likes Received:
    4,712
    Ratings:
    +8,175 / 17
    Home Country:
    New Zealand New Zealand
    Nice idea... but LAV splitter is not used for BR playback/splitting. The MP internal BR player uses our own splitter (BDReader).


     
    • Like Like x 1
  2. Google AdSense Guest Advertisement



    to hide all adverts.
  3. daWooky
    • Premium Supporter

    daWooky MP Donator

    Joined:
    April 3, 2012
    Messages:
    770
    Likes Received:
    393
    Gender:
    Male
    Ratings:
    +920 / 0
    Home Country:
    Germany Germany
    oh dear i overlooked he used internal br, you're right as always mm^^
    so mr. hulot if u want to try what i suggested before, u need to disable the internal blu-ray option. it should work but without fancy menus...
    Unbenannt2.JPG
    and please grab full logs option enabled for debugging
     
  4. mm1352000
    • Team MediaPortal

    mm1352000 Development Group

    Joined:
    September 1, 2008
    Messages:
    21,498
    Likes Received:
    4,712
    Ratings:
    +8,175 / 17
    Home Country:
    New Zealand New Zealand
    I'm not always right. In fact I'm often very wrong! :)

    Yup (y)
    I don't mind if M.Hulot wants to use the LAV splitter. However it would be nice to solve any problems with the internal player/splitter too. So, @M.Hulot : please don't give up on providing the log files. :)
     
  5. M.Hulot

    M.Hulot Portal Pro

    Joined:
    April 23, 2017
    Messages:
    160
    Likes Received:
    6
    Gender:
    Male
    Ratings:
    +13 / 4
    Home Country:
    Germany Germany
    Show System Specs
    You are right: not choosing the internal player solves the problem. But now I can't select any bonus features or the menu...
    So I have to choose: movie with the correct audio stream but without menus or bonus video streams or menus/bonus video stream but the wrong audio track.
    Am I correct? Or is there a chance to play the extras (bonus features) with disabled internal menu player?
     
  6. mm1352000
    • Team MediaPortal

    mm1352000 Development Group

    Joined:
    September 1, 2008
    Messages:
    21,498
    Likes Received:
    4,712
    Ratings:
    +8,175 / 17
    Home Country:
    New Zealand New Zealand
    Again, please give us a chance to fix the audio stream selection!
    I'm waiting on new log files...
     
  7. M.Hulot

    M.Hulot Portal Pro

    Joined:
    April 23, 2017
    Messages:
    160
    Likes Received:
    6
    Gender:
    Male
    Ratings:
    +13 / 4
    Home Country:
    Germany Germany
    Show System Specs
  8. M.Hulot

    M.Hulot Portal Pro

    Joined:
    April 23, 2017
    Messages:
    160
    Likes Received:
    6
    Gender:
    Male
    Ratings:
    +13 / 4
    Home Country:
    Germany Germany
    Show System Specs
    new log 2 with the requested settings.
    no difference
     
  9. M.Hulot

    M.Hulot Portal Pro

    Joined:
    April 23, 2017
    Messages:
    160
    Likes Received:
    6
    Gender:
    Male
    Ratings:
    +13 / 4
    Home Country:
    Germany Germany
    Show System Specs
    By the way: I noticed some strange behaviour
    I am using ffdshow Video Decoder for the AV Delay section in the OSD. This causes, that a Blu-ray ISO file doesn't start but blackens the screen. If I press the stop Button an start again, everything is fine.
    But using Titan within watchdog every movie starts immediatly - and AV Delay is available, too.
    But closing watchdog and starting MePo again manually with the Titan skin, then the first selected and Starter Blu-ray-movie blackens the screen. Stopping it and starting it again let the movie play. And every Blu-ray after that.

    Why does it work with Titan started by watchdog and doesn't work with Titan or an other skin selected by me?

    Gesendet von meinem BlackBerry | Priv mit Tapatalk
     
  10. mm1352000
    • Team MediaPortal

    mm1352000 Development Group

    Joined:
    September 1, 2008
    Messages:
    21,498
    Likes Received:
    4,712
    Ratings:
    +8,175 / 17
    Home Country:
    New Zealand New Zealand
    When you use the Watchdog (option 1), all third party plugins are disabled. If the problem goes away when the Watchdog is used (ie. plugins disabled) then I guess a plugin must be causing the problem.
     
  11. M.Hulot

    M.Hulot Portal Pro

    Joined:
    April 23, 2017
    Messages:
    160
    Likes Received:
    6
    Gender:
    Male
    Ratings:
    +13 / 4
    Home Country:
    Germany Germany
    Show System Specs
    thank you for your answer.

    When I disable ffdshow Video Decoder in Blu-ray postprocessing everything works fine, too. But ffdshow seems not to be disabled by watchdog, because the controller for AV Delay is adjustable. (But I have to test, if it really works or if it turns into a dummy while using watchdog). If it really works, I have to disable my plugins one after the other to find the one causing the problem.
    by the way: The black screen only occurs using ISOs from "real" blu-rays. When I load Blu-ray ISOs which I generated from TV-recordings in 720p50, the file/movie starts correctly.

    Gesendet von meinem BlackBerry | Priv mit Tapatalk
     
Loading...

Users Viewing Thread (Users: 0, Guests: 0)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
  • About The Project

    The vision of the MediaPortal project is to create a free open source media centre application, which supports all advanced media centre functions, and is accessible to all Windows users.

    In reaching this goal we are working every day to make sure our software is one of the best.

             

  • Support MediaPortal!

    The team works very hard to make sure the community is running the best HTPC-software. We give away MediaPortal for free but hosting and software is not for us.

    Care to support our work with a few bucks? We'd really appreciate it!