[BUG] graphbuild fails for .mkv with sub-streams (1 Viewer)

deebo

Portal Pro
April 19, 2006
233
3
os, vista ultimate 32
mp, svn 16374


using ANY avc decoder (coreavc, powerdvd7.3, ffdshow) graph build fails for .mkv files that contain subtitle streams when using vsfilter (directvobsub)

works fine in graphedit and zoomplayer/mpc

im sure of this, i went thru my whole movie collection, and all the files that failed to work had subtitle streams :)

edit: vmr9/evr makes no difference
 

tourettes

Retired Team Member
  • Premium Supporter
  • January 7, 2005
    17,301
    4,800
    Eabin could you have a look on this issue? Looks like it could have been introduced when the graph rebuidling changes have been done.
     

    deebo

    Portal Pro
    April 19, 2006
    233
    3
    heres the logs

    flow:
    start
    ->my videos
    play a mkv (avc) with no subs (Star Wars IV.mkv)
    press stop
    _try_ to play a mkv (avc) with subtitle tracks (Under Siege.mkv) (rocks btw)

    (powerdvd avc decoder + ffdshow audio decoder + DirectVobSub)
     

    Luke Roberts

    Portal Pro
    August 23, 2007
    65
    7
    48
    IJmuiden
    Netherlands Netherlands
    Same here, can't play mkv files that use DirectVobSub.

    I was going crazy looking for the solution until I found this thread. It seems the mkv testfile I have in my testfile directory, had subtitles. It is the only mkv file I have that has subtitles.... just added an mkv file without the subs to my test directory....
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    R Bug: Video Folders disappear General Support 11
    catalpa Bug MP2-837 Allgemeines Support- und Diskussionsforum 2
    framug [Approved] Fix Irtrans config bug Submit: code patches (MediaPortal/TV-Server/etc.) 4
    ge2301 Bugs and Improvements Nereus 6
    N [Finished] Focus problems - I think I've found the bug MediaPortal 2 30
    Scheibes [solved] Kategorisierung der Genres (Bug?) Allgemeines Support- und Diskussionsforum 13
    joecrow 3 Bugs in MP 1.21 1.21 5
    dcapslock TV Server xmltv IWakeupHandler Bug Television (MyTV frontend and TV-Server) 6
    rsbrux Various bugs, some Zombies ;-) 1.20 6
    J [solved] Mp 2.2 future bugs General 7
    S [MP2-768] Installation Setup Failed - Error 0x80070666 - VC++ 2015/2017 Redist bug 2.2 Archive 19
    D MP2.2: Possible bugs 2.2 Archive 20
    R Jira bug exposed private server keys at major companies Developer Discussions 1
    R Minor bug in recorded TV list Watch / Listen Media 0
    P MP2 - V2.1 Bug - Onlinevideos U.S. Amazon Prime Fails to Connect Older releases 5
    joecrow 1.25.0 Radio Time plugin fails after Resume from Sleep with MP 1.25 Bugreports 4
    M MovingPictures: Hang at retrieving details (connection fails) ? Moving Pictures 23
    Grisu002 Failed to startup - TV Server funktioniert nicht Allgemeines Support- und Diskussionsforum 0
    Dark Eyes TVService locks up or fails to restart on resuming from sleep, and crashes when grabbing EPG Installation, configuration support 7
    T [solved] failed to-startup tvservice Installation, configuration support 1
    B MP 1.23 First time click TV or Recorded TV fails, 2nd ... it will work General Support 5
    W Setup data connection - mySQL connection failed Installation, configuration support 1
    BrownGhost MP-TVSeries, Failed to save xml to cache, and not adding any info to tvseries from tvdb My TVSeries 4
    C Setup failed: 0xfffffff7 Allgemeines Support- und Diskussionsforum 1
    G MP1 TV Server "failed to upgrade the database" using MS Sql Server Installation, configuration support 3
    Similar threads

























    Top Bottom