Cannot record shows with double-byte names? (2 Viewers)

awh

New Member
August 17, 2007
4
0
Home Country
Japan Japan
TV-Server Version: 1.0.0.0

MediaPortal Version: 1.0.0.0

MediaPortal Skin: Indigo

Windows Version: XP Professional

CPU Type: AMD Athlon 64 3000+ (2 GHz)

HDD: 300GB

Memory: 512MB

Motherboard:

Video Card: GeForce4 Ti 4200

Video Card Driver:

Sound Card:

Sound Card AC3:

Sound Card Driver:

1. TV Card: Analog WinFast PVR3000 Tuner

1. TV Card Type:

1. TV Card Driver:

2. TV Card:

2. TV Card Type:

2. TV Card Driver:

3. TV Card:

3. TV Card Type:

3. TV Card Driver:

4. TV Card:

4. TV Card Type:

4. TV Card Driver:

MPEG2 Video Codec:

MPEG2 Audio Codec:

h.264 Video Codec:

Satelite/CableTV Provider: Antenna

HTPC Case:

Cooling:

Power Supply:

Remote:

TV: Monitor

TV - HTPC Connection:



When I try to record a TV show with Japanese in the program data, nothing gets recorded. Digging through the log files, I see this in MPFileWriter.log:


27-01-2009 05:46:46.424 CMemoryStreamSource::ctor()
27-01-2009 05:46:46.439 CFileSinkRecorder::create file:C:\Documents and Settings\All Users\Application Data\Team MediaPortal\MediaPortal TV Server\recordings\ズームイン!!SUPER - 4 日本テレビ - 2009-01-27.ts
27-01-2009 05:46:46.439 CFileSinkRecorder::create file:C:\Documents and Settings\All Users\Application Data\Team MediaPortal\MediaPortal TV Server\recordings\ズームイン!!SUPER - 4 日本テレビ - 2009-01-27.ts failed


On the other hand, if I record a show that is not in the guide (and therefore has no Japanese in the title), it records properly, and shows no failure in the logs at all.

I know that there isn't a problem with Japanese filenames on the system, because the .xml file that gets created that holds the recording info also has a Japanese filename.

Has anyone got this to work with Asian character sets?

Thanks,
 

benjerry

MP Donator
  • Premium Supporter
  • September 26, 2007
    167
    10
    Home Country
    Netherlands Netherlands
    Same problem here..

    Indeed a problem with tswriter.

    tswriter.log:
    14-03-2009 20:17:28.963 Recorder: RECORD transport stream mode
    14-03-2009 20:17:28.963 Recorder: RECORD set filename:D:\TV\Recordings\JSTV???????? - JSTV1 - 2009.03.14 - 20.00-22.00.ts
    14-03-2009 20:17:28.963 Recorder: RECORD Received from TvService: pmt pid:0x40d serviceId: 0x2015 pmtlength:134
    14-03-2009 20:17:28.963 Recorder: RECORD Old pids cleared
    14-03-2009 20:17:28.963 Recorder: RECORD got pmt - tableid: 0x2 section_length: 134 sid: 0x2015
    14-03-2009 20:17:28.963 Recorder: RECORD PMT parsed - Pid 0x40d ServiceId 0x2015 stream count: 5
    14-03-2009 20:17:28.963 Recorder: RECORD pcr pid:0x7d0
    14-03-2009 20:17:28.963 Recorder: RECORD SetPcrPid clear old PIDs
    14-03-2009 20:17:28.963 Recorder: RECORD add video stream pid: 0x7d0 fake pid: 0x30 stream type: 0x2 logical type: 0x2 descriptor length: 17
    14-03-2009 20:17:28.963 Recorder: RECORD add audio stream pid: 0x7d1 fake pid: 0x40 stream type: 0x3 logical type: 0x3 descriptor length: 20
    14-03-2009 20:17:28.963 Recorder: RECORD add audio stream pid: 0x7d2 fake pid: 0x41 stream type: 0x3 logical type: 0x3 descriptor length: 14
    14-03-2009 20:17:28.963 Recorder: RECORD add audio stream pid: 0x7d3 fake pid: 0x42 stream type: 0x3 logical type: 0x3 descriptor length: 20
    14-03-2009 20:17:28.963 Recorder: RECORD add audio stream pid: 0x7d4 fake pid: 0x43 stream type: 0x3 logical type: 0x3 descriptor length: 20
    14-03-2009 20:17:28.963 Recorder:unable to create file:'D:\TV\Recordings\JSTV???????? - JSTV1 - 2009.03.14 - 20.00-22.00.ts' 123

    error.log:
    2009-03-14 20:17:28.963250 [27]: subch:1 tswriter StartRecord failed:1

    only in recording folder: JSTVドラマスペシャル - JSTV1 - 2009.03.14 - 20.00-22.00.xml
     

    Attachments

    • tvguide-japanese.jpg
      tvguide-japanese.jpg
      74.6 KB

    zhvihti

    MP Donator
  • Premium Supporter
  • October 16, 2007
    20
    0
    Amsterdam
    Home Country
    Netherlands Netherlands
    Same problem here, with Bulgarian characters. Workaround is to change the TS naming format to not include channel or program name.

    It's strange because I it used to work in 2.3.0. I really hope this is fixed in the next version.
     

    Users who are viewing this thread

    Top Bottom