Can't load BasicHome editor after upgrade (1 Viewer)


MP Donator
  • Premium Supporter
  • January 7, 2006
    Home Country
    Netherlands Netherlands
    After doing the upgrade to this version I keep getting a SMP editor crash once I start it, tried a clean install of Streamedmp as well but didn't help.
    The .NET error report:

      Stopped working
    Problem signature:
      Problem Event Name:	CLR20r3
      Problem Signature 01:	smpeditor.exe
      Problem Signature 02:
      Problem Signature 03:	51c50e73
      Problem Signature 04:	StreamedMPEditor
      Problem Signature 05:
      Problem Signature 06:	51c50e6f
      Problem Signature 07:	7b
      Problem Signature 08:	0
      Problem Signature 09:	System.TypeInitialization
      OS Version:	6.1.7601.
      Locale ID:	1043

    Are there any additional logs that I can look into and maybe find the cause?

    /edit: Had to reinstall MP and now it works, wanted to a clean install for a while so no big deal but still seems like a bug in the upgrade process.
    Was running MP 1.3 stable before it that helps.
    Last edited:


    MP Donator
  • Premium Supporter
  • January 1, 2012
    Home Country
    Germany Germany
    I've had this one with 1.4pre and the cooresponding StreamedMP Beta version, after complete uninstall of streamedmp an reinstallation, this was gone. No issues so far with the upgrade regarding this one.

    I have another minor issue:
    When I'm inside some menu from the top menu (TV, Music, whatever), go to standby then, resume and go back to the main menu, the background and sometimes the menu font will not load. New for me since 1.4.


    New Member
    December 15, 2008
    Home Country
    I had this issue.

    For me, the root cause was an old version of OnlineVideos. Mediaportal 1.4 introduced Log4Net and Online videos (until the latest version) used When loading SMPEditor (Basic home editor) it tries to load stuff from online videos and crashes with the error message you posted. Also if you go to the plugin section of MediaPortal configuration it crashes. Long story short to fix it I did the following:

    1. Uninstall OnlineVideos (run the latest OnlineVideos installer, choose yes to uninstalling previous version, after uninstall cancel the new install).

    2. If the following files still exists delete them:
    - 'C:\Program Files (x86)\Team MediaPortal\MediaPortal\OnlineVideos.MediaPortal1.dll'
    - 'C:\Program Files (x86)\Team MediaPortal\MediaPortal\OnlineVideos.dll'
    - 'C:\Program Files (x86)\Team MediaPortal\MediaPortal\Plugins\Windows\OnlineVideos\*'
    - 'C:\Program Files (x86)\Team MediaPortal\MediaPortal\Plugins\Windows\OnlineVideos.MediaPortal1.dll'

    3. Install OnlineVideos as you would normally.

    4. Problem should be resolved

    *** Disclamer: I take no responsibility if the above does not work for you, or if it destroys your MP configuration, computer, or life. ***

    Users who are viewing this thread

    Top Bottom