Can't play stream 2.0 (1 Viewer)

Africa67

MP Donator
  • Premium Supporter
  • February 1, 2007
    35
    2
    52
    Cinquefrondi
    Italy Italy
    Sorry for the delay ... here are my logs.
    I hope you can find the problem.
     

    mm1352000

    Development Group
  • Team MediaPortal
  • September 1, 2008
    21,571
    8,218
    New Zealand New Zealand
    Country flag
    Hi Africa67

    So it looks like you are using WOL to wake the TV Server when you want to view TV on the remote client. Is this correct?
    Are you using a static IP address for the TV Server?
    It looks like you're not, because when MP first starts I see this error:
    [collapse]2012-06-26 13:41:48.993164 [Info.][MPMain(1)]: HTPC Info: TVServer Initialization Error. (Error Code: System.Net.Sockets.SocketException: Impossibile stabilire la connessione. Rifiuto persistente del computer di destinazione 192.168.1.19:31456

    Server stack trace:
    in System.Net.Sockets.Socket.DoConnect(EndPoint endPointSnapshot, SocketAddress socketAddress)
    in System.Net.Sockets.Socket.Connect(EndPoint remoteEP)
    in System.Runtime.Remoting.Channels.RemoteConnection.CreateNewSocket(EndPoint ipEndPoint)
    in System.Runtime.Remoting.Channels.RemoteConnection.CreateNewSocket()
    in System.Runtime.Remoting.Channels.RemoteConnection.GetSocket()
    in System.Runtime.Remoting.Channels.SocketCache.GetSocket(String machinePortAndSid, Boolean openNew)
    in System.Runtime.Remoting.Channels.Tcp.TcpClientTransportSink.SendRequestWithRetry(IMessage msg, ITransportHeaders requestHeaders, Stream requestStream)
    in System.Runtime.Remoting.Channels.Tcp.TcpClientTransportSink.ProcessMessage(IMessage msg, ITransportHeaders requestHeaders, Stream requestStream, ITransportHeaders& responseHeaders, Stream& responseStream)
    in System.Runtime.Remoting.Channels.BinaryClientFormatterSink.SyncProcessMessage(IMessage msg)

    Exception rethrown at [0]:
    in System.Runtime.Remoting.Proxies.RealProxy.HandleReturnMessage(IMessage reqMsg, IMessage retMsg)
    in System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke(MessageData& msgData, Int32 type)
    in TvControl.IController.get_Cards()
    in HTPCInfoPlugin.HTPCInfo.InitConnectors(), Impossibile stabilire la connessione. Rifiuto persistente del computer di destinazione 192.168.1.19:31456)
    2012-06-26 13:41:49.680664 [Info.][MPMain(1)]: HTPC Info: Speedfan Shared Memory Initialization Error. (Error Code: HTPCInfo.Core.SharedMemoryException: Error accessing shared memory area. (2)
    in HTPCInfo.Core.SpeedfanSharedMemory..ctor()
    in HTPCInfo.Core.SpeedfanConnector..ctor(Boolean filterZeroValues)
    in HTPCInfo.Core.SpeedfanConnector..ctor()
    in HTPCInfoPlugin.HTPCInfo.InitConnectors(), Error accessing shared memory area. (2))[/collapse]

    ...indicating the client can't connect to the server at 192.168.1.19 (port 31456 is the standard port that TV Server uses to communicate with the MP client TV plugin). After that, there are connection problems with 192.168.1.1 (presumably the new IP address of the server after it woke) when you try to view the stream.

    I would suggest that you try using a static IP address for the TV Server first if you're not already doing that.

    mm
     

    Africa67

    MP Donator
  • Premium Supporter
  • February 1, 2007
    35
    2
    52
    Cinquefrondi
    Italy Italy
    Yes, all clients use the WOL.
    Static IP on all computers including the server (192.168.1.1).
    I try to send another log from another client that has the same behavior.
     

    mm1352000

    Development Group
  • Team MediaPortal
  • September 1, 2008
    21,571
    8,218
    New Zealand New Zealand
    Country flag
    Hmmm. If the server is 192.168.1.1, then which PC is 192.168.1.19 and why was the client trying to connect to that address? :confused:
     

    Africa67

    MP Donator
  • Premium Supporter
  • February 1, 2007
    35
    2
    52
    Cinquefrondi
    Italy Italy
    On this machine (192.168.1.19) is also installed tvserver (a laptop) but the indication is correct, the inside of mpconfig servertv is listed as 192.168.1.1. As I wrote before I try to send another log where he is sure that it is not installed Tvserver.
     

    Africa67

    MP Donator
  • Premium Supporter
  • February 1, 2007
    35
    2
    52
    Cinquefrondi
    Italy Italy
    I noticed, from the logs of both clients, the access error tvserver is directed to the ip of their wireless network cards.
     

    Africa67

    MP Donator
  • Premium Supporter
  • February 1, 2007
    35
    2
    52
    Cinquefrondi
    Italy Italy
    I checked better, IP addresses are the addresses of network adapters of their client machines, not the wireless network cards as I suspected.
     

    mm1352000

    Development Group
  • Team MediaPortal
  • September 1, 2008
    21,571
    8,218
    New Zealand New Zealand
    Country flag
    I'm sorry - I don't understand what you mean. Can you please explain again?
     

    Africa67

    MP Donator
  • Premium Supporter
  • February 1, 2007
    35
    2
    52
    Cinquefrondi
    Italy Italy
    2012-06-26 13:41:48.993164 [Info.][MPMain(1)]: HTPC Info: TVServer Initialization Error. (Error Code: System.Net.Sockets.SocketException: Impossibile stabilire la connessione. Rifiuto persistente del computer di destinazione 192.168.1.19:31456
    The IP address, highlighted in red in the error above, is the IP address of itself. The same error on all clients, each one with its own IP.
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    M.Hulot MP plays in Internal Blu-ray-Player-mode always first audio stream not the one I chosen in settings General Support 1
    H Unable to play stream - again... Television (MyTV frontend and TV-Server) 2
    A Unable to play :stream 3 Television (MyTV frontend and TV-Server) 1
    joecrow [solved] DVD won't play properly. General Support 3
    BrownGhost Mepo/MediaInfo takes 59 secunds to open library and start play :o( General Support 26
    I 1.25.0 Videos in HEVC UHD 2160p don't play good watch/edit Videos 8
    CanadianEh MP TV server rebuild with Colossus 2 - Kodi clients receive PMT error when playing videos recoreded by Colossus 2 TV-Server 1
    M [solved] WTV Files does not play on client, MPEG files works well General 1
    A [solved] How to Play All Videos in a List watch/edit Videos 3
    horned_reaper [solved] When playing music Fanart does not shuffle Fanart Handler 20
    horned_reaper [solved] No Fanart when playing Fanart Handler 115
    horned_reaper [solved] When playing music Fanart does not appear immediately after downloading Fanart Handler 272
    B MP 2.2.3 Error playing videos from NAS Submit: Bug Reports 2
    N Play a TV recording needs a double selection - twice ok on remote Television (MyTV frontend and TV-Server) 2
    M MP 2.2.3 Unable to play .ts recordings and MediaPortal stops working for TV viewing General 31
    Z Error when attempting to play Blu Ray General 1
    Rob Hexenmeister Playing with hyperlinkParameter and List Control indexes General Support 2
    C Problem playing videos created on IPhone X and Samsung S9 General Support 2
    2BitSculptor MP 1.23.. music stops playing General Support 6
    C Attempt to play DVD locks up MediaPortal watch/edit Videos 0
    B Suddenly MP is unable to play anything Watch / Listen Media 6
    Edwardfc [solved] Mp 2.2.1 Configuration Issues - Goes to Sleep while playing Music General 6
    M After a while Live TV or Recorded TV doesn't play first time General Support 9
    L [solved] MP2 doesnt play anything - player missing? General 1
    badboyxx MP 1.22 final is crashing when jumping forward while playing DVD-Iso watch/edit Videos 26
    Similar threads

























    Top Bottom