Change tv subtitle in MediaPortal 1.26 (1 Viewer)

CyberSimian

Test Group
  • Team MediaPortal
  • June 10, 2013
    2,405
    1,456
    Southampton
    Home Country
    United Kingdom United Kingdom
    I would be appreciative if someone can play the file and see if they can see the subtitles in mediaportal and if they are a single colour for you.
    I copied your TS file to the "Recorded TV" folder, and to the "Videos" folder, and used "Import recordings" in "TV Server Config" to load the file into the TV Server database (so that the recording would be visible in the "Recorded TV" panel in MP).

    I also disabled DVB subtitles, and enabled CC subtitles in "MP Config".

    However, I saw no subtitles at all, and I was unable to enable them. Whilst playing the recording, pressing the INFO button on the remote should give a pop-up that allows you to navigate to a Context menu where you can enable subtitles. But on my system, "Enable subtitles" was not offered as a choice. This was true both for "Recorded TV" and for "Videos".

    Unfortunately, MP currently lacks a developer who is expert in the TV support, so I don't think that there is anyone who can help you with this. :(

    -- from CyberSimian in the UK
     

    CyberSimian

    Test Group
  • Team MediaPortal
  • June 10, 2013
    2,405
    1,456
    Southampton
    Home Country
    United Kingdom United Kingdom
    It looks like Australia might be using closed captions
    I had another go at this. :)

    I have noticed that with DVB subtitles, when subtitles are enabled via the Context menu whilst watching live TV or a recording, it takes several seconds before the subtitles start appearing. Possibly TV Server has to wait for a "key frame" to occur in the datastream before it can enable the subtitles. The sample that you provided (20 seconds) may be too short to enable subtitles and then wait for a key frame. So I decided the enable the option in "MP Config" that starts showing subtitles as soon as the video starts. Well...

    "Closed caption" subtitles still don't work. But then I decided to try instead "teletext subtitles", and they do work. However...

    As you have found, the text is always white, and there is no blanked area behind the subtitles to make them easier to read. There is an option in the "Video Subtitles" section to specify an opaque box behind the subtitles (it is deselected by default). I tried that, but it has no effect. :(

    If subtitles are really important to you (perhaps because you are hard of hearing), you may need to consider a different solution for your TV-watching and TV-recording requirements. :(

    -- from CyberSimian in the UK
     

    Trevc

    Portal Member
    December 2, 2020
    5
    0
    Home Country
    Australia Australia
    As you have found, the text is always white, and there is no blanked area behind the subtitles to make them easier to read. There is an option in the "Video Subtitles" section to specify an opaque box behind the subtitles (it is deselected by default). I tried that, but it has no effect.
    Thanks for your effort, much appreciated.

    I found this old post in the forum about Teletext subtitles don't have different transmitted colors, so it looks like unfortunately mediaPortal will just display it it a single colour.

    I still think MediaPortal is probably the best replacement for WMC so far I've found (plus highly configurable), and one of the only few alternatives that does show subtitles for Australian TV. So I think I can live it with at this stage.

    Thanks.
     

    Users who are viewing this thread

    Similar threads

    I've just switched over from windows media centre to MediaPortal ( MediaPortal 1.26). Is there anyway to change the colour of the subtitles used for tv? I'm in Australia and have dvb-t tv channels set up. I noticed the subtitles colour is white and I want to change the colour. I can see how to change the size using the configuration...
    I've just switched over from windows media centre to MediaPortal ( MediaPortal 1.26). Is there anyway to change the colour of the...
    I've just switched over from windows media centre to MediaPortal ( MediaPortal 1.26). Is there anyway to change the colour of the...
    Replies
    0
    Views
    514
    I thinks this is the first time I've installed MP on all my machines without a single IO error 32. Good work guys, thanks!
    I thinks this is the first time I've installed MP on all my machines without a single IO error 32. Good work guys, thanks!
    We have just released MediaPortal 1.26 - Winter is coming... Highlights of this release Bugfixes: [MP1-5031] - Fix Invalid File...
    Replies
    1
    Views
    2K
    Hi, must be really a while, cuz I can not remember any post from you ;) But might be also that I joined the team too late. Yes, there will be many things. Main reason is simply, that MP2 is not developed based on MP1. I for example never used MP1. I tried it lately to test voice control and was shocked about many inconsistancies in...
    Hi, must be really a while, cuz I can not remember any post from you ;) But might be also that I joined the team too late. Yes...
    It´s been a while... :) Well, simply the reason is cause MP1 was working so well... :) Now I decided to upgrade my old servers and...
    Replies
    1
    Views
    240
    • Sticky
    Great work and release!! Contrats to all involved developers :):D I installed MP1 initially, but didn’t get along with it. Many things were not intuitive, too frumpy and the gui had hardcoded dependencies to plug-ins, some buttons didn’t work even without a note due to that. Same for player controls, why do I see always play and pause...
    Great work and release!! Contrats to all involved developers :):D I installed MP1 initially, but didn’t get along with it. Many...
    We are proud to present MediaPortal 2.4 MediaPortal 2.4 is a full-blown media center software that addresses most common user...
    Replies
    4
    Views
    585
    Pre Releases are provided as a way for the community to test and give feedback on all the exciting things we have lined up for the next release. We allocate about one month for Pre Release testing. In that time we will only fix bugs, after which comes the final release! Highlights of this release Bugfixes: [MP1-5031] - Fix Invalid...
    Pre Releases are provided as a way for the community to test and give feedback on all the exciting things we have lined up for the...
    Pre Releases are provided as a way for the community to test and give feedback on all the exciting things we have lined up for the...
    Replies
    0
    Views
    2K
    Top Bottom