1.15.0 CI menu entitlements screen not showing but present (1 Viewer)

mm1352000

Development Group
  • Team MediaPortal
  • September 1, 2008
    21,571
    8,219
    New Zealand New Zealand
    Country flag
    Please answer this question:
    Same in both TV Server Config and MediaPortal?
    From what I can see in the TV Server log:
    [2017-04-15 17:57:13,830] [Log ] [31 ] [DEBUG] - EnterCiMenu called
    ...
    [2017-04-15 17:57:24,045] [Log ] [31 ] [DEBUG] - SelectCiMenu called
    ...
    [2017-04-15 17:57:36,237] [Log ] [31 ] [DEBUG] - EnterCiMenu called
    [2017-04-15 17:57:37,177] [Log ] [Digital Devices CiMenuHandler] [DEBUG] - Menu received (ID 1 Type 0 Choices 0)
    [2017-04-15 17:57:37,183] [Log ] [Digital Devices CiMenuHandler] [DEBUG] - Unknown MMI Type 0
    [2017-04-15 17:57:37,688] [Log ] [Digital Devices CiMenuHandler] [DEBUG] - Menu received (ID 2 Type 1 Choices 5)
    [2017-04-15 17:57:37,896] [Log ] [Digital Devices CiMenuHandler] [DEBUG] - Menu received (ID 2 Type 1 Choices 5)

    ...I think it's possible the problem is on the TV Server side, or even comes from the CAM itself.

    Also, every time before you test, please:
    1. Remove the CAM.
    2. Wait 10 seconds.
    3. Reinsert the CAM.
    4. Wait 10 seconds.
    ...before attempting to open the menu. With DD CAM sharing it's quite easy to confuse the CAM and/or TV Server because all tuners that are linked to the CAM will get menu notifications.
     

    Stéphane Lenclud

    Development Group
  • Team MediaPortal
  • April 29, 2013
    2,569
    1,293
    Germany Germany
    Country flag
    Same in both TV Server Config and MediaPortal?
    I had no idea you could access CI menu from the configuration.

    I just gave it a quick try without removing the CAM.
    • Launch TV Server configuration.
    • Try Open Menu on both tuner, no response.
    • Closed TV Server configuration.
    • Open CI Menu from DD software, works just fine.
    • Closed DD software.
    • Launch TV Server configuration.
    • CI Menu now somewhat working, though after a while going through menus you get duplicates entries showing up.
    upload_2017-4-16_10-55-19.png
     

    mm1352000

    Development Group
  • Team MediaPortal
  • September 1, 2008
    21,571
    8,219
    New Zealand New Zealand
    Country flag
    Try Open Menu on both tuner, no response.
    In my opinion this confirms my suspicion that the problem is likely with TV Server or the CAM itself.

    My feeling is that at this point we really need repeatable errors with the previously described CAM reinsertion process and/or new log files with full screenshots/description of steps and errors before we could make any progress.

    I further note that when testing or trying to reproduce errors, all interactions with the CAM menu should be for one tuner and with one program. If you test with multiple tuners and/or multiple programs, the chance of confusing the CAM is very high, and if the CAM gets confused you could see any and all manner of errors... but none of them would be real/actionable.
     

    mm1352000

    Development Group
  • Team MediaPortal
  • September 1, 2008
    21,571
    8,219
    New Zealand New Zealand
    Country flag
    I further add that access to particular parts of the CAM menu (eg. entitlements, supported CA system IDs) may be affected by the CAM usage at the time. In other words, if the CAM is busy decrypting channels, it may not be possible to access certain details. That would be a limitation imposed by the CAM and/or DD driver MTD design. As such there'd be nothing we could do about it.
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    V Skin With Menu Editor MediaPortal 1 Skins 13
    Rob Hexenmeister Navigation problems adding menu buttons to EPG General Support 1
    M [Duplicate] Always enter full screen when entering TV from main Menu Feature Requests 1
    A [solved] menu sounds General 1
    M.Hulot Warum Blu-ray-Menü nicht anwendbar bei MediaPortal? Allgemeines Supportforum 5
    HTPCSourcer [Evaluate] Remove obsolete menu entries from "MP2 TV Configuration" MediaPortal 2 0
    U [DVD] DVD Menu Navigation for HID keyboard Improvement Suggestions 0
    G How best to get cover art for tracks to show up on the Audio Menu (Latest Added, Unplayed)? General 9
    R TV menu icon does not work to return from sub-menu item Submit: Bug Reports 4
    cbr954rr Possibillity to add more Movie Folders in Menu General 5
    HTPCSourcer [Finished] [MP2-793] 'Restart MP2' as additional option in shutdown menu Archive 6
    N How do I get the menu in the WebRadio plugin WMC Skin 1
    HTPCSourcer Forum Advertisement covers menu Online Facilities 1
    krebbi [solved] Delete Media Files via Context Menu General 8
    A Hanging in Recorded TV menu General Support 1
    C video wont open, screen goes black and reverts to video menu General Support 3
    badboyxx Unable to play BD-Iso watch/edit Videos 7
    stirlinghart How to remove menu overlay General 11
    ajs [Proposal] Improving the MP1 Small Splash Screen, providing nicer Image :) MediaPortal 1 3
    J Blue Screen Error Submit: Bug Reports 0
    azzuro [fixed] 5011: Version label in Splash screen - pos, size from skin MediaPortal 1 61
    G [solved] Black Screen on all videos after upgrading to either 1.23 or 1.24 from 1.22 General Support 4
    F After resume, TV Server connection screen is shown General Support 4
    H random black screen live tv and videos (amended) General Support 0
    M Change size of the splash screen Skins and Plugins Installer (MPEI) 2
    Similar threads

























    Top Bottom