Configuring TV Server to use NAS (1 Viewer)

toricred

MP Donator
  • Premium Supporter
  • August 29, 2006
    141
    9
    United States of America United States of America
    Country flag
    I'm using MediaPortal 2.2.3 on a Windows 10 Home 64 machine. I need to keep my recordings on a NAS (Terra-Master F4-210) that is in the same workgroup and uses the same account that the MediaPortal2 Service is running under. When setting up recording directories I don't see a way to configure them to use a UNC path. How do I do that?
     
    Last edited:

    toricred

    MP Donator
  • Premium Supporter
  • August 29, 2006
    141
    9
    United States of America United States of America
    Country flag
    I finally got my NAS to show up in the Network area by turning on Jumbo Frames to max and changing from Auto Negotiation to Full Duplex Gigabit on the network adapter advanced settings.
     

    dasfiend

    New Member
    July 30, 2020
    2
    0
    United States of America United States of America
    Country flag
    I'm seeing this issue even after updating the 2 network adapter settings above. Very similar deployment here, Win 10 64 bit home edition, MP2.2.3.

    My issue differs in that I have mounted a network drive (M:\) and that isn't listed in the file explorer when I try to edit my TV Recording path.

    User accounts shouldn't be a factor here as it's a mounted drive and is accessed by all sorts of other applications.
     

    morpheus_xx

    Lead Dev MP2
  • Team MediaPortal
  • March 24, 2007
    11,400
    6,972
    Germany Germany
    Country flag
    My issue differs in that I have mounted a network drive (M:\) and that isn't listed in the file explorer when I try to edit my TV Recording path.

    User accounts shouldn't be a factor here as it's a mounted drive and is accessed by all sorts of other applications.
    Mounted network drives (like your M:\) are only available inside the current user's scope, so if you are logged in as "User1", the mapping is only valid there.

    In contrast to the MP2-Server/TV-Plugin, which runs as "Network Service" (or "Local System") account, it doesn't know about your user's profile mounted drives. That's why you always need to use UNC paths for network resources, and no mounted drive letters.
     

    dasfiend

    New Member
    July 30, 2020
    2
    0
    United States of America United States of America
    Country flag
    Thanks for the explanation.

    Why can't we manually edit the file path? I would be able to use my network drive with it's UNC if I could type in the address. Going through windows network discovery services has been a pain with my shared drive via Ubuntu.

    Thanks again.
     

    morpheus_xx

    Lead Dev MP2
  • Team MediaPortal
  • March 24, 2007
    11,400
    6,972
    Germany Germany
    Country flag
    If you are not able to select the recording from TV configuration GUI, you might consider editing it directly inside the database. MP2 uses SQLite and you can use tools like SQLite Expert Personal, open "C:\ProgramData\Team MediaPortal\MP2-Server\Database\MP2TVE_3.s3db" and change in the table "card" all "recordingFolder" rows to the wanted UNC path.

    It looks like:
    1596473398817.png


    But you should make sure to have enough rights on the share to allow MP2 to write there as network account (i.e. "write" to "everyone", or "PCNAME$" which is the network account of the PC)
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    M 1.25.0 Tv Server Configuration Italian Dvb-t2 test channel preview error Television (MyTV frontend and TV-Server) 2
    framug [solved] Some changes/fix in MP1 configuration client and server Submit: code patches (MediaPortal/TV-Server/etc.) 14
    O [solved] MP2.2.1 TV-Server Configuration wont start after initial installation General 10
    H MP2.2 client TV-Server configuration General 17
    splatterpop My optimized dvb epg configuration for tv server MediaPortal 1 Talk 0
    B Preview Channel in TV-Server Configuration not work Newcomers Forum 0
    K MP2 - V2.1 [MP2-763] Interface configuration for RTSP streaming server lost on every restart Older releases 6
    N [solved] MediaPortal do not show TV Channels, although Channels found in TV-Server Configuration Television (MyTV frontend and TV-Server) 7
    N [solved] MediaPortal do not show TV Channels, although Channels found in TV-Server Configuration Codecs, External Players 2
    W Info on particular configuration Installation, configuration support 2
    horned_reaper MediaPortal configuration error log message General Support 1
    T TV Series Configuration funktioniert nicht Plugins & Erweiterungen 15
    HTPCSourcer [Evaluate] Remove obsolete menu entries from "MP2 TV Configuration" MediaPortal 2 0
    T I cannot get a basic media import-what is the best configuration? General 10
    P Configuration Moving Pictures Support d'installation et de configuration 0
    cbr954rr How to disable a pre-configured plugin? General 2
    A FB funktioniert plötzlich nicht mehr korrekt Allgemeines Supportforum 0
    M.Hulot [solved] PureVisionHD 1080 taucht nicht im Configurator auf Allgemeines Supportforum 12
    Edwardfc Fanart setup/configuration General 10
    Edwardfc [solved] Mp 2.2.1 Configuration Issues - Goes to Sleep while playing Music General 6
    P Configuration closes on channel scan General 26
    M App Icon starts Configuration Installation, configuration support 3
    D [solved] How to configure subtitle color in MP 2.2.1? General 5
    sve1 Invalid DateTime when loading configuration tool Trakt 5
    johns11 [solved] MP2.2 TV configuration issue General 4
    Similar threads

























    Top Bottom