Control.Focus unstable since RC4

Discussion in '1.0 RC4 and SVN Builds' started by pilehave, December 3, 2008.

  1. pilehave
    • Premium Supporter

    pilehave Community Skin Designer

    Joined:
    April 2, 2008
    Messages:
    2,566
    Likes Received:
    500
    Gender:
    Male
    Occupation:
    Technical consultant, marketing
    Location:
    Hornslet
    Ratings:
    +517 / 0
    Home Country:
    Denmark Denmark
    TV-Server Version: RC4
    MediaPortal Version: RC4
    MediaPortal Skin: Monochrome 16:9
    Windows Version: XP Pro SP3
    CPU Type: AMD x2 4850e 2.5 GHz 45w
    HDD: Samsung Spinpoint 250GB 2.5"
    Memory: 4 GB DDR2 800 MHz Dual-Channel
    Motherboard: Gigabyte GA-MA78GM-S2H (rev 1.0)
    Video Card: Onboard AMD Radeon HD 3200
    Video Card Driver: Catalyst 8.8 official
    Sound Card: Onboard ALC889A
    Sound Card AC3:
    Sound Card Driver:
    1. TV Card: Terratec Cinergy 2400i DT
    1. TV Card Type: DVB-T
    1. TV Card Driver:
    2. TV Card:
    2. TV Card Type:
    2. TV Card Driver:
    3. TV Card:
    3. TV Card Type:
    3. TV Card Driver:
    4. TV Card:
    4. TV Card Type:
    4. TV Card Driver:
    MPEG2 Video Codec:
    MPEG2 Audio Codec:
    h.264 Video Codec:
    Satelite/CableTV Provider:
    HTPC Case:
    Cooling:
    Power Supply: picuPSU 120W
    Remote: Logitech 885
    TV: LG 42PM1MA
    TV - HTPC Connection: HDMI



    With RC4, a bug was introduced, that makes the use of Control.Focus pretty much unsable. I don't know what, but something changed.

    The three screenshots below (from 3 different skins; StreamedMP, Aeon Wide and MediaStream) are all provoked on RC4 by pressing Esc, Enter or H (home) many times in a row, aborting some of the animations or conditional visiblities.

    example1.jpg
    View attachment 30007
    example2.jpg

    Now, this is IMPOSSIBLE to do in both RC2, RC3 and all the SVN's after RC3. RC4 = broke skin-engine.

    I can see the problem at home and at work, both running RC4, one Vista and one XP SP3.

    Anyone care to comment on this? Once the problem is there, only solution is to restart MediaPortal.

    The error.log is FILLED with stuff like this:

    2008-12-03 13:04:39.890625 [ERROR][MPMain]: GUIWindow: FreeResources exception - System.NullReferenceException: Objektreferencen er ikke indstillet til en forekomst af et objekt.
    ved MediaPortal.GUI.Library.GUIButtonControl.Update()
    ved MediaPortal.GUI.Library.GUIControl.ReStorePosition()
    ved MediaPortal.GUI.Library.GUIGroup.ReStorePosition()
    ved MediaPortal.GUI.Library.GUIGroup.FreeResources()
    ved MediaPortal.GUI.Library.GUIWindow.FreeResources()
    2008-12-03 13:04:39.921875 [ERROR][MPMain]: Exception :confused:ystem.IndexOutOfRangeException: Indekset lå uden for arrayets grænser.
    ved MediaPortal.GUI.Library.GUITextureManager.GetFileName(String fileName)
    ved MediaPortal.GUI.Library.GUITextureManager.Load(String fileNameOrg, Int64 lColorKey, Int32 iMaxWidth, Int32 iMaxHeight)
    ved MediaPortal.GUI.Library.GUIImage.AllocResources()
    2008-12-03 13:04:39.921875 [ERROR][MPMain]: Exception :Indekset lå uden for arrayets grænser.
    2008-12-03 13:04:39.921875 [ERROR][MPMain]: site :confused:ystem.String GetFileName(System.String)
    2008-12-03 13:04:39.921875 [ERROR][MPMain]: source :Core
    2008-12-03 13:04:39.921875 [ERROR][MPMain]: stacktrace: ved MediaPortal.GUI.Library.GUITextureManager.GetFileName(String fileName)
    ved MediaPortal.GUI.Library.GUITextureManager.Load(String fileNameOrg, Int64 lColorKey, Int32 iMaxWidth, Int32 iMaxHeight)
    ved MediaPortal.GUI.Library.GUIImage.AllocResources()
     
  2. Google AdSense Guest Advertisement



    to hide all adverts.
  3. pilehave
    • Premium Supporter

    pilehave Community Skin Designer

    Joined:
    April 2, 2008
    Messages:
    2,566
    Likes Received:
    500
    Gender:
    Male
    Occupation:
    Technical consultant, marketing
    Location:
    Hornslet
    Ratings:
    +517 / 0
    Home Country:
    Denmark Denmark
    In the SVN posted 7. december these problems are still there. I can provoke this error in just about every skin besides Blue3 normal. Blue 3 Wide can do it to, I think its something in the memory handling, since the problem scales with the size of the skin-cache.

    Small skin = takes longer to create the error, large skin = shorter time to create the error.

    I think that the ressources are not being disposed correctly since the memory usage is nearing 280 MB before "crashing".

    Please, someone confirm that I'm not the only one having this problem? I see it on two independent machines with RC4 and different skins?
     
  4. Paranoid Delusion
    • Team MediaPortal

    Paranoid Delusion Moderation Manager

    Joined:
    June 13, 2005
    Messages:
    13,062
    Likes Received:
    1,481
    Gender:
    Male
    Occupation:
    Electrical Engineer
    Location:
    Cheshire
    Ratings:
    +1,482 / 0
    Home Country:
    United Kingdom United Kingdom
    Show System Specs
  5. pilehave
    • Premium Supporter

    pilehave Community Skin Designer

    Joined:
    April 2, 2008
    Messages:
    2,566
    Likes Received:
    500
    Gender:
    Male
    Occupation:
    Technical consultant, marketing
    Location:
    Hornslet
    Ratings:
    +517 / 0
    Home Country:
    Denmark Denmark
  6. Harley
    • Team MediaPortal

    Harley Retired Team Member

    Joined:
    May 7, 2004
    Messages:
    2,053
    Likes Received:
    996
    Location:
    Germany
    Ratings:
    +999 / 0
    Home Country:
    Germany Germany
    Hi,

    can you please test with current svn, we have reverted some changes.
    So hopefull it will be fixed with that.

    Greetings Harley
     
  7. pilehave
    • Premium Supporter

    pilehave Community Skin Designer

    Joined:
    April 2, 2008
    Messages:
    2,566
    Likes Received:
    500
    Gender:
    Male
    Occupation:
    Technical consultant, marketing
    Location:
    Hornslet
    Ratings:
    +517 / 0
    Home Country:
    Denmark Denmark
    Making a build from latest SVN did not solve my problems with the RC4, unfortunately. This time no errors was logged, but this has happened a couple of times before, so don't take this as an indication of anything :(

    For me: the revert of the fix 1755 was not the solution.

    I'll try and find the problem in older SVNs.
     
  8. mattsk88

    mattsk88 Community Skin Designer

    Joined:
    March 27, 2008
    Messages:
    363
    Likes Received:
    216
    Ratings:
    +216 / 0
    Home Country:
    This sounds like the a problem that I'm hearing lots of reports of in regards to StreamedMP, as pilehave stated this crash will occur after a little while using the basichome screen due to the amount of animations present.
     
Loading...

Users Viewing Thread (Users: 0, Guests: 0)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
  • About The Project

    The vision of the MediaPortal project is to create a free open source media centre application, which supports all advanced media centre functions, and is accessible to all Windows users.

    In reaching this goal we are working every day to make sure our software is one of the best.

             

  • Support MediaPortal!

    The team works very hard to make sure the community is running the best HTPC-software. We give away MediaPortal for free but hosting and software is not for us.

    Care to support our work with a few bucks? We'd really appreciate it!