Creating a new thread flattens my laptop

Discussion in 'Website/Forum/Wiki Feedback' started by CyberSimian, January 6, 2017.

  1. CyberSimian
    • Team MediaPortal

    CyberSimian Test Group

    Joined:
    June 10, 2013
    Messages:
    1,645
    Likes Received:
    542
    Gender:
    Male
    Location:
    Southampton
    Ratings:
    +962 / 3
    Home Country:
    United Kingdom United Kingdom
    Show System Specs
    With the current version of the forum software, whenever I create a new thread, it takes ages to type the title. This is because after every character typed, my CPU usage increases to 100% for several seconds, at the end of which the cursor is often moved to the start of the title (so subsequent characters typed appear at the start of the title, if I am not paying attention).

    I think that this 100% CPU-usage is caused by the forum software scanning a list of previous threads to find ones to show in the "similar threads" list, to encourage the user to post in an existing thread if there is a relevant one. There is nothing wrong with that, except when it loads the user's computer so much that the computer becomes unusable for several seconds. :mad:



    Is it possible to restrict in some way the CPU load? Perhaps by not scanning so many threads? (E.g. limit the threads scanned to those started within the last x months.) Thank you. :)

    -- from CyberSimian in the UK
     
  2. Google AdSense Guest Advertisement



    to hide all adverts.
  3. high
    • Team MediaPortal
    • IT-Admin

    high Administrator

    Joined:
    August 31, 2004
    Messages:
    4,742
    Likes Received:
    3,114
    Gender:
    Male
    Occupation:
    Sysadmin
    Location:
    Isselburg/NRW
    Ratings:
    +4,828 / 6
    Home Country:
    Germany Germany
    Show System Specs
    that simply shouldn't happen, your browser just starts the search but does not perform it. If it takes more then ms something is wrong. Please start with cleaning your cache and let me know which browser/version you use
     
  4. CyberSimian
    • Team MediaPortal

    CyberSimian Test Group

    Joined:
    June 10, 2013
    Messages:
    1,645
    Likes Received:
    542
    Gender:
    Male
    Location:
    Southampton
    Ratings:
    +962 / 3
    Home Country:
    United Kingdom United Kingdom
    Show System Specs
    I am using the current version of Firefox (50.1.0) on Windows XP. :eek:

    I am not sure which cache to clear. I emptied "...\me\Local Settings\Temporary Internet Files", but there were only circa 2500 files (3.5 MB). Are there any other folders that I should clear?

    The 100% CPU usage occurs only while I type the thread title. Performance is OK when I type the body of the post.

    -- from CyberSimian in the UK
     
Loading...

Users Viewing Thread (Users: 0, Guests: 0)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
  • About The Project

    The vision of the MediaPortal project is to create a free open source media centre application, which supports all advanced media centre functions, and is accessible to all Windows users.

    In reaching this goal we are working every day to make sure our software is one of the best.

             

  • Support MediaPortal!

    The team works very hard to make sure the community is running the best HTPC-software. We give away MediaPortal for free but hosting and software is not for us.

    Care to support our work with a few bucks? We'd really appreciate it!