Creating mask for image, will not work (1 Viewer)

D3ltoroxp

MP Donator
  • Premium Supporter
  • June 1, 2008
    3,308
    205
    Germany Germany
    Hello Com,

    i will create a new mask for fanart, so my steps are ::

    Create new file in paint.net and give him the size 1047 * 589 fill it with black, then i go to effects and make round corner, save it as png with transparent. So no i choose it with my texture but now i have no image shown anymore. When i use the defaul mask was in titanius it works, but with false corners.

    Here my mask and my code. What i'm doing wrong, or is there limitation for mask size ?

    XML:
    <control>
    <description>Background</description>
    <type>image</type>
    <id>0</id>
    <posX>436</posX>
    <posY>200</posY>
    <width>1047</width>
    <height>589</height>
    <shouldCache>true</shouldCache>
    <texture mask="LatestMedia_poster_mask_big.png">#latestMediaHandler.movingpicture.selected.fanart2</texture>
    <animation effect="fade" start="0" end="100" time="500" reversible="false" delay="400">Visible</animation>
    <animation effect="fade" time="250">WindowOpen</animation>
    <animation effect="fade" time="250">WindowClose</animation>
    <visible>control.isvisible(2000)</visible>
    </control>
    Greet's and thanks for read
     

    Attachments

    wizard123

    Retired Team Member
  • Premium Supporter
  • January 24, 2012
    2,543
    2,615
    United Kingdom United Kingdom
    Country flag
    Have you cleared the cache and restarted mp ? masks will not work unless they are in the cache. Do you get any errors or does the image show as normal ?

    Also use the should cache option carefully with big images as too many will slow your gui down on some machines.
     

    D3ltoroxp

    MP Donator
  • Premium Supporter
  • June 1, 2008
    3,308
    205
    Germany Germany
    Yes after a tip from mrbonsen i cleared the cache but no changes. Without mask the image will show normaly. Errors in the log, hm where i must search for them, in mediaportal.log ? So you mean i should not cache this big images ?

    With this little mask it works, but then it is streched to much.
     

    Attachments

    wizard123

    Retired Team Member
  • Premium Supporter
  • January 24, 2012
    2,543
    2,615
    United Kingdom United Kingdom
    Country flag
    If you have logs set to debug then you would usually see them in mediaportal.log yes.
    So you mean i should not cache this big images ?
    You can cache what you want but personally from experience i would not cache larger images because it can impact gui performance if you cache too many at a large size. This option does not just cache them to bitmaps like normal it holds the images in video memory.

    If i was you i would adjust the mask size so it is large enough to not appear stretched but so it is still under 1000 pixels either H or W.
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    Top Bottom