Dependency error on install v2.3.2.0 (1 Viewer)

Rob Hexenmeister

MP Donator
  • Premium Supporter
  • May 12, 2011
    190
    42
    Slaithwaite
    Home Country
    United Kingdom United Kingdom
    Country flag
    Good evening,

    I am getting the dependency error when trying to install using the stand alone MPEI.

    The latest version is not showing in the extension manager.

    Any suggestions anyone?
    Many thanks

    RH

    ps mp version 1.17.0.0
     

    doskabouter

    Development Group
  • Team MediaPortal
  • September 27, 2009
    4,023
    2,260
    Nuenen
    Home Country
    Netherlands Netherlands
    Country flag
    for older Mediaportal versions you need to stick with 2.3.1 Mind you, not much had been changed between 2.3.1 and 2.,3.2, most important change was to support the new mediainfo interface
     

    Rob Hexenmeister

    MP Donator
  • Premium Supporter
  • May 12, 2011
    190
    42
    Slaithwaite
    Home Country
    United Kingdom United Kingdom
    Country flag
    This version has SSL problems that were fixed in new versions (I don’t remember exactly, but it’s either 1.21 or 1.22 or 1.23) :)

    Many thanks all of you for the replies.

    This is a shame as I need to stick with 1.17.0.0 for now because somewhere in those later versions there is a change which makes my iMON display conflict with the volume bar. I went down the upgrade route some months back and ended up having to revert. There's a thread on that saga somewhere.

    My reason for wanting to upgrade OV is because ITV player isn't working. ("Unable to play the video. No URL".)

    Do any of you know of a workaround?


    Many thanks
    RH
     

    Attachments

    • log.zip
      14.7 KB · Views: 0

    ajs

    Development Group
  • Team MediaPortal
  • February 29, 2008
    13,974
    8,529
    Kyiv
    Home Country
    Ukraine Ukraine
    Country flag
    May be better solve IMon display vs Volume bar conflict?

    --
    WBR, ajs :):whistle::coffee:
     

    doskabouter

    Development Group
  • Team MediaPortal
  • September 27, 2009
    4,023
    2,260
    Nuenen
    Home Country
    Netherlands Netherlands
    Country flag
    ITV Player is a plugin within onlinevideos which can be updated regardless of the version of onlinevideos.
    So updating onlinevideos in basics is not going to help fix ITV. You should ask @Brownard (owner of the itv part) if he's able to fix it
     

    Rob Hexenmeister

    MP Donator
  • Premium Supporter
  • May 12, 2011
    190
    42
    Slaithwaite
    Home Country
    United Kingdom United Kingdom
    Country flag
    May be better solve IMon display vs Volume bar conflict?

    --
    WBR, ajs :):whistle::coffee:

    Hello everyone!

    An update! It has taken 5 months for me to get to this point. I have IMON working, Volume OSD working and I am primed to reinstall FLIRC which has not been the problem.

    Firstly, I've had to do a reinstall on a new SSD anyway because the boot sector of my HTPC got damaged and I was stuck in the repair loop. Disaster. But luckily all my data was backed up and this therefore created an opportunity.

    What I have discovered:

    Well, for me IMON+Volume OSD worked fine on early releases of MP up to around 1.8 then started tripping over. There is a well documented fix with a replacement minidisplay.dll library which many of you using IMON will remember.

    Circa MP 1.15 the IMON library was integrated and versions circa 1.15 to 1.17 seem to work with IMON and volume OSD happily working in tandem. That is what I am currently using again.

    This post may be of interest, particularly what Stéphane said on 29-05-2016
    [solved] - Mini Display MP 1.13 and Volume OSD

    At some point after 1.17 things go awry again and the volume OSD-IMON combination fail. This is what happened to me, and no amount of patching MiniDisplay.dlls etc solved the problem. Working out why is above my pay grade. I can't get any further.

    I am pleased to say though that I appear to have most things working on an older MP build (1.17). FLIRC is an absolute whizz. It emulates just about any IR remote as a USB keyboard and I am delighted with that.

    The one problem I have, and I really need help and would like to get it working, is that I need an older compatible version of Online Videos to work with MP 1.17 either to install through MPEI or manually with a bit of assistance. Can anyone help? I can't find anything on the downloads page.

    If I can get hold of that then this little saga will be complete.



    Well, I would love to do that as I would like to take advantage of all the latest plug-ins but above is a reminder of just how difficult it was to get IMON and volume working again.

    Kind regards
    RH
     

    ajs

    Development Group
  • Team MediaPortal
  • February 29, 2008
    13,974
    8,529
    Kyiv
    Home Country
    Ukraine Ukraine
    Country flag
    Unfortunately I did not understand what the conflict is, and it is always there, it doesn’t matter if the fix for volume is on or not?

    --
    WBR, ajs :):whistle::coffee:
     

    Rob Hexenmeister

    MP Donator
  • Premium Supporter
  • May 12, 2011
    190
    42
    Slaithwaite
    Home Country
    United Kingdom United Kingdom
    Country flag
    Unfortunately I did not understand what the conflict is, and it is always there, it doesn’t matter if the fix for volume is on or not?

    --
    WBR, ajs :):whistle::coffee:

    Evening AJS,

    There is something inside iMon manager I think which conflicts with MP. Depending on your settings you either end up with no volume OSD at all, or one which appears with every up-down-left-right remote click, or the volume stuck and not changing. I tried every permutation of volume setting I could think of, including master volume, wave etc etc etc but to no satisfactory conclusion.

    I ended up reverting to 1.17 which works, and I now only use iMon manager to drive the VFD because I have got FLIRC to handle the remote control.

    Everything was fine... until I started missing out on updated plugins and online videos stopped working....

    I have of course looked for alternatives to iMon Manager (tried and failed to get LCD Smartie to work with the VFD), also tried Doskabouter's plug in which but unfortunately that depends on iMon Manager being open...

    So I am up bit of a gum tree. If I could find a way of driving the display from MP without iMon manager then I could uninstall it. That would be great.

    ...or...

    If the conflict in MP was solved. That would also be great

    ...or...

    If I could fix the underlying problems with Online Videos and remain on 1.17. Not so great but it would at least get me up and running again,

    Kind regards
    RH
     

    Users who are viewing this thread

    Similar threads

    Very odd. Thank you for looking. I am mystified then. If ever I find a solution I will post it. Thank you RH
    Very odd. Thank you for looking. I am mystified then. If ever I find a solution I will post it. Thank you RH
    Good evening all, I am getting an error dialog when Online Videos opens : "Error in update: "Automatic update disabled. Check your...
    Replies
    8
    Views
    546
    Evening everyone, Is anyone operating Windows 10 and the latest installation of Mediaportal with iMON Frontview working, in particular the display. I am not bothered about the remote as I successfully use FLIRC for that. The VFD display is critical to me, so I need to know if it is reliable, with no black displays etc, Many thanks RH
    Evening everyone, Is anyone operating Windows 10 and the latest installation of Mediaportal with iMON Frontview working, in...
    Evening everyone, Is anyone operating Windows 10 and the latest installation of Mediaportal with iMON Frontview working, in...
    Replies
    0
    Views
    187
    Just about done! Most things are reinstated. A few issues with my Fanart, but I think that may be waiting for the scraper in FanartHandler to pick them up again from the old thumbs. Time will tell. I have moved all of my files on to a larger HDD and reduced the number that I had from two to one, so if it was a power supply issue...
    Just about done! Most things are reinstated. A few issues with my Fanart, but I think that may be waiting for the scraper in...
    Over the past few days MP has become a bit unstable and I have noted an error when exiting MP Configuration. The logs don't give...
    Replies
    9
    Views
    365
    I think there's a master table here http://install.team-mediaportal.com/MPEI/extensions.txt with a list of urls to all the plugin sources. Don't know exactly who has rights to change that
    I think there's a master table here http://install.team-mediaportal.com/MPEI/extensions.txt with a list of urls to all the plugin...
    I am attempting a virgin installation and configuration of MP1 v1.26 on a fresh installation on windows 8.1 Pro x64. When i try to...
    Replies
    7
    Views
    765
    • Sticky
    We have just released MediaPortal 1.29 The Phantom Menace Highlights of this release Bugfixes: [MP1-5081] - WatchDog not switch Mediaportal log to Debug level [MP1-5082] - Error when MP restart [MP1-5086] - XMLTV Import error - An item with the same key has already been added. Since Pre-Release : [MP1-5089] - MpurlSourceSplitter...
    We have just released MediaPortal 1.29 The Phantom Menace Highlights of this release Bugfixes: [MP1-5081] - WatchDog not switch...
    We have just released MediaPortal 1.29 The Phantom Menace Highlights of this release Bugfixes: [MP1-5081] - WatchDog not switch...
    Replies
    0
    Views
    183
    Top Bottom