DJBlu's Custom Sky Data Grabber for MP1.9 onwards

Discussion in 'General Development (no feature request here!)' started by ears, October 1, 2014.

  1. ears

    ears Portal User

    Joined:
    October 7, 2008
    Messages:
    162
    Likes Received:
    27
    Ratings:
    +59 / 0
    Original thread - more documentation and earlier versions available here - https://forum.team-mediaportal.com/...r-including-sky-uk-channel-epg-grabber.96767/

    Comprehensive installation guide


    Please find attached a universal installer for MediaPortal 1.9. This will install full MediaPortal 1.9 with the Sky Grabber modification integrated. This installer should work if you're installing MP for the first time or upgrading from a relatively recent (probably about 1.4 onwards) version of MP.

    EDIT - 1.10 & 1.11 available now - linked at the bottom of this post. All the points below still apply.

    Please read the following points carefully
    • This installer has the standard protection that prevents upgrade from previous GIT installations disabled. This allows you to install this modified MP version over a previous modified MP version. The installer will tell you that you cannot upgrade an earlier GIT version, but it will allow you to do it anyway. Please only install this version over previous Sky Grabber modified versions of MP. You risk losing data if you install over other non-standard versions of MP.
    • If you have never installed MP before, this installer will be all you need. You do not need to copy any additional DLLs and you don't need to install any other MP versions first.
    • If you already have MP installed, this installer will still be all you need. It will upgrade an existing version.
    • Installing MediaPortal 1.9 from this installer seemed to reset my Titan skin settings. I suspect that this standard behaviour and not a specific issue with this installer. Running the Titan editor and simply saving without changing anything reset my settings back to how they were before the install.
    • This version has a few additional log entries during install so if you have issues please post your logs on this thread.
    • This customisation is not officially supported by Team MediaPortal. There is limited support available for this customised version of MediaPortal.
    • There's a fair bit of new code in here. I've tested it successfully myself but I'd advise letting a few people test and feed back first, before everyone installs it.



     
    Last edited: December 29, 2015
    • Thank You! Thank You! x 9
    • Like Like x 2
  2. Google AdSense Guest Advertisement



    to hide all adverts.
  3. MonkeyJug

    MonkeyJug Portal Member

    Joined:
    October 18, 2012
    Messages:
    34
    Likes Received:
    3
    Gender:
    Male
    Ratings:
    +6 / 0
    Home Country:
    United Kingdom United Kingdom
    great work, ears! i will try and find time tomorrow evening to install this and report back...
     
  4. theidiot
    • Premium Supporter

    theidiot MP Donator

    Joined:
    January 12, 2009
    Messages:
    96
    Likes Received:
    3
    Ratings:
    +6 / 0
    Show System Specs
    Just upgraded. Only one issue aside from the one you reported ears, Titan was reset for me too, and that was MySQL didn't stop in a timely manner. But tbh it was doing that anyway.

    Cheers ears, that worked really well!
     
  5. colossus-x

    colossus-x Portal Member

    Joined:
    December 4, 2007
    Messages:
    30
    Likes Received:
    7
    Ratings:
    +8 / 12
    Home Country:
    Ireland Ireland
    I got this msg when installing over the previous most recent version, just in case it's of any any importance.

    "Invalid file handle 92 "

    I'm not 100% sure if it was 92 or some other number.

    The installation continued as normal and I seem to have started up okay now.
     
  6. MonkeyJug

    MonkeyJug Portal Member

    Joined:
    October 18, 2012
    Messages:
    34
    Likes Received:
    3
    Gender:
    Male
    Ratings:
    +6 / 0
    Home Country:
    United Kingdom United Kingdom
    absolutely amazing work, ears! upgraded perfectly in literally seconds (using streamedMP skin). i used to only update with every even number build, due to having to do a complete uninstall beforehand (and with my particular setup, this was VERY time-consuming), but this is just fantastic that it now updates custom builds!
     
    Last edited: November 19, 2015
    • Like Like x 3
  7. desidunda

    desidunda Portal Member

    Joined:
    November 16, 2010
    Messages:
    14
    Likes Received:
    0
    Gender:
    Male
    Location:
    Southampton, United Kingdom
    Ratings:
    +0 / 0
    Home Country:
    United Kingdom United Kingdom
    Show System Specs
    thanks @ears Just updated from 1.6 to 1.9 last night. went in tv server config stopped the service manually and started the update with your installer every thing went smoothly and working as it should and for the first time ever installation did retain my setting as well. So many thanks for continuing @DJBlu work.
     
  8. onetoomany

    onetoomany Portal Pro

    Joined:
    July 5, 2005
    Messages:
    122
    Likes Received:
    1
    Location:
    UK
    Ratings:
    +2 / 0
    ears - thanks for doing this.

    I've just upgraded from 1.6 - not sure whether it is because I'm using MS Sql or older version of MP, but it seems to have dropped all the data.
    No worries for me as I'd backed up, but just to flag.
     
  9. jonm

    jonm Portal Pro

    Joined:
    January 12, 2009
    Messages:
    429
    Likes Received:
    13
    Gender:
    Male
    Occupation:
    Geeky stuff
    Location:
    Wales
    Ratings:
    +15 / 0
    Home Country:
    Wales Wales
    Show System Specs
    I just tried this and MySQL now seems to be broken, I can't connect to it from the PC it's running on. Any ideas on how to fix?

    Update - fixed it, eventually. Not sure what happened there, completely unrelated to this grabber I think.
     
    Last edited: October 9, 2014
  10. ctrlz

    ctrlz Portal Member

    Joined:
    April 15, 2014
    Messages:
    9
    Likes Received:
    0
    Gender:
    Male
    Ratings:
    +0 / 0
    Home Country:
    United Kingdom United Kingdom
    Show System Specs
    I'm having trouble getting this working.

    I just upgraded from the 1.7.0 hotfix to the 1.9.0 pre-release. I've never used the custom sky data grabber before but wanted to start using it (I was using the webEPG plugin before with freesat).

    I upgraded again using the installer in this thread and followed the instructions above. When I get to the stage of clicking "Grab" on the general tab of the plugin config, it comes back with "UnknownError". Tried a couple of times and got the same. No channels whatsoever in the channel list at that point.

    When I looked in the logs there was an error about some missing columns in the "Program" table in the database. Could this be because I'm using the sky grabber for the first time and those columns have never been added (I notice the original post advises to only install this version over previous sky grabber-modified versions)?

    I can't post the logs at the moment I'm afraid as I've done a reinstall and restored my old database to get the TV working again. If need be I can try the upgrade again and post results.
     
  11. ctrlz

    ctrlz Portal Member

    Joined:
    April 15, 2014
    Messages:
    9
    Likes Received:
    0
    Gender:
    Male
    Ratings:
    +0 / 0
    Home Country:
    United Kingdom United Kingdom
    Show System Specs
    Any help with this? Can't get it working with either the 1.9.0 Final version on the homepage, or with the installation file posted in this thread.

    If I try and use the sky grabber with the MediaPortal 1.9.0 Final version, TV Server config exits with this error:

    Code (Text):
    1.  
    2. Problem signature:
    3.   Problem Event Name:    CLR20r3
    4.   Problem Signature 01:    SetupTv.exe
    5.   Problem Signature 02:    1.9.0.0
    6.   Problem Signature 03:    54168061
    7.   Problem Signature 04:    Custom Data Grabber
    8.   Problem Signature 05:    1.0.0.3
    9.   Problem Signature 06:    4e5261dd
    10.   Problem Signature 07:    1d
    11.   Problem Signature 08:    0
    12.   Problem Signature 09:    System.MissingMethodException
    13.   OS Version:    6.3.9600.2.0.0.256.48
    14.   Locale ID:    2057
    15.   Additional Information 1:    5861
    16.   Additional Information 2:    5861822e1919d7c014bbb064c64908b2
    17.   Additional Information 3:    d1d9
    18.   Additional Information 4:    d1d94a13d3609d6b740644c12508f581
    19.  
    20. Read our privacy statement online:
    21.   http://go.microsoft.com/fwlink/?linkid=280262
    22.  
    23. If the online privacy statement is not available, please read our privacy statement offline:
    24.   C:\Windows\system32\en-GB\erofflps.txt

    If I try to use the version posted in this thread, I see some SQL errors in the logs (I've now uploaded the logs) and I can't even timeshift channels any more. Note that this happens before I even try a grab with the custom grabber.

    The SQL errors only appear in the logs when using the installer version posted in this thread. I suspect it's something to do with the fact that I'm using SQL Server rather than MySQL.
     
Loading...

Users Viewing Thread (Users: 0, Guests: 0)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
  • About The Project

    The vision of the MediaPortal project is to create a free open source media centre application, which supports all advanced media centre functions, and is accessible to all Windows users.

    In reaching this goal we are working every day to make sure our software is one of the best.

             

  • Support MediaPortal!

    The team works very hard to make sure the community is running the best HTPC-software. We give away MediaPortal for free but hosting and software is not for us.

    Care to support our work with a few bucks? We'd really appreciate it!