Emulators 0.9.1 (25/11/2018) (1 Viewer)

heiserfeger77

Portal Pro
November 10, 2009
275
63
Germany Germany
Country flag
Did you also compare the same items in every skin? It's hard to judge for me, because I do not know if Donkey Kong is showing a description in other skins/themes.
Yes. The same problem with every game in this skin. The desciption of Donkey Kong is shown in all other skins. Donkey Kong is only for example to show what i mean.
 

ge2301

MP2 Design
  • Team MediaPortal
  • January 11, 2014
    6,614
    2,384
    Stuttgart
    Germany Germany
    Country flag
    @Brownard
    where did you push the latest changes of emulators? It seems some parameters as "rating" are empty now.
    I want to look up in models what has changed. Generally I fear some old skin files came into the latest build. Many things are disorted or broken. But I could not find something better in my backups. I guess I need to go through and fix everything.
     

    Brownard

    Development Group
  • Team MediaPortal
  • March 21, 2007
    1,945
    1,297
    United Kingdom United Kingdom
    Country flag
    where did you push the latest changes of emulators?
    To this branch.
    It seems some parameters as "rating" are empty now.
    I want to look up in models what has changed.
    TheGamesDb switched to a new API and retired the old one, the new API doesn't provide user ratings (there is talk on their forum of reinstating it). Besides that, I don't think I changed any of the skin bindings/files. I'll have a proper check later.
    EDIT: I can confirm most of the issues above, I expect what has happened is that the base templates have been changed in Win10 and I need to update the emulators skin files to account for that. I can probably do it later this evening. My fault for not properly testing :whistle:
     

    ge2301

    MP2 Design
  • Team MediaPortal
  • January 11, 2014
    6,614
    2,384
    Stuttgart
    Germany Germany
    Country flag
    TheGamesDb switched to a new API and retired the old one, the new API doesn't provide user ratings (there is talk on their forum of reinstating it). Besides that, I don't think I changed any of the skin bindings/files. I'll have a proper check later.
    EDIT: I can confirm most of the issues above, I expect what has happened is that the base templates have been changed in Win10 and I need to update the emulators skin files to account for that. I can probably do it later this evening. My fault for not properly testing :whistle:
    Ok, I'll wait until your base changes and then fix a few more things. If you need help with something, just let me know.
     

    Brownard

    Development Group
  • Team MediaPortal
  • March 21, 2007
    1,945
    1,297
    United Kingdom United Kingdom
    Country flag
    Ok, I'll wait until your base changes and then fix a few more things. If you need help with something, just let me know.
    I've pushed some changes that get the skin files working. I haven't made any cosmetic changes though so if you wouldn't mind taking a look ;)
     

    ge2301

    MP2 Design
  • Team MediaPortal
  • January 11, 2014
    6,614
    2,384
    Stuttgart
    Germany Germany
    Country flag
    I've pushed some changes that get the skin files working. I haven't made any cosmetic changes though so if you wouldn't mind taking a look ;)
    I'll take a look. I just pulled your branch, but can not build the server. Is there any trick I have to consider? The assembly reference seems to be missing.
    upload_2018-11-24_13-14-39.png
     

    ge2301

    MP2 Design
  • Team MediaPortal
  • January 11, 2014
    6,614
    2,384
    Stuttgart
    Germany Germany
    Country flag
    Update: I removed the reference from emulators.server and readded it again, now it compiles.
    Maybe you can retry on your side, I tried several clean builds before and every thime got same error.
     

    ge2301

    MP2 Design
  • Team MediaPortal
  • January 11, 2014
    6,614
    2,384
    Stuttgart
    Germany Germany
    Country flag
    @Brownard Your fixes did basically all, so easy job for me. I did some minor adjustments and added a missing label. Everything is pushed.
    So after you checked everything is working you can punlish a fixed version I think (I fixed the broken reference, but not sure if correctly) :)

    Btw. would be cool, of emulators also supports home content. Havining latest played or favourite games in home screen would be cool ;):whistle:
     

    Brownard

    Development Group
  • Team MediaPortal
  • March 21, 2007
    1,945
    1,297
    United Kingdom United Kingdom
    Country flag
    So after you checked everything is working you can punlish a fixed version I think (I fixed the broken reference, but not sure if correctly) :)
    Thanks, the reference change looks correct, I'll look into the home content too.

    @heiserfeger77 new version in first post which hopefully resolves the skin issues.
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    Top Bottom