[no Bug] EVR Hiccups without frame drops (nvidia refresh rate bug) (1 Viewer)

nyt

Retired Team Member
  • Premium Supporter
  • October 15, 2009
    199
    48
    United States of America United States of America
    Country flag
    MediaPortal Version: 25153 svn
    MediaPortal Skin: blue3
    Windows Version: windows 7 ultimate 64
    CPU Type: intel E6300 wolfdale 2.8ghz
    HDD: seagate 1.5tb
    Memory: 4gb ddr2 800
    Motherboard: zotac gf-9300-d-e
    Video Card: onboard nvidia ion 9300
    Video Card Driver: 191.07
    Sound Card: nvidia hdmi output
    Sound Card AC3:
    Sound Card Driver: 1.00.00.59
    MPEG2 Video Codec: coreavc, ms dtv-dvd
    MPEG2 Audio Codec: ffdshow, mpc-mpa
    h.264 Video Codec: coreavc
    Satelite/CableTV Provider:
    HTPC Case: inwin bp655
    Cooling:
    Power Supply: inwin 200w
    Remote: imon
    TV: JVC RS10
    TV - HTPC Connection: hdmi

    This has been happening since before RC1. I'm running SVN 25153 and I have tested with multiple audio and video codecs. I have tested this with all plugins disabled and using the blu3 skin and it still occurs.

    While watching video (x264 23.976) there are brief stutters every now and then without dropped frames. This may happen with other media types as well, but I have not tested yet. While watching the shift-1 menu, the green line slowly starts to rise, then falls sharply and playback stutters. There are no dropped frames and nothing in the logs.

    My only guess is that MP is getting ahead of itself with rendering then has to delay causing a stutter. This is just a guess, I have no idea what is actually going on behind the scenes with this one. Playback is perfectly smooth otherwise. Sometimes it takes minutes for this to happen, sometimes its every 15-30 seconds. It seems to happen faster on media that's easier to render.

    SS1: perfectly smooth playback then the drop. There is a noticeable stutter.

    SS2: the red/yellow were sawtoothing a bit, but while this was happening, the green stayed very flat.

    SS3: green line going up

    SS4: green line dropping, no frames dropped, visual stutter
     

    Attachments

    mylle

    Portal Pro
    April 14, 2005
    574
    66
    Denmark
    Denmark Denmark
    Re: EVR Hiccups without frame drops

    This is kinda the same thing i am experiencing but only on dvb-s channels and only if i have dvbsubs enabled.

    Are you using dvbsubs?
     

    Kotik

    MP Donator
  • Premium Supporter
  • March 19, 2009
    699
    485
    Athens
    Greece Greece
    Re: EVR Hiccups without frame drops

    Could you pls try to force 23.976Hz refresh rate over the nvidia control panel?

    You can do it by creating a custom resolution and editing the timings manually.

    I suggest this since i see that you have 23.970 instead of 23.976.

    + Disable Jitter Correction in ffdshow audio codec. --> ffdshow audio decoder configuration --> Decoder Options --> Jitter Correction (uncheck it)
     

    nyt

    Retired Team Member
  • Premium Supporter
  • October 15, 2009
    199
    48
    United States of America United States of America
    Country flag
    Re: EVR Hiccups without frame drops

    Could you pls try to force 23.976Hz refresh rate over the nvidia control panel?

    You can do it by creating a custom resolution and editing the timings manually.

    I suggest this since i see that you have 23.970 instead of 23.976.

    + Disable Jitter Correction in ffdshow audio codec. --> ffdshow audio decoder configuration --> Decoder Options --> Jitter Correction (uncheck it)
    I'll try adding the custom timing. This happens even if I'm not using ffdshow for audio decoder.

    Also, logs incoming. Generating some now.
     

    nyt

    Retired Team Member
  • Premium Supporter
  • October 15, 2009
    199
    48
    United States of America United States of America
    Country flag
    Re: EVR Hiccups without frame drops

    logs.

    I stopped playback about 5 seconds after the stutter.

    03-03-2010 02:29:18.305 [13ec]Scheduling sample from the past (19.03 ms, last call to NotifyWorker: 29.74 ms)
    03-03-2010 02:29:18.305 [7e4]Dropping frame, behind 19.07 ms, last sleep time 0.00 ms.
    03-03-2010 02:30:50.715 [acc]OnClockPause
    03-03-2010 02:30:50.719 [9cc]Should not be processing data in pause mode

    nothing in evr.log. The dropped frames are from when video started playing.
     

    nyt

    Retired Team Member
  • Premium Supporter
  • October 15, 2009
    199
    48
    United States of America United States of America
    Country flag
    Re: EVR Hiccups without frame drops

    Could you pls try to force 23.976Hz refresh rate over the nvidia control panel?

    You can do it by creating a custom resolution and editing the timings manually.

    I suggest this since i see that you have 23.970 instead of 23.976.

    + Disable Jitter Correction in ffdshow audio codec. --> ffdshow audio decoder configuration --> Decoder Options --> Jitter Correction (uncheck it)
    having trouble actually getting it to accept 23.976. It's at 23.974 at the moment and its happening much slower. I'll keep messing with this... is 24000 / 1001 really that hard? =[ damnit nvidia.

    ok so it looks like this is an nvidia driver issue. They use 23.970 as default and their control panel does not exactly make it easy to adjust modes.
     

    Kotik

    MP Donator
  • Premium Supporter
  • March 19, 2009
    699
    485
    Athens
    Greece Greece
    Re: EVR Hiccups without frame drops

    Actually they use 23.971 although on my ION system i am able to force 23.976.

    Try the NVIDIA 196.21 drivers since those are the ones i am using.

    And yes custom resolution panel sucks. This is how i am using it: Go over the nvidia panel and force 24 Hz then close the panel and open it again, after that try to create a custom resolution and only change the automatic timings setting to "Manual" and go for 23.976 or as close to it as you can.
     

    nyt

    Retired Team Member
  • Premium Supporter
  • October 15, 2009
    199
    48
    United States of America United States of America
    Country flag
    Re: EVR Hiccups without frame drops

    Actually they use 23.971 although on my ION system i am able to force 23.976.

    Try the NVIDIA 196.21 drivers since those are the ones i am using.

    And yes custom resolution panel sucks. This is how i am using it: Go over the nvidia panel and force 24 Hz then close the panel and open it again, after that try to create a custom resolution and only change the automatic timings setting to "Manual" and go for 23.976 or as close to it as you can.
    23.976 -> 23.974
    23.977 -> 23.974
    23.978 -> 23.977

    will have to adjust some pixel settings I guess. What are yours set to?
     

    Kotik

    MP Donator
  • Premium Supporter
  • March 19, 2009
    699
    485
    Athens
    Greece Greece
    Re: EVR Hiccups without frame drops

    Don't bother with pixel settings.

    Mine is on 23.976-->23.976 but then again i am using VMR9 and XP.

    Keep it on 23.978 as this will give you the most close to 23.976 result.

    You could always try the Cyberlink Decoder as IMO it's DXVA performance is more smooth than CoreAVC's CUDA.

    Also check which Antivirus you are using, since for an example some versions of NOD32 will spike CPU usage which will result in video stuttering.

    Simply try it without an Antivirus.
     

    nyt

    Retired Team Member
  • Premium Supporter
  • October 15, 2009
    199
    48
    United States of America United States of America
    Country flag
    Re: EVR Hiccups without frame drops

    there are no cpu spikes, the playback is perfectly smooth except its out of sync with the refresh rate. I was able to get it to play perfectly with 23.976 with different pixel settings, however it moved my display down a bit =] I'm still trying to find the right settings.
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    Top Bottom