Excessive memory usage with certain skins while playing music

Discussion in 'General Support' started by Gcarr, November 16, 2015.

  1. Gcarr
    • Premium Supporter

    Gcarr MP Donator

    Joined:
    August 17, 2014
    Messages:
    67
    Likes Received:
    8
    Gender:
    Male
    Ratings:
    +16 / 0
    Home Country:
    United States of America United States of America
    Show System Specs
    Hi,
    I've noticed a problem with mediaportal crashing due to excessive memory use. When I play music, and leave client on the now playing screen, my memory usage will climb about 1 GB after about 1 1/2 hours. At that point I start getting errors about invalid thunbs and out of memory in the logs. Shortly after that, mediaportal will crash.

    I've tried disabling plug-ins (including fanart handler) with negative results. Two things have seemed to help so far... changing skins or navigating away from now playing to the home screen. I normally run mp-streamed but, avalon also shows this behavior. I tried Apollo and Default-wide and they don't appear to have the problem.

    Thanks,
    Glen


     

    Attached Files:

    • Thank You! Thank You! x 1
  2. Google AdSense Guest Advertisement



    to hide all adverts.
  3. mm1352000
    • Team MediaPortal

    mm1352000 Development Group

    Joined:
    September 1, 2008
    Messages:
    21,527
    Likes Received:
    4,736
    Ratings:
    +8,202 / 17
    Home Country:
    New Zealand New Zealand
    Hello Glen

    It seems odd that the problem only occurs in 2 out of 4 skins even with FanArt disabled, and for the system to be out of memory after playing only 17 songs. If memory is climbing to 1 GB, that's an average of ~64 MB per song. :confused:

    Do the significant memory use increases occur at the song changes, or does it climb steadily until crash (as suggested by the graph)?
    In the "memory-Capture.PNG" image, I don't understand the "scale" (for the vertical/Y axis). Are you able to explain?
    Would it be possible to attach screenshots of the now playing screens from each skin so we can try to compare which features are used?
     
  4. Gcarr
    • Premium Supporter

    Gcarr MP Donator

    Joined:
    August 17, 2014
    Messages:
    67
    Likes Received:
    8
    Gender:
    Male
    Ratings:
    +16 / 0
    Home Country:
    United States of America United States of America
    Show System Specs
    Hi mm1352000,
    In the graph above, the vertical axis is memory in tens of mb. So what it shows is a climb from 400mb to 1.5gb.

    I ran through some tests and couldn't see any correlation with songs changing. It does seem to only use memory on the Now Playing screen though. I tried several other screens with the music playing and each time memory would stop climbing but it still wouldn't get released.

    I've attached screen shots of default wide, mpstreamed and apollo. For some reason I can't get avalon to display the Now Playing screen. I've run out of time on it tonight so I'll have to try later to get it working and upload a screen shot for you. Thanks for looking. Oh, default wide is on the left, apollo then mpstreamed.
    Edit: Well, it appears I made a mistake about Avalon, memory is straight line all across the graph. I don't know what I was seeing the other day.


    defaultwide.PNG apollo.PNG mpstreamed.PNG
     
    Last edited: November 17, 2015
  5. mm1352000
    • Team MediaPortal

    mm1352000 Development Group

    Joined:
    September 1, 2008
    Messages:
    21,527
    Likes Received:
    4,736
    Ratings:
    +8,202 / 17
    Home Country:
    New Zealand New Zealand
    Hmmm, this is a bit of a puzzler. FanArt Handler is certainly the plugin that appears the most likely to cause a problem like this. I'm not an expert on this part of MediaPortal. Hopefully somebody else will be able to step in and suggest how to debug...
     
  6. Gcarr
    • Premium Supporter

    Gcarr MP Donator

    Joined:
    August 17, 2014
    Messages:
    67
    Likes Received:
    8
    Gender:
    Male
    Ratings:
    +16 / 0
    Home Country:
    United States of America United States of America
    Show System Specs
    Thanks for looking at it. Perhaps it's just something with that skin. After all this testing the Avalon skin is starting to grow on me so it's not so bad as I first thought :) Oh, I never mentioned that I see this problem on both my main HTPC and on a client in another room.
     
Loading...

Users Viewing Thread (Users: 0, Guests: 0)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
  • About The Project

    The vision of the MediaPortal project is to create a free open source media centre application, which supports all advanced media centre functions, and is accessible to all Windows users.

    In reaching this goal we are working every day to make sure our software is one of the best.

             

  • Support MediaPortal!

    The team works very hard to make sure the community is running the best HTPC-software. We give away MediaPortal for free but hosting and software is not for us.

    Care to support our work with a few bucks? We'd really appreciate it!