Filmtipset.se - Swedish grabber (1 Viewer)

emphatic

Design Group
  • Team MediaPortal
  • August 25, 2006
    3,600
    1,093
    Alingsås
    Sweden Sweden
    Country flag
    The latest version if broken for me.

    I tried to import two movies today, and the results I got back was some "<div" code (a rather long string actually) concerning "background image".

    Emph
    Looks like filmtipset changed some HTML code. You should be getting the same error with all versions of the scraper. I'll upload a fix shortly.
    Thanks. Here's a screen dump:



    Emph
     

    uffeb

    New Member
    September 7, 2007
    3
    0
    Sweden Sweden
    The latest version if broken for me.

    I tried to import two movies today, and the results I got back was some "<div" code (a rather long string actually) concerning "background image".

    Emph
    Looks like filmtipset changed some HTML code. You should be getting the same error with all versions of the scraper. I'll upload a fix shortly.
    :D

    :oops:I tried to understand the xml code, but failed!
     

    vuego

    Documentation Group
  • Team MediaPortal
  • August 5, 2006
    1,584
    744
    Göteborg
    Sweden Sweden
    Country flag
    • Thread starter
    • Moderator
    • #33
    I know what you mean, Uffe. It took me a couple of days before I could understand how to start creating the scraper :)

    Here's the fixed version 1.4.0 of the scraper.

    I improved the matching when there's movies with articles at the end. For example movies like "Wild, The.avi" should auto approve correctly now.
    I also added Language from IMDb. It's in English (will say English instead of Engelska) but it's better than nothing right? :)
     

    vuego

    Documentation Group
  • Team MediaPortal
  • August 5, 2006
    1,584
    744
    Göteborg
    Sweden Sweden
    Country flag
    • Thread starter
    • Moderator
    • #34
    Version 1.4.1

    armandp gave a good tip to improve the scraper. Sometimes there's several movies with the same name (alternate title is counted equal to title). In those cases the last movie would be auto approved, which was the least likely match since filmtipset probably would have the correct title at position #1.

    This is now fixed. See this post for details if interested :)
     

    Johan

    Portal Pro
    April 19, 2006
    443
    11
    44
    Sweden Sweden
    I am having problem with "Transformers: Revenge of the fallen (2009)".
    When going into plug-in config it says "Retrieving information" but it seems to get stuck.
    It seems to autodetect the correct movie but some problem with retrieving the data.

    Anyone else who have had problems?
     

    vuego

    Documentation Group
  • Team MediaPortal
  • August 5, 2006
    1,584
    744
    Göteborg
    Sweden Sweden
    Country flag
    • Thread starter
    • Moderator
    • #36
    You'll probably get this error on all movies today since themoviedb.org seems to be down. It's Moving Pictures' default backdrop source. As a workaround you could either wait for it to timeout or disable themoviedb.org as backdrop source.
     

    vuego

    Documentation Group
  • Team MediaPortal
  • August 5, 2006
    1,584
    744
    Göteborg
    Sweden Sweden
    Country flag
    • Thread starter
    • Moderator
    • #38
    Did you get HTML tags in the title?
    Most movies gets about 100 search matches on filmtipset but some goes directly to the movie information page. I tested about 200 movies without finding such a case. Disturbia is a good example. The Lookout is another :)

    Anyway I fixed it in v1.4.2.
     

    vuego

    Documentation Group
  • Team MediaPortal
  • August 5, 2006
    1,584
    744
    Göteborg
    Sweden Sweden
    Country flag
    • Thread starter
    • Moderator
    • #40
    If you use the U.S. ratings, couldn't we just create substitution images instead of the R, PG-13 etc that comes with our favorite skins? I'm currently using XFactor, and I'm sure that cul8er would be up to creating a nice looking pack. It shouldn't be very hard to do otherwise. Most Swedish releases doesn't use any real rating logos anyway, just the "Barntillåten", "Rekommenderas från 15 år" etc.

    Just my 2 cents.
    Emph
    Hey I used the Canal+ certification screen to create Swedish logos for XFactor.

    Here's Canal+' description of the different logos:
    Btl.png/7.png: Kan ses av alla
    11.png: Ej lämplig för personer under 10 år
    15.png: Ej lämplig för personer under 15 år
    18.png: Ej lämplig för personer under 18 år
    Just extract the files to ...MediaPortal\skin\XFactor\Media\Logos and that's it :)
     

    Attachments

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    Top Bottom