FireDTV Remote does not work (1 Viewer)

audioPitheco

MP Donator
  • Premium Supporter
  • February 2, 2009
    68
    2
    furlan
    Home Country
    Italy Italy
    TV-Server Version: 1.0 latest
    MediaPortal Version: 1.0 latest
    MediaPortal Skin: default (16/9)
    Windows Version: Vista 64bit Ultimate
    CPU Type: Intel Core 2 Quad Q6600
    HDD: SAMSUNG HD103UJ 1TB S-ATA2 32MB
    Memory: 4 Gigs
    Motherboard: Asus PQ5-Pro
    Video Card: ATI HD 4850 1GB GDDR3 PCI-E 2.0 DX10.1
    Video Card Driver: latest
    Sound Card: integrated in the mboard
    Sound Card AC3:
    Sound Card Driver:
    1. TV Card: FloppyDTV S2/CI
    1. TV Card Type: DVB-S2
    1. TV Card Driver: latest
    2. TV Card: FloppyDTV T/CI
    2. TV Card Type: DVB-T
    2. TV Card Driver: latest
    3. TV Card:
    3. TV Card Type:
    3. TV Card Driver:
    4. TV Card:
    4. TV Card Type:
    4. TV Card Driver:
    MPEG2 Video Codec: Cyberlink
    MPEG2 Audio Codec: Cyberlink
    h.264 Video Codec: Cyberlink
    Satelite/CableTV Provider:
    HTPC Case: Cooler Master Sileo RC-500-KKN1-GP
    Cooling: Noctua CPU Cooler NH-U9B
    Power Supply: Cooler Master Silent Pro M500W
    Remote: FireDTV Remote
    TV: Sony 32" FullHD KDL-32W4000
    TV - HTPC Connection: HDMI


    Hello to everybody in the forum.

    I've installed TV Server and MP Client in the same VISTA 64 machine in which I've placed a FloppyDTV-S2 and a FloppyDTV-T;

    I cannot configure MP Client to let it see the FireDTV Remote.
    The FireDTV remote works properly with "FireDTV Viewer" software but doesn't with MP Client.

    Perhaps the problem is that in the FireDTV remote config window of MP Client Setup the combo box that has to let me choose the TV Card to make as reciever, is empty!

    Thank You very much for Your valued help!
     

    flokel

    Portal Developer
  • Premium Supporter
  • October 11, 2005
    1,601
    168
    Unterfranken
    Home Country
    Germany Germany
    so you checked this box and chose one receiver
    and still nothing is happening ?

    firedtv.png
     

    audioPitheco

    MP Donator
  • Premium Supporter
  • February 2, 2009
    68
    2
    furlan
    Home Country
    Italy Italy
    so you checked this box and chose one receiver
    and still nothing is happening ?

    Thank You very much flokel for having answered!

    Yes, I checked the check-boxes exactly as in Your example attached. The problem, instead, is that I do not see any "receiver" in the combo-box (I'm C++ developer and I'm used to call combo-box the element that I've highlighted in the image attached): the combo-box is empty!

    Other info: I've closed the FireDTV Viewer IR exe that I found was in memory (try bar) because of an autostart default option of the FireDTV Viewer setup.... but still nothing.

    Guessing... mine is a client-server setup (MP Client + TV Server) even if is installed on the same machine (I've choose this configuration to let MP provide HDTV functions)... so the devices (FloppyDTV-S2 and FloppyDTV-T one installed in a front 3,5" slot and the other installed in a rear PCI slot, both with IR reciever) are controlled by the TV Server: is this the reason why the MP Client does not see the devices?

    Thanks a lot!
     

    Attachments

    • firedtv-mod.png
      firedtv-mod.png
      88 KB

    flokel

    Portal Developer
  • Premium Supporter
  • October 11, 2005
    1,601
    168
    Unterfranken
    Home Country
    Germany Germany
    Hi,

    could you post your log files after
    having started MP conf and tried to configure the remote in the fireDTV tab ?

    A guide for collecting and posting logs can be found in my signature.
     

    xcvb

    Portal Member
    November 13, 2008
    5
    0
    Home Country
    Austria Austria
    firedtv remote

    Hi!

    I have a similar problem. The remote was working with Mediaportal 0.2.3.
    Now I installed the MediaPortal 1.0 with SVN-Snapshot:-01-23-2009 22-00, but it isn't working any more.
    Maybe it is because I also upgraded the FireDTV driver to version: 081217_firedtv_beta_setup_5_3.
    The new FiresatApi.dll has version 1.11.2226.0. I have a backup of the mediaportal folder with the older 1.10.1.0 version of the .dll, but this one doesn't work either. Unfortonately I haven't got the older driver anymore.
    Next problem is that the remote now even won't work after downgrading to 0.2.3.
    I've attached the logs, and in the error log there are some firedtv errors, but the don't say anything to me.
    System is Vista business 64bit with SP1 and all windows updates.

    I hope anyone has some suggestions for me!
    Thanks,
    Eric
     

    chemelli

    Retired Team Member
  • Premium Supporter
  • September 28, 2006
    6,159
    2,264
    47
    Milano, Italy
    Home Country
    Italy Italy
    Country flag
    xcvb log:

    2009-02-03 17:40:09.365000 [ERROR][MPMain]: FireDTVRemote: SourceFilter Not Found

    audioPhiteco log:

    2009-02-04 00.21.43.451544 [Info.][Config Main]: FireDTV: FiresatApi.dll could not be found on your system!
    2009-02-04 00.21.43.451544 [ERROR][Config Main]: FireDTV: FiresatApi.dll could not be found on your system!

    Simone
     

    audioPitheco

    MP Donator
  • Premium Supporter
  • February 2, 2009
    68
    2
    furlan
    Home Country
    Italy Italy
    Grazie chemelli per aver risposto!
    Thank You chemelli for answering!

    New log, new error.

    2009-02-05 00.56.21.404611 [Warn.][Config Main]: x10Remote: Can't initialize
    2009-02-05 00.56.21.404611 [Info.][Config Main]: FireDTV: Using FiresatApi.dll located in MediaPortal's base dir C:\Program Files (x86)\Team MediaPortal\MediaPortal\FiresatApi.dll
    2009-02-05 00.56.21.404611 [Info.][Config Main]: FireDTV: error initializing Tentativo di caricare un programma con un formato non corretto. (Eccezione da HRESULT: 0x8007000B)
    2009-02-05 00.56.21.404611 [ERROR][Config Main]: FireDTV: error initializing Tentativo di caricare un programma con un formato non corretto. (Eccezione da HRESULT: 0x8007000B)

    There's someone throwing an exception ;-)

    From my DirectX Error lookup tool:

    HRESULT: 0x8007000b (2147942411)
    Name: ERROR_BAD_FORMAT
    Description: An attempt was made to load a program with an incorrect format.
    Severity code: Failed
    Facility Code: FACILITY_WIN32 (7)
    Error Code: 0x000b (11)

    Are You perhaps using the sdk "LoadModule" func?
     

    chemelli

    Retired Team Member
  • Premium Supporter
  • September 28, 2006
    6,159
    2,264
    47
    Milano, Italy
    Home Country
    Italy Italy
    Country flag
    maybe this dll doesn't like to be loaded in a x64 env.

    Simone
     

    xcvb

    Portal Member
    November 13, 2008
    5
    0
    Home Country
    Austria Austria
    As I said the errors don't say anything to me. What does: FireDTVRemote: SourceFilter Not Found mean?
    -Eric
     

    Users who are viewing this thread

    Similar threads

    Sorry for the late response. In my experience, the EPG grabbing of a single transponder takes 2 to 3 minutes. Afterwards it takes 1 to 2 minutes to write the data to disk. To speed up the EPG stuff (not only writing but also reading the EPG guide in MediaPortal), I changed the program table (and only that table) from InnoDB to...
    Sorry for the late response. In my experience, the EPG grabbing of a single transponder takes 2 to 3 minutes. Afterwards it takes...
    I get a few "Continuity error..." after the EPG scan finished: [2021-01-30 18:56:10,278] [4c45530] [18c8] - mhw reset [2021-01-30...
    Replies
    2
    Views
    1K
    It is looking and working very well now and I am almost at the point of switching my HTPC to MP2, madvr would definitely push me over the edge for sure.;)
    It is looking and working very well now and I am almost at the point of switching my HTPC to MP2, madvr would definitely push me...
    We are proud to present MediaPortal 2.3 MediaPortal 2.3 is a full-blown media center software that addresses the most common user...
    Replies
    4
    Views
    2K
    Hi mm1352000, first thanks for your lightning fast reply. Of course this is not an issue of Mediaportal. Sorry if this somehow sounded like that. I just wanted to check, if someone has made similar experience and possibly found a solution/driver that works. But the chances that a similar configuration is in use is pretty low, I...
    Hi mm1352000, first thanks for your lightning fast reply. Of course this is not an issue of Mediaportal. Sorry if this somehow...
    Hi, I guess I need some help from the experts here. If you are looking for the Log-Files, please be so kind and take a minute to...
    Replies
    2
    Views
    994
    I had this issue using MP 1.20 Windows 7 x64, AMD 5570 catylst divers 13.12, since upgrading to MP1.21 Final, this issue has disappeared, but now have issue where remote volume OSD is absent....which was working in MP 1.20, :(
    I had this issue using MP 1.20 Windows 7 x64, AMD 5570 catylst divers 13.12, since upgrading to MP1.21 Final, this issue has...
    The much delayed rollout of the Win 10 x64 1809 update finally arrived for my HTPC but after installing I ran into a number of...
    Replies
    4
    Views
    2K
    I'm a returnee to MP after several years and want to use my CEC remote box. I have the mpe1 files but have no idea where to copy them to. Can anyone point me in the right direction as my memory of the config is hazy and probably out of date anyway.
    I'm a returnee to MP after several years and want to use my CEC remote box. I have the mpe1 files but have no idea where to copy...
    I just installed MP2 yesterday. Getting the digital tuner going went pretty straight forward. Right now I mainly have 2 issues as...
    Replies
    2
    Views
    1K
    Top Bottom