FOCUS not on MP after resuming from sleep (1 Viewer)

stirlinghart

Portal Pro
July 22, 2011
110
2
Hi,

I have noticed that when the pc resumes from sleep Mediaportal 2.1.3 can not be controlled with the remote until you get the keyboard out and click the cursor anywhere inside mediaportal to focus windows on to it.

Does anyone know a fix for this?

Thanks heaps.
 

BlueMax1916

Super User
  • Team MediaPortal
  • Super User
  • January 29, 2007
    699
    124
    Germany Germany
    Country flag
    Hi,

    I face the same problem with MP2 and my solution is to press mute/unmute on the remote then the black screen goes away and I see the MP GUI again. The same happens after watching a movie and sometimes also after MP2 sits idle for a while and the screensaver kicks in. In my case this solution is only possible because my Intel Graphics Driver's HDMI audio sends a small 'loudness window' on the screen which kills the black screen. If there is a possibility for the MP2 developers ( @morpheus_xx ...) to have a software side fix for this then this would be great. It needs to delete the black layer in the foreground of the MP2 GUI. Woman Acceptacnbe Factor is low for such things ;)

    I know that MP1 has the same problem for some people and there is a so called FCU fix discussed in the 1.19 release thread.

    This problem has been introduced by Microsoft with Windows 1709 and the Internet is full with peoples complaining about it. See Windows 10 creators update - Screen does not come back on after sleep/hibernate as an example.

    I wanted to bring this to attention earlier but I face some time constraints right now. Just jumping on the bandwagon :D

    Cheers

    Blue Max
     

    joecrow

    Test Group
  • Team MediaPortal
  • August 9, 2012
    1,642
    1,233
    Germany Germany
    Country flag
    Although I never suffered the black screen problem with Win 10 1709 (did not seem to effect AMD GPUs) I had several other issues with that update. If you still have it I would strongly advise updating to the latest 1803 update as it seems to have fixed everything that went wrong after 1709.:)
     

    joecrow

    Test Group
  • Team MediaPortal
  • August 9, 2012
    1,642
    1,233
    Germany Germany
    Country flag
    Probably wise, if you are using an Nvidia GPU it might be a good idea to checkout their forum also.
     

    stirlinghart

    Portal Pro
    July 22, 2011
    110
    2
    Hi everyone, thank you all for your comments. I will try the mute button workaround for now and see how I go. The black screen does happen for a while but the other issue is that I can see the MP screen, no matter what menu/area it is on. Recordings for example screen, and then I cant use the remote until I get my keyboard out and click anywhere on the screen to focus it. Then....... I can use the remote.
     

    joecrow

    Test Group
  • Team MediaPortal
  • August 9, 2012
    1,642
    1,233
    Germany Germany
    Country flag
    Just a thought, do you have MP set to fullscreen (see attached screenshot of settings in MP config.) if not please give it a try (on my desktop PC I don't have that set and MP is not in focus on startup and then have the same problem as you with the remote, on my HTPC it is set and MP is always in focus on start and resume from sleep and the remote works). If it is set then try it with the second setting highlighted disabled (unticked).
    mp.jpg
     

    BlueMax1916

    Super User
  • Team MediaPortal
  • Super User
  • January 29, 2007
    699
    124
    Germany Germany
    Country flag
    @joecrow, he is on MP2. There is a fullscreen setting there but MP2 uses different programming techniques than MP1.


    Cheers


    Blue Max
     

    stirlinghart

    Portal Pro
    July 22, 2011
    110
    2
    Hi @joecrow, yes, I was going to say just that, MP2. It is on start on fullscreen. Could just be a bug that gets fixed in the next update. I dont think I can do much about it in the meantime.
     

    CyberSimian

    Test Group
  • Team MediaPortal
  • June 10, 2013
    2,024
    1,260
    Southampton
    United Kingdom United Kingdom
    Country flag
    on my desktop PC I don't have that set and MP is not in focus on startup and then have the same problem as you with the remote
    [off_topic]
    If you are using the Ortek/Hama remote on your desktop PC, and you are using the AutoHotKey script from the "Centarea HID" package, you should be able to press the START button on the remote to cause the MP1 window to be given the focus (the AutoHotKey script contains code specifically to do this). Please let me know if this does not work for you.
    [/off_topic]

    -- from CyberSimian in the UK
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    stirlinghart [duplicate] Mp not focused on after resuming from sleep 2.2 Archive 7
    F MCE Remote has no focus General 6
    M [further infos missing] Stuttery UI behaviour when in focus, super fast outside focus. Submit: Bug Reports 14
    cbr954rr Mp loose focus after switching tv off General 1
    N [Finished] Focus problems - I think I've found the bug MediaPortal 2 30
    HTPCSourcer [Rejected] Mouse movements and focus: Windows standards MediaPortal 2 3
    B [MP2-744] WMC home content focus improvements Archive 55
    S Resume Playback Annoyance Newcomers Forum 4
    joecrow MP 1 Hangs on resume fro sleep (TV) Watch / Listen Media 2
    joecrow 1.25.0 Radio Time plugin fails after Resume from Sleep with MP 1.25 Bugreports 4
    F After resume, TV Server connection screen is shown General Support 4
    Dark Eyes TVService locks up or fails to restart on resuming from sleep, and crashes when grabbing EPG Installation, configuration support 7
    P MP2 Client Screen Flickering on Resume General 2
    HTPCSourcer [fixed] [MP2-815] User not logged in when resuming from standby MediaPortal 2 17
    J Resume from Standby Last Module TV Showing TV Server Settings Television (MyTV frontend and TV-Server) 2
    R Media portal resumes with wrong screen resolution General Support 3
    B resume from within a folder Watch / Listen Media 0
    joecrow No Audio after MP Start/Resume from Sleep General Support 0
    R Weird sleep/resume loop General Support 4
    joecrow Further problem on resume from sleep (MP Crash) 1.21 5
    joecrow Loss of Navigation Sounds on Resume from Sleep Mp 1.21 General Support 10
    D [further infos missing] Problems switching to live tv channel after resume 2.2 Archive 1
    P Multiple clients - share resume/watched data General 1
    U IR Blaster doesn't work after system wake/resume General Support 6
    megahorst Mediaportal chrashs when the PC goes to suspend mode (or when it resumes?) 1.19 11
    Similar threads

























    Top Bottom