Forwarding / Skipping stops working once max. buffer size is reached (1 Viewer)

Muldini

Retired Team Member
  • Premium Supporter
  • February 11, 2007
    206
    0
    Germany Germany
    Think I found out what is causing this.
    Yesterday I tested if this is linked to buffer-file change. It actually is in some way.

    As soon as the max. buffer size is reached, skip forward or any other buffer related task doesn't work anymore.

    What happens if the max. buffer size is reached?

    When the Tv-Server starts, it creates buffer files in the following sheme:
    live1-0.ts.tsbuffer
    live1-0.ts.tsbuffer1.ts
    live1-0.ts.tsbuffer2.ts
    live1-0.ts.tsbuffer3.ts

    The longer you watch, the more it creates, for me it ends at the 6th (max. buffer size) file, once the "7th" is created, it overrides the 1st one.
    This is the exact moment when forwarding/skipping stops working.

    Regards,
    Muldini
     

    Peter Pan

    Portal Pro
    April 22, 2004
    119
    3
    Kiel
    Germany Germany
    Oh yes, sometime I have exactly the same problems.

    It did not help you, but it's good to hear, that I am not the only man with this kind of problem ;-)
     

    Eabin

    Retired Team Member
  • Premium Supporter
  • September 18, 2006
    465
    43
    this is just a quick note to confirm the timeshifting problem as described above. happens to me all the time when watching timeshifted TV.
     

    Rhys.Goodwin

    Portal Pro
    November 20, 2006
    336
    1
    New Zealand New Zealand
    Hi,
    For test:
    Single seat (latest TVE3 & MP SVN).
    You need a channel where show starts every 30 min or every hour.

    Test:
    Start watching Channel_A, Show_A, wait 20 min & "Pause" it.
    Leave this until Show_B starts + 10 min, then start the show again & try to skip +x min (here i can skip at most +3min & end it's comming after that).

    I have a mixed results after this test & sometimes i can skip step + 3 min & other times it goes straight to end, will test this further to see whats causing this to happen.

    Regards
    Roy
    Hey Roy,

    Have you had any luck tracking down the source of this problem? It's really makes timeshifting risky bussiness! ;-) Is this loaded in Mantis Or are the devs aware of or experiencing this?

    Cheers,
    Rhys
     

    Muldini

    Retired Team Member
  • Premium Supporter
  • February 11, 2007
    206
    0
    Germany Germany
    Seems fixed in latest SVN. Therefor a really big thanks!

    Can you tell me what "min buffer files" and "max buffer files" mean? I left it to standard 6 and 20, it creates 6 and starts overwriting the first one then.

    Also, what benefits would a different file size give?

    Regards, Muldini
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    P Another Fast Forward/Rewind/Skip/Replay Question General 3
    N [Finished] [MP2-806] Playing a recorded radio program does not show screen to allow skipping forward, etc MediaPortal 2 141
    FlatEric [solved] 5016: Same position for title and speed-info when forwarding watch/edit Videos 3
    badboyxx MP 1.22 final is crashing when jumping forward while playing DVD-Iso watch/edit Videos 26
    M Forwarding Cmd Line Arg in IRSS Run Program MediaPortal 1 Plugins 0
    T Fast Forward / Rewind Feature Requests 7
    HTPCSourcer MP2 - V2.1 Picture freeze when jumping forward Older releases 7
    F Show Player info while skipping Feature Requests 0
    doskabouter 1.23.0 Crash when skipping in a dvd Bugreports 3
    Rob Hexenmeister DVD Skip steps causing crash General Support 2
    BlueMax1916 [confirm] Music: Every 2nd track skipped MediaPortal 2 30
    D Skip to end/live during dvbip recording causes it to stop playing instead. General Support 15
    R MP 2.2 client spielt audio-titel kurz an und springt dann zum nächten Allgemeines Support- und Diskussionsforum 9
    G [solved] Cannot skip when programme info is visible Archive 20
    mickb [solved] Mediaportal Stops working General Support 5
    D [solved] Movie artwork download stopped working Submit: Bug Reports 9
    M MP 2.2.3 Unable to play .ts recordings and MediaPortal stops working for TV viewing General 31
    ajs [solved] 4982: Why this error hard stop when Mediaportal start? MediaPortal 1 3
    rsbrux IR has stopped working Remotes 4
    2BitSculptor MP 1.23.. music stops playing General Support 6
    M MP1 stops responding after Starting Plugins General Support 14
    fredco [solved] Large import not working Moving Pictures 15
    W Recordings will not stop General Support 8
    S [solved] Live TV playing stopped General 13
    R [solved] Watching a record during recording stops sometimes 2.2 Archive 30
    Similar threads

























    Top Bottom