harmony remote and usbuirt IR to control MP? (1 Viewer)

bergsprekken

Portal Member
February 8, 2009
15
0
41
Home Country
Norway Norway
I have the usb-uirt ir receiver for pc installed and it blinks when i hit something on the remote control.
The remote is Harmony 785 set to control "windows media center". I tried to set the remote settings in mediportal to mce control but it doesnt work. Is there something more i need for mediaportal to receive the commands, any software or remote drivers? Ive installed the drivers for usb-uirt..so I thought the only thing needed was to set harmony to act as a mce remote?


TV-Server Version: 1.0.0.0
MediaPortal Version: 1.0.0.0
MediaPortal Skin: blue3
Windows Version: Microsoft Windows XP Professional Version 2002 Service Pack 3
CPU Type: Intel Core 2 duo E6300 @ 1.86GHZ
HDD: Western Digital 74GB
Memory: 2GB DDR2
Motherboard: Asus P5K Deluxe wifi
Video Card: HSI Radeon HD 4650 silent
Video Card Driver: 8.561
Sound Card: ATI Function Driver for High Definition Audio - ATI AA01
Sound Card AC3: no AC3
Sound Card Driver: 5.0.50000.8
1. TV Card: Digital-Everywhere FloppyDTV T/CI
1. TV Card Type: DVB-T
1. TV Card Driver: 4.8.0
2. TV Card:
2. TV Card Type:
2. TV Card Driver:
3. TV Card:
3. TV Card Type:
3. TV Card Driver:
4. TV Card:
4. TV Card Type:
4. TV Card Driver:
MPEG2 Video Codec: MPV Decoder Filter
MPEG2 Audio Codec: MPA Decoder Filter
h.264 Video Codec: CoreAVC Video Decoder
Satelite/CableTV Provider:
HTPC Case: SilverStone
Cooling:
Power Supply:
Remote:
TV: Panasonic th42
TV - HTPC Connection: hdmi
 

piairo

New Member
March 20, 2008
1
0
Home Country
France France
Hi Bergsprekken,

Similar problem as you for the time, did you found a solution?
 

matis1

MP Donator
  • Premium Supporter
  • January 13, 2005
    139
    1
    Austria /Europe
    Home Country
    Austria Austria
    i am having the same problem again as it was about two years ago:
    drivers installed and USBUIRT connected to an USBport but MP doesnt recognize either driver or device...

    could someone of the devs look into that problem?
    thanks in advance
     

    mike0999

    Portal Member
    June 21, 2009
    13
    0
    Home Country
    United States of America United States of America
    Usbuirt IR to control MP?

    Hi

    I know this is an old thread, but I recently purchased a USBUIRT to use with mediaportal. It works briefly, and I can get it configured using the learn commands, but it will at some point just stop working. Also, if I go back to the mediaportal configuration program after it has stopped working, the check box that I selected to activate USBUIRT will have become unchecked on its own, and mediaportal tells me that the driver for the USBUIRT is not installed if I try to check the box again. If I go to the device manager, though, the driver is installed and says that it is working properly. Also, I can see that the device is responding to transmission of RF by flashing when I press the remote.

    Any thoughts? I am using the latest SVN version of mediaportal. I suppose I can uninstall everything and try it with the latest beta and alternatively production release.

    Has anyone else experienced that problem? Any suggestions? I didn't see anything in any of the logs that was useful.
     

    bergsprekken

    Portal Member
    February 8, 2009
    15
    0
    41
    Home Country
    Norway Norway
    Hello

    You should try to use EventGhost with its usb-uirt "plugin". I havent been able to set up usb-uirt and a remote with mediaportals own setup controls, but when I installed EventGhost and chose the usb-uirt plugin the remote suddenly works in mediaportal client.
    EventGhost
     

    mike0999

    Portal Member
    June 21, 2009
    13
    0
    Home Country
    United States of America United States of America
    Thanks. I'll give that a try. I'm actually wondering if I might have some sort of software conflict, but we'll see.
     

    D3tritus

    Portal Pro
    February 14, 2008
    62
    12
    I'm seeing something similar. Sometimes my USB UIRT just stops working with Mediaportal. I don't see any change in config or any driver issues, however, and simply shutting down MP and starting it again generally fixes the issue. It's intermittent though and difficult to reproduce... :(
     

    mdg78

    Portal Member
    February 23, 2009
    49
    2
    Providence, RI
    Home Country
    United States of America United States of America
    Just to add my experience here, I'm using a USB-UIRT with MP without an issue. I originally got the USB-UIRT to blast commands, so I had IRSS plugin set up for that. MY case has an imon pad, which I find pretty crummy. When I recently got a new remote, I used IRSS to get the commands from the USB-UIRT to MP, and it works pretty well. It took a while to set up (but I'm not using a MCE remote, which I think is supposed to go pretty quickly) but I haven't had any problems with it. I haven't tried the build-in USB-UIRT support in MPconfig, though. Don't know if this will help anyone. I would assume that EventGhost would work just as well as an earlier poster suggested, but I haven't used it.

    Michael
     

    D3tritus

    Portal Pro
    February 14, 2008
    62
    12
    Hmmm. I'm not using the IR Server Suite, but the built-in support. I'll look into installing IRSS and give that a try. Sounds like it could resolve the issues. I'll post back here next week once I've had time to look into it. Thanks for the post. :)
     

    Crackofdawn

    Portal Pro
    September 21, 2009
    75
    1
    Home Country
    United States of America United States of America
    I couldn't get my harmony to work with most functions in Mediaportal with the built in remote settings. I installed IR Server Suite and completely disabled the remote in MediaPortal, then in IRSS I chose my Harmony as an MCE Remote and in the harmony software I programmed the Harmony to emulate an MCE remote and everything just worked immediately without any additional configuration. Without IRSS many MCE functions like pause and stop didn't work.
     

    Users who are viewing this thread

    Similar threads

    Thanks. Your screenshot is showing the "TVGuide", the mentioned "MiniEPG" appears, if you press "enter" or "OK" during Live-TV. But you're right, the channel arrow and PIP button are not reachable by mouse, something insibile is overlapping them and preventing focus. I'll fix that. Anyway, I'll provide a new installer to you soon...
    Thanks. Your screenshot is showing the "TVGuide", the mentioned "MiniEPG" appears, if you press "enter" or "OK" during Live-TV. But...
    I have a new tuner card (Hauppauge model 01609: WinTV-quadHD). It has four tuners and also an IR remote control. I can't figure...
    Replies
    33
    Views
    753
    I have now connected the IR Receiver from the HAMA Remote and enabled the HDI in Remotes. It will worke
    I have now connected the IR Receiver from the HAMA Remote and enabled the HDI in Remotes. It will worke
    Hello I used SerialUIR on my old XP HTPC. But unfortunately I can't get it to work right now. I plugged the COM plug of the old...
    Replies
    4
    Views
    789
    Many people found the Lentoid decoder better optimised than LAV for software decoding. If you want to try it, download it from the link below, run reg.bat as an admin to install it and change the HEVC Video settings in MediaPortal Configuration/Codecs and Renderer...
    Many people found the Lentoid decoder better optimised than LAV for software decoding. If you want to try it, download it from the...
    For some unknown reason I can't play HEVC encoded video with MP1 on my system. I have tried every trick I know, but nothing works...
    Replies
    10
    Views
    703
    Hi catavolt, selling this HTPC does not mean that I will no longer be available to the community as a plugin developer. If there are severe problems with the plugins at the moment, I can try to analyze causes and find possible solutions. However, this will currently only have low priority, as I am responsible for employees and...
    Hi catavolt, selling this HTPC does not mean that I will no longer be available to the community as a plugin developer. If there...
    After many years as a MediaPortal supporter and plugin developer I will now have to say goodbye to my beloved HTPC for personal...
    Replies
    2
    Views
    2K
    Sorry for the late response. In my experience, the EPG grabbing of a single transponder takes 2 to 3 minutes. Afterwards it takes 1 to 2 minutes to write the data to disk. To speed up the EPG stuff (not only writing but also reading the EPG guide in MediaPortal), I changed the program table (and only that table) from InnoDB to...
    Sorry for the late response. In my experience, the EPG grabbing of a single transponder takes 2 to 3 minutes. Afterwards it takes...
    I get a few "Continuity error..." after the EPG scan finished: [2021-01-30 18:56:10,278] [4c45530] [18c8] - mhw reset [2021-01-30...
    Replies
    2
    Views
    1K
    Top Bottom