Hauppauge IR Blaster and IRSS - Standalone (1 Viewer)

ranlandau

New Member
March 19, 2013
4
0
42
Tel Aviv, Israel
Home Country
Israel Israel
Hi,

I've downloaded IRSS version 1.4.2.4290.
I'm trying to configure my Hauppuange IR Blaster (Came with HD-PVR 2) to learn new IR codes and blast them.

When i use the Debug client, after installing (as service, and as application), and both, disabling the IR software of Hauppuange and enabling it, i always get:

Learn IR :
- IR Server is not setup to support learning


What am i doing wrong? please help!

Thanks!
 

geoffstewart

MP Donator
  • Premium Supporter
  • October 12, 2008
    346
    112
    Ottawa
    Home Country
    Canada Canada
    in the IRSS config windw, you see a list of IR send and receive devices.

    Is there an entry there for the hauppauge ir blaster with checkboxes set for send and receive?

    edit: I added a screenshot of the config window I mean

    g
     

    Attachments

    • Screenshot from 2013-03-19 13:14:18.png
      Screenshot from 2013-03-19 13:14:18.png
      54.3 KB
    Last edited:

    ranlandau

    New Member
    March 19, 2013
    4
    0
    42
    Tel Aviv, Israel
    Home Country
    Israel Israel
    Hi,

    I know that window,

    But it seems Haupaunge has no transmit checkbox, and when i "detect" it's not found.
    only by selecting manually.
     

    geoffstewart

    MP Donator
  • Premium Supporter
  • October 12, 2008
    346
    112
    Ottawa
    Home Country
    Canada Canada
    Ya, figured.

    I've always read that the hauppauge blaster (HD-PVR or old school pvr-150, pvr-250, etc) were clunky and didn't work really well.

    Way back when I bit the bullet and got a USB-UIRT because at the time, it was the best alternative... not cheap, but it's been working flawlessly for about 10 years.

    I actually have 2 USB-UIRT... one on my server and the other on MP client in multi-seat setup.

    I think you may just not be able to do what you're looking for with that device.

    g
     

    ranlandau

    New Member
    March 19, 2013
    4
    0
    42
    Tel Aviv, Israel
    Home Country
    Israel Israel
    I purchased the latest HD-PVR2, and i thought it would work.
    I guess if there is no other solution, i'll go ahead an purchased the USBUIRT.

    Thanks.
     

    geoffstewart

    MP Donator
  • Premium Supporter
  • October 12, 2008
    346
    112
    Ottawa
    Home Country
    Canada Canada
    Unfortunately, I think that's what you're left with. There may be other IR blaster/receivers out there that are more economical, though.

    Good luck.

    g
     

    geoffstewart

    MP Donator
  • Premium Supporter
  • October 12, 2008
    346
    112
    Ottawa
    Home Country
    Canada Canada
    You managed to get USB-UIRT much faster than I was able ... cool.

    Do you have any other apps trying to use the USB-UIRT at the same time? Only one can use it at a time.

    In the config screen that I attached above, you have the USB-UIRT listed with checkboxes in both send and receive columns?

    g
     

    Weekend Wally

    New Member
    March 27, 2013
    1
    0
    47
    Home Country
    Canada Canada
    Ranlanau,

    I am in the exact same situation, just received my new HDPVR 2 with blaster. I haven't invested in the USB-UIRT yet, I am hoping I can get the built in one to work...

    Please keep this thread updated with you solution. If I find anything I will post here.

    Regards
    Wally
     

    hexed

    Portal Member
    January 18, 2007
    11
    0
    Home Country
    New Zealand New Zealand
    I've been happy with MCE up until recently, and want to explore Media Portal.

    What impresses me about MCE (I'm running Windows 7 32-bit) is the way it handles the IR blasting. It asks you to press the enter key on your STB remote, and it just automatically recognised my remote and everything has worked reliably.

    I installed Media Portal in the hopes of playing with it from time to time in the background with a plan to possibly moving to it.

    I use Live TV functionality with my Sky STB, so IR blasting is critical for me. I installed IR Server (I'd previously used this with great success on XP using GB-PVR as well as using HIP before that, so I'm familiar with configuring remotes with blasting) and have been trying to get it working all week.

    My first issue is that the HTPC says that the IR Server is not setup to support learning, as experienced by Ranlandau. I'm using a Hauppauge MCE remote kit that came with my PVR-500 MCE card.

    I tried all sorts of config options before resorting to using the usb IR receiver on my laptop which is running the same version of Windows. It was able to learn successfully. I copied the ir commands from the IR Server config folder of my laptop across to my HTPC and was eventually able to see that when I tested the blasting, the light lit up on my IR blasting bud. I wasn't able to get the STB to respond to the codes though.

    I then decided to turn off my plasma TV and sure enough, I was able to get codes to work for digits 1, 2, 4, 6, 7, 8 and 0. Not bad. This gave me hope that maybe I'd just been inconsistent with the learning, so I did a few iterations for the codes that didn't work. No luck.

    I then began to doubt that the blasting was happening, which was confirmed when I rechecked a known good code. Up to this point, it was very stable. The 1 digit was able to work for 1, 11 etc. It was no longer working. I'm not sure what caused this, but I suspected removing and replacing the IR receiver may have been the issue, so I did reboots prior to retesting.

    I gave up and went to bed. I made some progress, but was annoyed at the end, with the inconsistency. I haven't delved into the logs to see if there's a reason for the blasting to stop.


    I do have one question though - my MCE setup is very reliable with the STB blasting. Does anyone know if it's possible to export the IR codes from MCE somewhere? I suppose I could go through each remote option and try to figure out which one my remote is (it's not obvious from the STB - it's a Sky NZ Pace STB). But ideally, I could find the codes it uses in the registry, or at least an indication of what it's set to, so that I can import the perfect codes into IR Server Suite. If I can eliminate dodgy learned IR codes, that would be a big help.

    Another thing - I've noticed that if I learn the same remote button 8 times, it always varies in length and value. I try to be consistent and only press the button long enough to register the successful learning.


    Any help would be greatly appreciated, as I'm dying to dive into Media Portal further, but am not going to if I can't get blasting to work. I may end up buying a new IR receiver and remote if necessary, but it works so well with MCE.
     

    Users who are viewing this thread

    Top Bottom