HEVC Video, DTSX, ATMOS, DD+ Audio Codecs (1 Viewer)

bta489

Portal Pro
March 17, 2013
129
66
Germany Germany
Country flag
Hi there,

since Germany moved to HEVC with DVB-T2, whenever I add a recorded Movie to MovPic the Video Codec is filled with "v_mpegh/iso/hevc". This makes it impossible for it to have a corresponding Logo in the GUI and I have to manually change every movie I add to just "hevc".

I suppose it's just the normal output of MediaInfo for that Codec, but can there be anything done to override it and have a filename-friendly Codec-Value by default?
 

RoChess

Extension Developer
  • Premium Supporter
  • March 10, 2006
    4,345
    1,824
    Country flag
    I've got HEVC and 4K detection for skin working fine in MP-TVSeries, and Moving-Pictures.

    I decided to make them "pop" out more than the default skin, so I personally went with a blue HEVC logo, and a bright yellow 4K logo. Feel free to use the default `hevc.png` and `2160p.png` images if you prefer default look.

    Was able to play with size/aspect-ratio and placement with the Moving-Pictures skin, but not with MP-TVSeries, and haven't taken then time yet to fix that with transparent canvas padding. The following will work as-is, but I planned to submit this properly with adjusted images to the GitHub repositories of the respective plugin.

    Copy the attachments as follows:

    <skin folder>\Media\logos\resolution\4K.png
    <skin folder>\Media\logos\video\hevc2.png

    <skin folder>\Media\TVSeries\Logos\4K.png
    <skin folder>\Media\TVSeries\Logos\hevc2.png​

    And then make the following skin changes (they are for Titan Extended, but should work for most other skins with minor adjustments for MovPic placement by paying attention to the existing posX/posY of the entries above):

    TVSeries.SkinSettings.xml (parts in bold are changed)

    skin\Titan\Media\TVSeries\Logos\1080p.png;-;<Episode.videoWidth>;-;>;-;1820;-;AND;-;<Episode.videoWidth>;-;<=;-;1920;-;AND;-;;-;=;-;;-;<Restrict:Episode>
    skin\Titan\Media\TVSeries\Logos\4K.png;-;<Episode.videoWidth>;-;>;-;3640;-;OR;-;<Episode.videoHeight>;-;=;-;2160;-;AND;-;;-;=;-;;-;<Restrict:Episode>
    skin\Titan\Media\TVSeries\Logos\hevc2.png;-;<Episode.VideoFormat>;-;=;-;HEVC;-;OR;-;<Episode.VideoCodec>;-;=;-;h265;-;AND;-;;-;=;-;;-;<Restrict:Episode>

    skin\Titan\Media\TVSeries\Logos\h264.png;-;<Episode.VideoFormat>;-;=;-;AVC;-;OR;-;<Episode.VideoCodec>;-;=;-;h264;-;AND;-;;-;=;-;;-;<Restrict:Episode>
    movingpictures.mediainfo.xml (bold is new)

    <control Style="MediaLogos">
    <description>Video resolution</description>
    <type>image</type>
    <id>0</id>
    <posX>660</posX>
    <posY>890</posY>
    <width>92</width>
    <height>60</height>
    <texture>Logos\resolution\#MovingPictures.LocalMedia.videoresolution.png</texture>
    <keepaspectratio>yes</keepaspectratio>
    <visible>facadeview.list+Control.IsVisible(50)+!string.equals(#MovingPictures.LocalMedia.videowidth,3840)</visible>
    <animation effect="fade" time="250">WindowOpen</animation>
    <animation effect="fade" time="250">WindowClose</animation>
    </control>
    <control Style="MediaLogos">
    <description>Video resolution 4K Force</description>
    <type>image</type>
    <id>0</id>
    <posX>662</posX>
    <posY>898</posY>
    <width>72</width>
    <height>60</height>
    <texture>Logos\resolution\4K.png</texture>
    <keepaspectratio>yes</keepaspectratio>
    <visible>facadeview.list+Control.IsVisible(50)+string.equals(#MovingPictures.LocalMedia.videowidth,3840)</visible>
    <animation effect="fade" time="250">WindowOpen</animation>
    <animation effect="fade" time="250">WindowClose</animation>
    </control>

    <control Style="MediaLogos">
    <description>Video codec</description>
    <type>image</type>
    <id>0</id>
    <posX>740</posX>
    <posY>890</posY>
    <width>92</width>
    <height>60</height>
    <texture>Logos\video\#MovingPictures.LocalMedia.videocodec.png</texture>
    <keepaspectratio>yes</keepaspectratio>
    <visible>facadeview.list+Control.IsVisible(50)</visible>
    <animation effect="fade" time="250">WindowOpen</animation>
    <animation effect="fade" time="250">WindowClose</animation>
    </control>
    <control Style="MediaLogos">
    <description>Video codec HEVC</description>
    <type>image</type>
    <id>0</id>
    <posX>746</posX>
    <posY>894</posY>
    <width>80</width>
    <height>52</height>
    <texture>Logos\video\hevc2.png</texture>
    <keepaspectratio>yes</keepaspectratio>
    <visible>facadeview.list+Control.IsVisible(50)+string.contains(#MovingPictures.LocalMedia.videocodec,hevc)</visible>
    <animation effect="fade" time="250">WindowOpen</animation>
    <animation effect="fade" time="250">WindowClose</animation>
    </control>
    movingpictures.mediainfo.details.xml (bold is new)

    <control Style="MediaLogos">
    <description>Video resolution</description>
    <type>image</type>
    <id>0</id>
    <posX>1118</posX>
    <posY>898</posY>
    <width>92</width>
    <height>60</height>
    <texture>Logos\resolution\#MovingPictures.LocalMedia.videoresolution.png</texture>
    <keepaspectratio>yes</keepaspectratio>
    <visible>!Control.IsVisible(50)+ !Control.IsVisible(51) + !Control.HasFocus(10001)+ !Control.HasFocus(10002) + !Control.HasFocus(10005)</visible>
    <animation effect="fade" time="250">Visible</animation>
    <animation effect="fade" time="0">WindowClose</animation>
    </control>
    <control Style="MediaLogos">
    <description>Video resolution 4K Force</description>
    <type>image</type>
    <id>0</id>
    <posX>1120</posX>
    <posY>906</posY>
    <width>72</width>
    <height>60</height>
    <texture>Logos\resolution\4K.png</texture>
    <keepaspectratio>yes</keepaspectratio>
    <visible>!Control.IsVisible(50)+ !Control.IsVisible(51) + !Control.HasFocus(10001)+ !Control.HasFocus(10002) + !Control.HasFocus(10005)+string.equals(#MovingPictures.LocalMedia.videowidth,3840)</visible>
    <animation effect="fade" time="250">WindowOpen</animation>
    <animation effect="fade" time="250">WindowClose</animation>
    </control>

    <control Style="MediaLogos">
    <description>Video codec</description>
    <type>image</type>
    <id>0</id>
    <posX>1198</posX>
    <posY>898</posY>
    <width>92</width>
    <height>60</height>
    <texture>Logos\video\#MovingPictures.LocalMedia.videocodec.png</texture>
    <keepaspectratio>yes</keepaspectratio>
    <visible>!Control.IsVisible(50)+ !Control.IsVisible(51) + !Control.HasFocus(10001)+ !Control.HasFocus(10002) + !Control.HasFocus(10005)</visible>
    <animation effect="fade" time="250">Visible</animation>
    <animation effect="fade" time="0">WindowClose</animation>
    </control>
    <control Style="MediaLogos">
    <description>Video codec HEVC</description>
    <type>image</type>
    <id>0</id>
    <posX>1204</posX>
    <posY>904</posY>
    <width>80</width>
    <height>52</height>
    <texture>Logos\video\hevc2.png</texture>
    <keepaspectratio>yes</keepaspectratio>
    <visible>!Control.IsVisible(50)+ !Control.IsVisible(51) + !Control.HasFocus(10001)+ !Control.HasFocus(10002) + !Control.HasFocus(10005)+string.contains(#MovingPictures.LocalMedia.videocodec,hevc)</visible>
    <animation effect="fade" time="250">WindowOpen</animation>
    <animation effect="fade" time="250">WindowClose</animation>
    </control>
     

    Attachments

    Last edited:

    bta489

    Portal Pro
    March 17, 2013
    129
    66
    Germany Germany
    Country flag
    Thank you, @RoChess

    Maybe not the cleanest solution, but a workaround I can live with. I modified my skinfiles accordingly, so hopefully the next Movie I add will have all those fancy Logos right from the start. (y)
     

    RoChess

    Extension Developer
  • Premium Supporter
  • March 10, 2006
    4,345
    1,824
    Country flag
    I will update the MovingPictures mediainfo parsing to detect HEVC and set that as the VideoCodec. That will allow you to simply drop in a logo without using a string.contains skin expressions.
    Please expand the scan on audio information as well then for "Atmos".

    Original string is something like "E-AC-3+Atmos / E-AC-3" or "TrueHD+Atmos / TrueHD / AC-3", and then the "Atmos" part gets lost with the codec showing up as just "E-AC-3" or "TrueHD".

    The '+' character is allowed in filenames, so "E-AC-3+Atmos.png" and "TrueHD+Atmos.png" should work fine.

    I'm personally fine with "Atmos.png" taking precedence for both (and others) if that is easier.

    Not sure if DTS-X is covered by default, and I can't look at HTPC right now.
     

    RoChess

    Extension Developer
  • Premium Supporter
  • March 10, 2006
    4,345
    1,824
    Country flag
    @ltfearme, I got a few test files I can throw at it, if you have like a compiled test version of MovPic so I can look at logs to see what the detected, and create PNG files as needed.
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    bta489 [solved] Stuttering playback of edited recordings watch/edit Videos 2
    M 1.25.0 Tv Server Configuration Italian Dvb-t2 test channel preview error Television (MyTV frontend and TV-Server) 2
    M HEVC 10 bit washed out colours Codecs, External Players 3
    M Apollo Lake and Gemini Lake 4K HEVC HDR10 performance General 1
    Rob Hexenmeister Skinning Online Videos question OnlineVideos 2
    A [solved] How to Play All Videos in a List watch/edit Videos 3
    O 1.25.0 Codecs and Video Format for PlayStation 2 Codecs, External Players 0
    g0rsq Info box randomly popping up when watching TV or other video MediaPortal 2 Newcomers Forum 1
    I Video Playback Stuttering General Support 45
    B some videos jerky Television (MyTV frontend and TV-Server) 0
    B MP 2.2.3 Error playing videos from NAS Submit: Bug Reports 2
    T Kurze Tonaussetzter bei Videos und TV Allgemeines Supportforum 1
    mrmojo666 [Tv Server Plugin ]Direct Show Video Control Plugin 0.0.0.1 for Hauppauge PVR cards MediaPortal 1 Plugins 0
    ajs [Proposal] Video embedded cover MediaPortal 1 1
    G [solved] Black Screen on all videos after upgrading to either 1.23 or 1.24 from 1.22 General Support 4
    H random black screen live tv and videos (amended) General Support 0
    404 [solved] Live TV...video and audio freeze General Support 20
    R kein Ton bei TV, Video, Aufnahme, Musik Allgemeines Support- und Diskussionsforum 0
    U [solved] Dynamic Refresh Rate for 23fps video Watch / Listen Media 1
    J Debug OnlineVideos, How To? OnlineVideos 1
    A MP2.2.2, understanding movies/videos/tv and WTV recordings. General 16
    C Problem playing videos created on IPhone X and Samsung S9 General Support 2
    H [solved] Video database genres, sort titles and collection thumbnails Newcomers Forum 12
    M How to Watch my videos from my Media Portal to My TV without TV Tuner Newcomers Forum 1
    cbr954rr Issue BOOTSUWRNQ with online videos? Plugin Development 1
    Similar threads

























    Top Bottom