[fixed] Image browser crashing in Folder View (WMC skin) (1 Viewer)

Digsy

Portal Pro
August 29, 2018
189
19
50
Great Britain (UK) Great Britain (UK)
Country flag
MediaPortal 2 Version: 2.1.3

Description
Not sure if this is the correct way to submit a report, but I have uncovered a bug in a different thread. I have quoted the relevant posts below.
02-Sep-2018: Steps to reproduce updated.


Second update: I am also now getting image thumbs! I swear I didn't change anything, but I am now getting image thumbs for almost all my folders. Some still wont display. Maybe they will generate after more time.

There is now a new weird bug though.

If I have a folder with the right number of images in it to exactly fill the "grid" as far as the right hand side of the screen (in my case that's 8 columns of thumbs) then selecting any thumbnail in the 8th column makes MP2 crash. If there is less or more than 8 columns, it doesn't crash.
View attachment 198399
Can you try the library view (which is generally better to use). I have possibly an idea what could create the crash.
You are right. On screens with 8 columns of thumbs, in library view there is no crash if I select the thumbs in the 8th column.
Unfortunately my images are not that well organised, so I really need to use folder view :(
Reason is, that the folder style has a thumb layout and images a square layout. Before scrolling the crash happens because of not enough margins.
@Brownard
Any good idea? The folder style is common independent from aspect of other covers. The crash is probably created by smooth scrolling margins. I’ll try to fiddle a bit around tomorrow with the margins, if you do not have a better idea.

Steps to Reproduce:
In my case (may be different for other screen sizes / aspect ratios.
1) Use the WMC skin.
2) Create an image folder which has enough images in it to show 8 columns of thumbnails (enough columns to fill the screen, but not require sideways scrolling).
NOTE: The image folder MUST contain a subfolder (see below).
3) Browse to this folder and select any thumbnail in the 8th column. This should cause MP2 to crash.
Thumbs bug2.jpg
 
Last edited:

ge2301

MP2 Design
  • Team MediaPortal
  • January 11, 2014
    6,787
    2,435
    Stuttgart
    Germany Germany
    Country flag
    @Brownard
    When I want to enter folder view under images I always get and empty view and number of media items as "-1" or MP is crashing.
    The strange thing: I'm in "show all MI's" and when switching to folder view it sets automatically the filter "year".
    Unbenannt.jpg

    [2018-09-02 14:17:33,347] [577469 ] [InputMgr ] [INFO ] - WorkflowManager: Screen 'home' successfully shown
    [2018-09-02 14:17:33,347] [577469 ] [AMQ 'ScreenManager'] [DEBUG] - ScreenManager: Showing screen 'home'
    [2018-09-02 14:17:33,347] [577469 ] [InputMgr ] [INFO ] - WorkflowManager: Pushing workflow state 'ImagesNavigation-Root' (id='76019aeb-3445-4da9-9a10-63a87549a7cf') onto the navigation stack...
    [2018-09-02 14:17:33,347] [577469 ] [InputMgr ] [DEBUG] - WorkflowManager: Using workflow model with id '4cdd601f-e280-43b9-ad0a-6d7b2403c856' for new workflow state '76019aeb-3445-4da9-9a10-63a87549a7cf'
    [2018-09-02 14:17:33,347] [577469 ] [InputMgr ] [DEBUG] - WorkflowManager: Entering workflow state 'ImagesNavigation-Root'
    [2018-09-02 14:17:33,348] [577470 ] [InputMgr ] [DEBUG] - WorkflowManager: Entering model context with workflow state '76019aeb-3445-4da9-9a10-63a87549a7cf' (old state was '7f702d9c-f2dd-42da-9ed8-0ba92f07787f') in new workflow model '4cdd601f-e280-43b9-ad0a-6d7b2403c856'
    [2018-09-02 14:17:33,348] [577470 ] [InputMgr ] [ERROR] - FilterScreenData: Wrong type of media library view 'MediaPortal.UiComponents.Media.Views.BrowseMediaRootProxyViewSpecification'
    [2018-09-02 14:17:33,348] [577470 ] [InputMgr ] [DEBUG] - WorkflowManager: Attaching GUI model '6997cd35-63f0-4f96-8997-e18c9382e2dc' to workflow state '76019aeb-3445-4da9-9a10-63a87549a7cf'
    [2018-09-02 14:17:33,350] [577472 ] [InputMgr ] [DEBUG] - WorkflowManager: Compiling menu actions for workflow state 'ImagesNavigation-Root'
    [2018-09-02 14:17:33,350] [577472 ] [InputMgr ] [DEBUG] - WorkflowManager: Tidying up...
    [2018-09-02 14:17:33,350] [577472 ] [InputMgr ] [INFO ] - WorkflowManager: Trying to show screen 'ImageFilterByYear'...
    [2018-09-02 14:17:33,350] [577472 ] [InputMgr ] [DEBUG] - ScreenManager: Preparing to show screen 'ImageFilterByYear'...
    [2018-09-02 14:17:33,351] [577473 ] [InputMgr ] [DEBUG] - ScreenManager: Loading screen from file path 'C:\Users\ge230\Documents\Mediaportal 2\Git_WIP2.2\MediaPortal\Bin\MP2-Client\bin\x86\Release\Plugins\Media\Skin\default\screens\ImageFilterByYear.xaml'...
    [2018-09-02 14:17:33,361] [577483 ] [DX Render] [DEBUG] - ScreenManager: Closing screen 'ImageShowItems'
    [2018-09-02 14:17:33,364] [577486 ] [InputMgr ] [DEBUG] - WorkflowManager: Attaching GUI model '1f4caede-7108-483d-b5c8-18bec7ec58e5' to workflow state '76019aeb-3445-4da9-9a10-63a87549a7cf'
    [2018-09-02 14:17:33,378] [577499 ] [171 ] [DEBUG] - AsyncWebLoadOperation: Failed to download http://127.0.0.1:55555/MediaPortal/...dth=250&height=250&NoCache=636714946533669185 - Der Remoteserver hat einen Fehler zurückgegeben: (404) Nicht gefunden.
    [2018-09-02 14:17:33,380] [577501 ] [241 ] [DEBUG] - AsyncWebLoadOperation: Failed to download http://127.0.0.1:55555/MediaPortal/...dth=250&height=250&NoCache=636714946533784352 - Der Remoteserver hat einen Fehler zurückgegeben: (404) Nicht gefunden.
    [2018-09-02 14:17:33,518] [577639 ] [InputMgr ] [DEBUG] - WorkflowManager: Attaching GUI model '8f42c8e9-e8a3-475c-a50a-99e1e644dc91' to workflow state '76019aeb-3445-4da9-9a10-63a87549a7cf'
    [2018-09-02 14:17:33,518] [577639 ] [InputMgr ] [DEBUG] - WorkflowManager: Attaching GUI model '13961014-16c4-4361-9751-8e2c585efd44' to workflow state '76019aeb-3445-4da9-9a10-63a87549a7cf'
    [2018-09-02 14:17:33,519] [577640 ] [InputMgr ] [DEBUG] - WorkflowManager: Attaching GUI model '9e9d0cd9-4fdb-4c0f-a0c4-f356e151bde0' to workflow state '76019aeb-3445-4da9-9a10-63a87549a7cf'
    [2018-09-02 14:17:33,522] [577644 ] [InputMgr ] [DEBUG] - WorkflowManager: Attaching GUI model 'ca6428a7-a6e2-4dd3-9661-f89cebaf8e62' to workflow state '76019aeb-3445-4da9-9a10-63a87549a7cf'
    [2018-09-02 14:17:33,523] [577645 ] [InputMgr ] [DEBUG] - WorkflowManager: Attaching GUI model '54f798af-03e1-4a82-938e-d0d0dc608b1a' to workflow state '76019aeb-3445-4da9-9a10-63a87549a7cf'
    [2018-09-02 14:17:33,523] [577645 ] [InputMgr ] [DEBUG] - WorkflowManager: Attaching GUI model '0e621aa5-0733-4e88-a0f0-887f8d73a055' to workflow state '76019aeb-3445-4da9-9a10-63a87549a7cf'
    [2018-09-02 14:17:33,523] [577645 ] [InputMgr ] [DEBUG] - WorkflowManager: Attaching GUI model 'b23d8dc1-405e-4564-92d0-e247c299ffae' to workflow state '76019aeb-3445-4da9-9a10-63a87549a7cf'
    [2018-09-02 14:17:33,523] [577645 ] [InputMgr ] [DEBUG] - WorkflowManager: Attaching GUI model '82582433-fd64-41bd-9059-7f662dbda713' to workflow state '76019aeb-3445-4da9-9a10-63a87549a7cf'
    [2018-09-02 14:17:33,524] [577646 ] [InputMgr ] [DEBUG] - WorkflowManager: Attaching GUI model '843f373d-0b4b-47ba-8dd1-0d18f00faad3' to workflow state '76019aeb-3445-4da9-9a10-63a87549a7cf'
    [2018-09-02 14:17:33,576] [577698 ] [InputMgr ] [WARN ] - Name 'MediaItemsList' was registered twice in namescope 'Unnamed screen'
    [2018-09-02 14:17:33,615] [577736 ] [InputMgr ] [INFO ] - WorkflowManager: Screen 'ImageFilterByYear' successfully shown
    [2018-09-02 14:17:33,615] [577736 ] [AMQ 'ScreenManager'] [DEBUG] - ScreenManager: Showing screen 'ImageFilterByYear'
    [2018-09-02 14:17:33,617] [577738 ] [AMQ 'ScreenManager'] [WARN ] - Cannot open texture: TopMenu\5619e98d-6b3d-42eb-b593-82e277896654.png
    [2018-09-02 14:17:33,633] [577754 ] [DX Render] [DEBUG] - ScreenManager: Closing screen 'home'
    [2018-09-02 14:17:42,825] [586946 ] [DX Render] [DEBUG] - ContentManager: 30 resources deallocated, next cleanup in 1 seconds. 130.547080993652/100 MB
    [2018-09-02 14:17:43,837] [587958 ] [DX Render] [DEBUG] - ContentManager: 30 resources deallocated, next cleanup in 1 seconds. 128.73021697998/100 MB
    [2018-09-02 14:17:44,853] [588974 ] [DX Render] [DEBUG] - ContentManager: 30 resources deallocated, next cleanup in 1 seconds. 108.257316589355/100 MB
    [2018-09-02 14:17:45,865] [589986 ] [DX Render] [DEBUG] - ContentManager: 10 resources deallocated, next cleanup in 10 seconds. 107.651695251465/100 MB
    [2018-09-02 14:17:55,877] [599998 ] [DX Render] [DEBUG] - ContentManager: 30 resources deallocated, next cleanup in 1 seconds. 88.5540390014648/100 MB
    [2018-09-02 14:17:56,879] [601001 ] [DX Render] [DEBUG] - ContentManager: 10 resources deallocated, next cleanup in 1 seconds. 87.7325553894043/100 MB
    [2018-09-02 14:17:57,896] [602018 ] [DX Render] [DEBUG] - ContentManager: 10 resources deallocated, next cleanup in 1 seconds. 78.6700553894043/100 MB
    [2018-09-02 14:17:58,897] [603018 ] [DX Render] [DEBUG] - ContentManager: 1 resources deallocated, next cleanup in 10 seconds. 78.6094932556152/100 MB
    [2018-09-02 14:17:59,532] [603653 ] [DX Render] [DEBUG] - ContentManager: Allocation 78.6094932556152/100 MB
    [2018-09-02 14:18:08,911] [613032 ] [DX Render] [DEBUG] - ContentManager: 10 resources deallocated, next cleanup in 1 seconds. 71.9805870056152/100 MB
    [2018-09-02 14:18:09,911] [614032 ] [DX Render] [DEBUG] - ContentManager: 10 resources deallocated, next cleanup in 1 seconds. 67.9708213806152/100 MB
    [2018-09-02 14:18:59,538] [663660 ] [DX Render] [DEBUG] - ContentManager: Allocation 67.9708213806152/100 MB
     

    Brownard

    Development Group
  • Team MediaPortal
  • March 21, 2007
    1,955
    1,309
    United Kingdom United Kingdom
    Country flag
    Steps to Reproduce:
    Thanks, I can reproduce it here.
    When I want to enter folder view under images I always get and empty view and number of media items as "-1" or MP is crashing.
    The strange thing: I'm in "show all MI's" and when switching to folder view it sets automatically the filter "year".
    And I can reproduce this, so I'll try and fix both.

    @ge2301 The VirtualizingPanels expect/assume that all of the items are the same size in order to predict the position of the items that aren't being rendered. This means that the different sized folder container is going to cause layouting issues. It should never crash though so we should at least be able to avoid that.
     

    ge2301

    MP2 Design
  • Team MediaPortal
  • January 11, 2014
    6,787
    2,435
    Stuttgart
    Germany Germany
    Country flag
    @ge2301 The VirtualizingPanels expect/assume that all of the items are the same size in order to predict the position of the items that aren't being rendered. This means that the different sized folder container is going to cause layouting issues. It should never crash though so we should at least be able to avoid that.
    I know, but it's somehow not avoidable. We have 3 different base layouts: thumbnail, squared cover (audio), Poster. If I change the folder container to a squared format, it will crash in combination with poster und thumbnails in folder view. Additonally it would be hard to place text inside due to space. I was aware ofthe problem, but almost nobody uses the folder view, so probably thats why the problem was not found before. Deactivating smooth scrolling for only folder view is also not a good idea. I guess these are also the problems keeping you away from grouping rework ;)
     

    BlueMax1916

    Super User
  • Team MediaPortal
  • Super User
  • January 29, 2007
    702
    125
    Germany Germany
    Country flag
    Hi,

    I am using folder view for example because my photographs mostly are not tagged. It odes not crash in the Tiranium Extended skin but it is soooo slow during each folder change if you have a lot of subfolders and a lot of pictures in each folder. Starting on the main pictures folder takes about two minutes to show the subfolders.


    Cheers

    Blue Max
     

    Lehmden

    Retired Team Member
  • Premium Supporter
  • December 17, 2010
    12,125
    3,700
    Lehmden
    Germany Germany
    Country flag
    Hi.
    but almost nobody uses the folder view,
    Don't think so, especially if you have a clean folder structure as you've collected images long before MP2 exists, then the database view is completely unusable. I always use folder view in Videos and Images. Only for Series, Movies and Audio (where extra metadata and fanart is available) I use the library view as only there the library view does make sense imho. I simply never had this crash up to now also ever since the very first beginning I'm using folder view...

    But I never were really happy the way folders and media items are displayed without respecting the aspect the images and/or thumbs have. They are cropped or distorted but mostly not shown properly. Maybe it's time to rework this so portrait, landscape and square "thumbs" could be used together in one list/grid...
     

    Lehmden

    Retired Team Member
  • Premium Supporter
  • December 17, 2010
    12,125
    3,700
    Lehmden
    Germany Germany
    Country flag
    Starting on the main pictures folder takes about two minutes to show the subfolders.
    Yes, this is true too... Not only for pictures but most of the time when you enter a module (Audio, Series, Movies, Images,...) it take ages before the lists are shown. Once you are inside the lists it's getting better (but not good enough, imho) Also I have to say, the images part needs far the most time to be shown. Probably because there are the most media items contained (at least here)...
     

    HTPCSourcer

    Retired Team Member
  • Premium Supporter
  • May 16, 2008
    11,431
    2,334
    Germany Germany
    Country flag
    Browse to this folder and select any thumbnail in the 8th column. This should cause MP2 to crash.
    Is this still crashing the app or does it meanwhile work?
     

    Digsy

    Portal Pro
    August 29, 2018
    189
    19
    50
    Great Britain (UK) Great Britain (UK)
    Country flag
    Is this still crashing the app or does it meanwhile work?
    @HTPCSourcer Having now got 2.2.1 working I can report back:

    It is not crashing anymore but the behaviour is now totally different. In the same folder that was causing the crash before, now if I keep using the arrow keys to select the next image to the right, the arrangement of the thumbnails and the position of the image with focus changes erratically. I have tried to show this in the attached pictures:

    In this image I have selected a picture in the last but one column on the right. All good so far...
    All good.jpg

    Now I go one extra click to the right. Previously this would have caused a crash but instead now all the thumbnails rearrange themselves.
    1 right click.jpg

    And another click to the right...
    2 right clicks.jpg

    And a third....
    3 right clicks.jpg

    And a fourth.
    4 right clicks.jpg

    So now instead of a crash, is just all goes a bit crazy. Sorry guys - this one isn't fixed. :(
     

    Users who are viewing this thread

    Similar threads
    OP Title Forum Replies Date
    ajs [Proposal] Improving the MP1 Small Splash Screen, providing nicer Image :) MediaPortal 1 3
    CyberSimian [Bug] 5025, 5034: Image borders MediaPortal 1 78
    cbr954rr [Finished] [MP2-801] Support for tag image extraction Archive 7
    N Option to "Filter" Images by folder name Feature Requests 8
    D [solved] New install of MP2 - no image thumbs General 1
    morpheus_xx [WiP] OnlineVideos: New browser based playback support using WebDriver, new Amazon siteutil MediaPortal 2 14
    A MediaPortal crash (and restart) on LiveTV after Windows Update (Sep 2020) driver update for Intel HD Graphics 4600 General Support 10
    F MediaPortal 1.16 server crashing due to user error? General Support 5
    L Service keeps crashing General 5
    U [solved] MediaPortal crashing on startup General Support 10
    RoChess Weird GPU crash -- possible cause: resizing media MediaPortal 1 Talk 8
    torone Dritter versuch mit Mediaportal 2 Allgemeines Support- und Diskussionsforum 1
    W [solved] MP suddenly Crashes when starting live TV on most channels and on recordings from the same channels General Support 20
    W [solved] MP suddenly Crashes when starting live TV on some channels and on some recordings Television (MyTV frontend and TV-Server) 1
    D [solved] Changed username in Win10, now TV Server config crashes on fresh install Installation, configuration support 1
    ajs Trakt error when start with MP crash Trakt 1
    R TV server crash with WintTV quadHD General 0
    Dark Eyes TVService locks up or fails to restart on resuming from sleep, and crashes when grabbing EPG Installation, configuration support 7
    atlantic [solved] MP1.24 Pre released crash in TV General Support 12
    RoChess Random GPU crash leads to MePo restart, but works fine afterwards MediaPortal 1 14
    R [fixed] [MP2-819] MP2 Server crashes on ATSC OTA channel scan Submit: Bug Reports 33
    doskabouter 1.23.0 Crash when skipping in a dvd Bugreports 3
    J [fixed] [MP2-833] 2.2.2 server crash during import Submit: Bug Reports 50
    P MP2 TV Server crashes when starting - throws error remoting exception General 2
    G MP Crashed during setting up recording. Newcomers Forum 1

    Similar threads

    Top Bottom