Install Problems

Discussion in 'Installation, configuration support' started by 404, August 6, 2019.

  1. 404

    404 Portal Pro

    Joined:
    January 11, 2005
    Messages:
    244
    Likes Received:
    18
    Ratings:
    +34 / 1
    Been attempting to update MP to the latest version (1.22) but I constantly get a deploytool crash, Details of the crash below:

    Problem Event Name: CLR20r3
    Problem Signature 01: mediaportal.deploytool.exe
    Problem Signature 02: 1.2.0.15456
    Problem Signature 03: 5cc003a0
    Problem Signature 04: System
    Problem Signature 05: 4.0.0.0
    Problem Signature 06: 53b51323
    Problem Signature 07: 23b3
    Problem Signature 08: 1b
    Problem Signature 09: System.NotSupportedException
    OS Version: 6.1.7601.2.1.0.256.1
    Locale ID: 2057
    Additional Information 1: 0a9e
    Additional Information 2: 0a9e372d3b4ad19135b953a78882e789
    Additional Information 3: 0a9e
    Additional Information 4: 0a9e372d3b4ad19135b953a78882e789

    Read our privacy statement online:
    Windows 7 Privacy Statement



    If the online privacy statement is not available, please read our privacy statement offline:
    C:\Windows\system32\en-US\erofflps.txt

    I'm using a fully patched and up-to -date version of Win 7 64 Ultimate, it's the same result if I try to install 1.23...Not something I've ever seen before so I would be grateful if anyone could point me in the right direction.
     
  2. Google AdSense Guest Advertisement



    to hide all adverts.
  3. CyberSimian
    • Team MediaPortal

    CyberSimian Test Group

    Joined:
    June 10, 2013
    Messages:
    1,670
    Likes Received:
    553
    Gender:
    Male
    Location:
    Southampton
    Ratings:
    +978 / 3
    Home Country:
    United Kingdom United Kingdom
    Show System Specs
    Searching the internet for "CLR20r3" suggests that this is a problem with the runtime library for Microsoft's .Net environment. I have just searched my Windows 7 "C:" drive for all files beginning "CLR", and found 12 files with various extensions. Looking at several I see that on my system I have files for .Net version 4, and for .Net version 2. From the event name, it suggests that you are missing .Net version 2, or that there is some problem with it.

    I seached the internet for "microsoft .net version 2 installer" and found this link:

    Download Microsoft .NET Framework Version 2.0 Redistributable Package (x64) from Official Microsoft Download Center

    Try downloading and running the installer, and then reboot.

    -- from CyberSimian in the UK
     
    • Thank You! Thank You! x 1
  4. 404

    404 Portal Pro

    Joined:
    January 11, 2005
    Messages:
    244
    Likes Received:
    18
    Ratings:
    +34 / 1
    @CyberSimian thanks for taking the time to reply, I downloaded the NET 2 installer but it quits with a 'This software is installed as a part of your OS' error with no way to override with a repair or re-install, This is a clean install on which I only intend to run MP and really don't want to re-download all the patches etc again because it took about a day and a half in total,Think I'll go through all my updates and delete anything I can find t do with NET then hopefully it will get installed correctly on the next update, At least I know where to look now so thank you for that.

    404...Also in the UK
     
  5. 404

    404 Portal Pro

    Joined:
    January 11, 2005
    Messages:
    244
    Likes Received:
    18
    Ratings:
    +34 / 1
    Just tried running the MS .NET verification tool and all versions installed checked out fine.
     
  6. 404

    404 Portal Pro

    Joined:
    January 11, 2005
    Messages:
    244
    Likes Received:
    18
    Ratings:
    +34 / 1
    ....And a scan with the FSC tool comes back with 'Windows Resource Protection did not find any integrity violations'
    So on the face of it it seems I'm running a pretty healthy drive and now I'm really lost, Is there anyway to install MP without using Deploytool?
     
  7. 404

    404 Portal Pro

    Joined:
    January 11, 2005
    Messages:
    244
    Likes Received:
    18
    Ratings:
    +34 / 1
    Installing the latest .NET framework (4.8) seems to have fixed the problem.
     
    • Like Like x 1
  8. ramu

    ramu Portal Pro

    Joined:
    July 15, 2008
    Messages:
    190
    Likes Received:
    6
    Ratings:
    +10 / 2
    Got the same problem ! - Installing .net 4.8 runtime solved the problem ;-))

    Perhaps the MediaPortal team can write a hit on instal requerments information in the portal web page. I tried -net 4.0 as usally...
    Thx ramu
     
  9. SpudR
    • Team MediaPortal

    SpudR Documentation Group

    Joined:
    July 27, 2007
    Messages:
    2,609
    Likes Received:
    449
    Occupation:
    CTO, MD
    Location:
    Yorkshire, UK
    Ratings:
    +678 / 2
    Home Country:
    England England
    Show System Specs
    Probably should be installed as a dependency of the install.
    @Developers can someone please check this?
     
Loading...

Users Viewing Thread (Users: 0, Guests: 0)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
  • About The Project

    The vision of the MediaPortal project is to create a free open source media centre application, which supports all advanced media centre functions, and is accessible to all Windows users.

    In reaching this goal we are working every day to make sure our software is one of the best.

             

  • Support MediaPortal!

    The team works very hard to make sure the community is running the best HTPC-software. We give away MediaPortal for free but hosting and software is not for us.

    Care to support our work with a few bucks? We'd really appreciate it!