IR Server running external program for Firewire STB channel changing.... (1 Viewer)

chesh

MP Donator
  • Premium Supporter
  • February 5, 2009
    139
    5
    Spokane, WA
    United States of America United States of America
    First off, thank you and-81 for a great plugin! Unfortunately I'm having a little problem with it. I'm trying to use it to control my STB via firewire. I've installed Tim Moore's MCE 2005 STB Controller suite and the drivers needed for my cable box. When I use channel.exe -f 2 103 (force the channel change on the box to channel 103) via the command line, it works just fine. I've got a similar command as a run command setup for each of the keys in the TV3 Blaster Plugin for IR Suite as follows:

    Program: C:\Program Files\Timmmoore\MCE 2005 STB Controller\channel.exe
    Start in folder: C:\Program Files\Timmmoore\MCE 2005 STB Controller
    Parameters: -f 2 %2
    Window Style: Hidden

    It's odd though, everytime it types a channel it double types it....from the logfile:

    2009-02-09 19:05:35.953125 [ProcessExternalChannel]: TV3BlasterPlugin: ProcessExternalCommand("Run: C:\Program Files\Timmmoore\MCE 2005 STB Controller\channel.exe|C:\Program Files\Timmmoore\MCE 2005 STB Controller|-f 2 %2|Hidden|True|False|False|False", 1, 103)
    2009-02-09 19:05:36.203125 [ProcessExternalChannel]: TV3BlasterPlugin: ProcessExternalCommand("Run: C:\Program Files\Timmmoore\MCE 2005 STB Controller\channel.exe|C:\Program Files\Timmmoore\MCE 2005 STB Controller|-f 2 %2|Hidden|True|False|False|False", 0, 103)
    2009-02-09 19:05:36.468750 [ProcessExternalChannel]: TV3BlasterPlugin: ProcessExternalCommand("Run: C:\Program Files\Timmmoore\MCE 2005 STB Controller\channel.exe|C:\Program Files\Timmmoore\MCE 2005 STB Controller\|-f 2 %2|Hidden|True|False|False|False", 3, 103)

    And, for the life of me I can't find the setting that prevents it from doing that. I've got the Channel Digits set to 3. I can literally watch my STB freak out as soon as this plugin starts to try to send commands. It's like it's always typing in one extra # when trying to tune it. Anyway, my basic is as follows: I'm using a SVN build of Media Portal from 12/22/08 (the last one with a working patch made by garry for the Hauppage HD-PVR), IR Server Plugin 1.0.4.2 and the TV3 Server from the same SVN date. Attached you'll find my logfiles. Any help would be greatly appreciated. Thanks everyone.

    chesh

    P.S. Sorry for the double post. I didn't know if it should be in the main IR Server thread for help, or if it should go as a seperate thread. Please forgive me. :sorry:
     

    chesh

    MP Donator
  • Premium Supporter
  • February 5, 2009
    139
    5
    Spokane, WA
    United States of America United States of America
    I just got home and have been playing with this for a little bit again. It seems that the IR Server is sending 3 commands to my STB when it only really needs to send 1 with the exact channel I want it to tune to. Does anyone know how to edit the plugin / .xml files in order to achieve this? If I can figure that much out, I should be golden. Thanks for any help someone can offer.
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    M Admin to start TV-server MediaPortal 1 Talk 2
    A Keine Verbindung mit Kodi auf Server Allgemeines Support- und Diskussionsforum 10
    CyberSimian Unhandled exception in TV Server TV-Server 0
    Grisu002 Failed to startup - TV Server funktioniert nicht Allgemeines Support- und Diskussionsforum 0
    ajs [WiP] 5030: Add UHD Thumb size to TV Server MediaPortal 1 0
    toricred [solved] Configuring TV Server to use NAS General 1
    T Client / Server slow channel-to-channel change (zapping) General Support 1
    T Server / client channel logo location Installation, configuration support 6
    framug [solved] Some changes/fix in MP1 configuration client and server Submit: code patches (MediaPortal/TV-Server/etc.) 14
    S TV-Server MP1 - Automatic search doesn't work Installation, configuration support 2
    M TV Server can't tune to some DVB-S multiplexes while other software can General 0
    J TV Server setup question Newcomers Forum 0
    D [solved] Changed username in Win10, now TV Server config crashes on fresh install Installation, configuration support 1
    I [solved] Connection to TV Server MySQL General Support 8
    mrmojo666 [Tv Server Plugin ]Direct Show Video Control Plugin 0.0.0.1 for Hauppauge PVR cards MediaPortal 1 Plugins 0
    F After resume, TV Server connection screen is shown General Support 4
    R TV server crash with WintTV quadHD General 0
    R MP Server und Fileshare Einsteigerforum 4
    R [further infos missing] some movies freezing evry seconds Submit: Bug Reports 9
    I MP Server goes into suspend, because it doesn't detect the MP Client General Support 6
    S software to send analog to iptv server OffTopic 11
    geeky_herman Recent server upheaval with thegamesdb.net My Emulators 0
    Lehmden [WiP] [MP2-824] DLNA Server functionality MediaPortal 2 27
    A Client/Server Setup: Slow TV Startup Television (MyTV frontend and TV-Server) 0
    R [fixed] [MP2-819] MP2 Server crashes on ATSC OTA channel scan Submit: Bug Reports 33
    Similar threads

























    Top Bottom