Issues after updating Mediaportal

Discussion in 'General Support' started by doskabouter, November 1, 2017.

  1. doskabouter
    • Premium Supporter

    doskabouter Community Plugin Dev

    Joined:
    September 27, 2009
    Messages:
    2,837
    Likes Received:
    799
    Location:
    Nuenen
    Ratings:
    +1,168 / 1
    Home Country:
    Netherlands Netherlands
    Show System Specs
    Hi,

    First off, thanks for maintaining the steady release cycle of mediaportal, always good to see things continuing!.

    However the last 2 updates (1.16 -> 1.17 and 1.17->1.18) did come with some subtle changes regarding (educated guess) the skinengine.
    I've checked the changelogs and there was no hint to changes in it, so I was a bit surprised (although being a developer myself, I don't always create issues for minor improvements etc).

    The issue I had with the update to 1.17 was this one: Title of video is not displayed when choosing a playbackoption · Issue #163 · offbyoneBB/mp-onlinevideos2 · GitHub, where the skinproperty #selecteditem is updated for all occurrences on the screen, I think it's indeed an improvement and I found fixed onlinevideos accordingly.

    But the update from 1.17 to 1.18 is giving me more troubles (as I'm absolutely not familiar with skinning).
    I must say that issue doesn't occur with the default-skins, but only with my old blackglass (GitHub - doskabouter/blackglass: Original Repository of Black Glass Skins for MediaPortal) skin that I'm trying to keep alive, so I'm hoping someone will be helpful enough to nudge me in the right direction.

    The issue is that when in OnlineVideos and choose a video, that when I'm presented with the resolution dialog (in f.e. youtube) the left (hidden) menu is opened on the screen.
    Exiting that dialog will close the left-menu too.
    See screenshots

    resolution.png videolist.png

    I have tried finding the differences between the default skinfiles and the blackglass ones, and also tried fiddling with the expressions used for the visible attributes of the left menu, but I can't get it to work like it used to...



    So if anyone is able to shed some light on this...
     
  2. Google AdSense Guest Advertisement



    to hide all adverts.
  3. CyberSimian
    • Team MediaPortal

    CyberSimian Test Group

    Joined:
    June 10, 2013
    Messages:
    1,687
    Likes Received:
    558
    Gender:
    Male
    Location:
    Southampton
    Ratings:
    +985 / 3
    Home Country:
    United Kingdom United Kingdom
    Show System Specs
    I have encountered a similar problem with my "ClassicWide" variant of the "DefaultWide" skin. It works as intended on MP 1.12, but on MP 1.18 I find the following:

    In "Recorded TV", "Recorded Radio", "Videos", when I press the INFO button on the remote control, the context menu appears (correct), but the left side menu also appears (incorrect). The current "DefaultWideHD" on MP 1.18 does not show this behaviour.

    I will have a careful look at what is different between DWHD's xml file and my CW's xml file, but if anyone has a clue as to the cause of this problem, please post details! Thanks.

    -- from CyberSimian in the UK
     
  4. CyberSimian
    • Team MediaPortal

    CyberSimian Test Group

    Joined:
    June 10, 2013
    Messages:
    1,687
    Likes Received:
    558
    Gender:
    Male
    Location:
    Southampton
    Ratings:
    +985 / 3
    Home Country:
    United Kingdom United Kingdom
    Show System Specs
    I have found the problem with my "ClassicWide" skin; your problem may or may not be the same.

    The xml definition of the side menu starts with a control tag that has a type of actiongroup. There is a nested control tag, but preceding that I had these:
    Code (Text):
    1. <dimColor>ffffffff</dimColor>
    2. <visible>!Control.HasFocus(50)</visible>
    DWHD is different; it has the following dimcolor tag:
    Code (Text):
    1. <dimColor>00ffffff</dimColor>
    In addition, the visible tag in DWHD is moved from the control with a type of actiongroup to the subsequent control with a type of group. Making these changes to "ClassicWide" fixes the problem for me. I have not yet tested this enough to know whether there are any unwanted side effects of these changes.

    -- from CyberSimian in the UK
     
  5. doskabouter
    • Premium Supporter

    doskabouter Community Plugin Dev

    Joined:
    September 27, 2009
    Messages:
    2,837
    Likes Received:
    799
    Location:
    Nuenen
    Ratings:
    +1,168 / 1
    Home Country:
    Netherlands Netherlands
    Show System Specs
    Hm, after some experimenting I see that unwanted appearance is dependent on dimcolor, that is quite a surprise and frankly shouldn't be.
    Can we promote this to a regression-bug?
    Also I see that it's not only onlinevideos which is affected, it's all over the place (f.e. recorded tv)
    I could create a workaround for the unwanted appearances (however since it occurs at various places, it's going to be a lot of work, but more important: in the blackglass skin, the whole screencontents shift to the right as the hidden menu opens, and that behavior I can't disable when opening a dialog
     
  6. doskabouter
    • Premium Supporter

    doskabouter Community Plugin Dev

    Joined:
    September 27, 2009
    Messages:
    2,837
    Likes Received:
    799
    Location:
    Nuenen
    Ratings:
    +1,168 / 1
    Home Country:
    Netherlands Netherlands
    Show System Specs
    • Thank You! Thank You! x 1
  7. Sebastiii
    • Team MediaPortal

    Sebastiii Development Group

    Joined:
    November 12, 2007
    Messages:
    16,297
    Likes Received:
    6,249
    Gender:
    Male
    Location:
    France
    Ratings:
    +10,270 / 9
    Home Country:
    France France
    Show System Specs
  8. Sebastiii
    • Team MediaPortal

    Sebastiii Development Group

    Joined:
    November 12, 2007
    Messages:
    16,297
    Likes Received:
    6,249
    Gender:
    Male
    Location:
    France
    Ratings:
    +10,270 / 9
    Home Country:
    France France
    Show System Specs
    Link added :p
     
Loading...

Users Viewing Thread (Users: 0, Guests: 0)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
  • About The Project

    The vision of the MediaPortal project is to create a free open source media centre application, which supports all advanced media centre functions, and is accessible to all Windows users.

    In reaching this goal we are working every day to make sure our software is one of the best.

             

  • Support MediaPortal!

    The team works very hard to make sure the community is running the best HTPC-software. We give away MediaPortal for free but hosting and software is not for us.

    Care to support our work with a few bucks? We'd really appreciate it!