Issues with MediaPortal not starting correctly using versions after 1.20 Final (1 Viewer)

Three6ZeroCool

Portal Member
April 4, 2013
29
1
New Zealand New Zealand
Giday.

Long time MediaPortal user here.

When the final of MediaPortal 1.21 went release, I downloaded and upgraded my working 1.20 install.

I ran Mediaportal, and it started normally and was greeted by the familiar GUI of the skin I use, which is 'Apollo'
I later had to reboot my PC thru windows updates.

The next time I ran MediaPortal 1.21, (which was working before restarting the PC) it starts, then seems to get into some weird startup loop, which I can not escape from, except by using task manager, and even then it is hard to select the mediaportal process and kill it, as it is constantly restarting.

I retrograded back to MediaPortal 1.20, and everything works fine once more.

When 1.22 pre-release dropped, I tried upgrading again from 1.20 to 1.22 pre-release, and the identical thing happens, and get stuck in infinite start loop, where Mediaportal fails to make it into it's GUI interface. If I retrograde back to 1.20, then it is fine again.

Any idea what might be happening here?, I am gonna try choosing a different skin from the configuration utility, but this behavior is kinda weird.
 

Three6ZeroCool

Portal Member
April 4, 2013
29
1
New Zealand New Zealand
Thanks for linking that post.

I downloaded the 2 files.
I first upgraded my install to 2.2 Pre-release, then replaced the files.

Unfortunately it made no difference at all to my startup issues.
It progresses thru the normal Mediaportal startup, and gives messages like loading fonts, loading plugins.. then screen goes black, and back on Windows desktop, then it just starts running Mediaportal again, and repeats forever.

I then have to run task manager, but that poses another problem, trying to kill the mediaportal task, as it rapidly appears and disappears, so it takes like multiple attempts to successfully select and end the process. (sometimes 20-30 attempts)

I have a complete drive image, so I reloaded that, and got back to working 1.20 Final configuration, then I let Windows update do it's thing, and noticed that it screwed my 1.20 Final config. ie. It now exhibits the same weird startup behavior.

I tested my clients, and the TVserver itself is working fine, but the local MediaPortal client can not load into the main GUI.

While messing around, I managed to crash my Nvidia drivers, so got the error that Display Driver did not start, using basic drivers blah blah blah.
I then tried running MediaPortal again, and this time it worked.

I then tried restarting the PC, and once again get caught in the startup Loop of MediaPortal.

Seemingly something in the recent Windows Updates is causing this behavior?
It may have upgraded my NVidia drivers, as they seem to be a later version than I previously had, so can maybe restore my drive image again, and see what version
I had before, and then see what happens.

If I can get things working again with the new pre-release MediaPortal version, I can test Colossus1 and 2 functionality for you, as I have both.
 

CyberSimian

Test Group
  • Team MediaPortal
  • June 10, 2013
    2,016
    1,248
    Southampton
    United Kingdom United Kingdom
    Country flag
    screen goes black, and back on Windows desktop, then it just starts running Mediaportal again, and repeats forever.
    MP has a setting to restart MP automatically if MP crashes. It is the setting shown in the screen shot in this page in the Wiki:

    General Config

    If you have that setting enabled, that may have caused the restart loop.

    -- from CyberSimian in the UK
     

    Three6ZeroCool

    Portal Member
    April 4, 2013
    29
    1
    New Zealand New Zealand
    OK, an update.

    Thanks for the tip regarding the restart settings option.
    I was aware of that, and had it disabled already.

    I made some progress and actually got MediaPortal 2.2 pre-release to fully startup.
    I had noticed that Windows update has updated my Nvidia cards drivers.

    As a test, I changed the drivers to use the basic Windows display drivers from Windows itself.
    MediaPortal starts normally and works fine.

    It would appear that the issue I am encountering with MediaPortal 1.21 and 1.22 pre-release, is actually Nvidia driver related.
    My working MediaPortal 1.20 Final drive image uses much older NVidia drivers than what the Windows Update installs.

    As a test, I updated my working MediaPortal 1.20 Final config using Windows Update, and it updated the display drivers to latest WHQL ones, which is a few revisions behind the latest available. It broke the startup again.
    I changed the display drivers to use Microsoft basic drivers, and MediaPortal starts loading again fine.

    Yes, will send some logs, but it seems to be NVidia driver related.
     

    Three6ZeroCool

    Portal Member
    April 4, 2013
    29
    1
    New Zealand New Zealand
    Another Update:

    The startup issue is definitely NVidia driver related. I retrograded the Nvidia drivers on my PC, to what was previously installed before Windows Update upgraded them.

    MediaPortal 1.21 Final fires up as per normal.

    Not sure exactly which NVidia drivers cause the startup issues, but is something quite bizarre.
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    DHosein Mediaportal & Antimalware Service High CPU issue General Support 2
    J MediaPortal TV Server and Kodi media source issues General 9
    D [SOLVED] Radio issue in MediaPortal 1.20 Pre-Release 1.20 Pre Release 47
    T Mediaportal 1.18 on win 10 issue with Kodi as client server General Support 8
    1gkar A Couple of {On-going} Issues Within Various MP Versions General Support 6
    R MP2 GUI Issues General 7
    morpheus_xx [WiP] WIP 2.3 Fanart issues? MediaPortal 2 13
    morpheus_xx [Help Me!] Build issues on TeamCity MediaPortal 2 1
    W Not finding/matching new series - thetvdb issue? My TVSeries 3
    J [fixed] Import issue with alternate movie title matching the name of another movie Submit: Bug Reports 7
    1gkar Latest Intel HD4600 Drivers Issue General Support 1
    J Odd issues with Freesat EPG - MP2 General 18
    S Movie navigation issues in MP2 General 8
    cbr954rr Issue BOOTSUWRNQ with online videos? Plugin Development 1
    2BitSculptor MP1.23 release mediainfo issue? MediaPortal 1 Talk 4
    A TV Channel Combination - case issue Television (MyTV frontend and TV-Server) 0
    Edwardfc [solved] Mp 2.2.1 Configuration Issues - Goes to Sleep while playing Music General 6
    G Amazon Prime (Online Videos) Issue Plugin Development 6
    joecrow 1.22.0 MPE Manager issues. 1.22 5
    M [solved] MP2 v 2.2.1 Issue - Registry Key not created General 5
    D [solved] Multiple issues with new MP2.2.1 install 2.2 Archive 7
    S [solved] Live TV subtitle issue if not using 100% font General 31
    T FF or Rewind video issue watch/edit Videos 0
    K server issue OffTopic 0
    johns11 [solved] MP2.2 TV configuration issue General 4
    Top Bottom