[solved] Latest Media Handler - Latests empty (1 Viewer)

joecrow

Test Group
  • Team MediaPortal
  • August 9, 2012
    1,908
    1,355
    Home Country
    Germany Germany
    Country flag
    i
    What version are we talking about?
    Release version in MPE repository (with small bug due FH not installed)
    Yes 2.3.0.65.
    What number of fairly basic issues when using it with MP 1.18?
    1. In the Config, regardless of what I select in the top box, after closing and saving and closing MP Config. with OK, when re-opened it is always blank, see attached screenshot (config). This is not a problem with MP 1.19pre.
    2. Screenshot tvs-1-3 it is not possible to navigate from the lower strip to the upper strip using the arrow keys on the remote unless there is a middle strip present that allows further upper migration, i.e. if the middle strip is Show Times for example then its nav. controls take over and the upper strip can only be accessed with a mouse.
    3. TV Series only, after navigating to one of the tiles on the upper strip OK or Enter will not play the selected item but just brings up text details, see screenshot tvs-4, it will play with a left mouse click.. Hitting OK in the same situation with Mov.Pics, Music etc does result in playback of the selected item.

    config.jpg tvs-1.jpg tvs-2.jpg tvs-3.jpg tvs-4.jpg
     

    catavolt

    Design Group Manager
  • Team MediaPortal
  • August 13, 2007
    13,320
    9,591
    Lanzarote
    Home Country
    Germany Germany
    Country flag
    2. Screenshot tvs-1-3 it is not possible to navigate from the lower strip to the upper strip using the arrow keys on the remote unless there is a middle strip present that allows further upper migration, i.e. if the middle strip is Show Times for example then its nav. controls take over and the upper strip can only be accessed with a mouse.
    3. TV Series only, after navigating to one of the tiles on the upper strip OK or Enter will not play the selected item but just brings up text details, see screenshot tvs-4, it will play with a left mouse click.. Hitting OK in the same situation with Mov.Pics, Music etc does result in playback of the selected item.
    Both are intentionally implementations of skin functionality, nothimg to do with the LMH itself ;)
     

    joecrow

    Test Group
  • Team MediaPortal
  • August 9, 2012
    1,908
    1,355
    Home Country
    Germany Germany
    Country flag
    Both are intentionally implementations of skin functionality, nothimg to do with the LMH itself
    Bit strange that it is not possible to navigate from one strip to another if there are only 2 but it is possible when there are 3??o_O
    Why is it only the TV Series upper strip that can not be utilized properly with the remote, pressing OK plays the selected items in the upper strip of Music, Mov.Pics and Recorded TV etc. If you are saying that it is a bug in the skin functionality of TV-S which will be fixed and nothing to do with LMH then fair enough but I find it hard to believe that it is an intentional.;)
     

    ajs

    Development Group
  • Team MediaPortal
  • February 29, 2008
    13,739
    8,287
    Kyiv
    Home Country
    Ukraine Ukraine
    Country flag
    About TVSeries in LMH and Play (Hit Ok):
    If show episodes then play selected episode, if season or series then go to Details view for Season or Series...

    About config, need log, what happened with settings... may be Language related :(

    --
    WBR, ajs :):whistle::coffee:
     

    catavolt

    Design Group Manager
  • Team MediaPortal
  • August 13, 2007
    13,320
    9,591
    Lanzarote
    Home Country
    Germany Germany
    Country flag
    Bit strange that it is not possible to navigate from one strip to another if there are only 2 but it is possible when there are 3??o_O
    Sure it´s a bit strange, but skin engine is as it is and does not allow navigation as you or I like it - or do you really think I would do something like this if there was another solution? ;)
     

    joecrow

    Test Group
  • Team MediaPortal
  • August 9, 2012
    1,908
    1,355
    Home Country
    Germany Germany
    Country flag
    About TVSeries in LMH and Play (Hit Ok):
    If show episodes then play selected episode, if season or series then go to Details view for Season or Series...
    If I have Series or Season selected then I confirm it does go to details with OK, working fine. With Episodes though it does not play just briefly flashes the screen and displays as per screenshot tvs-4 in previous post.
    About config, need log, what happened with settings... may be Language related :(
    Yes looks like Language, changed MP skin to English (UK) and selection shows, see attached screenshot. The attached log is for a config. with skin set to German and change for TV-S to Episodes, then an attempt to play one of the displayed episodes.
    config-2.jpg
    UPDATE:_ my mp 1.19pre is also with skin set to English
     

    Attachments

    • MediaPortalLogs_23_02_18__15_00.zip
      254.2 KB · Views: 21
    Last edited:

    joecrow

    Test Group
  • Team MediaPortal
  • August 9, 2012
    1,908
    1,355
    Home Country
    Germany Germany
    Country flag
    Sure it´s a bit strange, but skin engine is as it is and does not allow navigation as you or I like it - or do you really think I would do something like this if there was another solution? ;)
    Couldn't you have used the skin as a trampoline to jump high enough to reach the upper strip?:ROFLMAO:
    Just a thought:p.
     

    ajs

    Development Group
  • Team MediaPortal
  • February 29, 2008
    13,739
    8,287
    Kyiv
    Home Country
    Ukraine Ukraine
    Country flag
    If I have Series or Season selected then I confirm it does go to details with OK, working fine. With Episodes though it does not play just briefly flashes the screen and displays as per screenshot tvs-4 in previous post.

    Yes looks like Language, changed MP skin to English (UK) and selection shows, see attached screenshot. The attached log is for a config. with skin set to German and change for TV-S to Episodes, then an attempt to play one of the displayed episodes.
    View attachment 196468
    Its fixed in new Version to :) i think ;)

    --
    WBR, ajs :):whistle::coffee:
     

    joecrow

    Test Group
  • Team MediaPortal
  • August 9, 2012
    1,908
    1,355
    Home Country
    Germany Germany
    Country flag
    Its fixed in new Version to :) i think ;)
    Hope so, once working it is a very nice plugin.:)(y)
    P.S. It would be nice to have an option to not display the upper strip for Online Videos.
     

    Users who are viewing this thread

    Similar threads

    Yes I thought you and others might be interested in the logic I have used in some of the controls though. I am feeling rather smug with myself about the arrows on the left and right hand side of the LatestMH thumbnail on screen 601 for example ;) and the visibility condition
    Yes I thought you and others might be interested in the logic I have used in some of the controls though. I am feeling rather smug...
    Afternoon all, The Latest Media Handler facade and buttons (ids 919199840, 91919984 et al.) are only working for me on the basic...
    Replies
    19
    Views
    1K
    Since this thread has wandered a bit from the original issue / title, I am starting another one.
    Since this thread has wandered a bit from the original issue / title, I am starting another one.
    I have just done a virgin installation of MP 1.26 on a bare metal installation of Windows 8.1 Pro x64 (because Intel does not...
    Replies
    13
    Views
    874
    This is not possible if it is a self made series, like personal travel videos etc.
    This is not possible if it is a self made series, like personal travel videos etc.
    Hi! I have videos that I want to show in TV-Series, such as personal TV series and educational series. As some examples I have...
    Replies
    8
    Views
    423
    I have asked a couple of times to have the default for that setting to be set disabled, but clearly it is not a problem for everyone and perhaps there are negative implications though I have never experienced any. I and a couple of others had this and reported it on the upgrade to MP 1.21 and there have been a handful of incidences...
    I have asked a couple of times to have the default for that setting to be set disabled, but clearly it is not a problem for...
    I'm having a strange one here ... it seems to have started after getting a new Sony 4k TV, and manifests itself by refusing to...
    Replies
    5
    Views
    723
    That fixed it many thanks.
    That fixed it many thanks.
    I have nearly completed building a new desktop PC, hardware and software, everything was looking great till I tried to get MP2 2.3...
    Replies
    2
    Views
    336
    Top Bottom