LAV Filters error

Discussion in 'Skins and Plugins Installer (MPEI)' started by SpudR, May 18, 2017.

  1. SpudR
    • Team MediaPortal

    SpudR Documentation Group

    Joined:
    July 27, 2007
    Messages:
    2,609
    Likes Received:
    451
    Occupation:
    CTO, MD
    Location:
    Yorkshire, UK
    Ratings:
    +680 / 2
    Home Country:
    England England
    Show System Specs
    So OnlineVideos updated, and with it, it installed the LAVFilters plugin.
    All good except I noticed that the plugin installed an older version (see attached).
    I tried to update the version through the MPEI (it shows version 0.69), but you get the error below.
    I removed the downloaded file from the MP/installer/v2 folder and tried again, but the same happens.
    I'll manually install the latest version but it seems like a mixup somewhere.
    There are no logs to post AFAIK before anyone asks!


     

    Attached Files:

    • Agree Agree x 2
  2. Google AdSense Guest Advertisement



    to hide all adverts.
  3. Requiem
    • Premium Supporter

    Requiem MP Donator

    Joined:
    January 1, 2012
    Messages:
    585
    Likes Received:
    80
    Gender:
    Male
    Ratings:
    +174 / 2
    Home Country:
    Germany Germany
    Show System Specs
    I can confirm that. Multiseat setup, 3 clients, on all clients it says "invalid update info, update aborted" from MPEI.
     
  4. SpudR
    • Team MediaPortal

    SpudR Documentation Group

    Joined:
    July 27, 2007
    Messages:
    2,609
    Likes Received:
    451
    Occupation:
    CTO, MD
    Location:
    Yorkshire, UK
    Ratings:
    +680 / 2
    Home Country:
    England England
    Show System Specs
    Anyone??
     
  5. SpudR
    • Team MediaPortal

    SpudR Documentation Group

    Joined:
    July 27, 2007
    Messages:
    2,609
    Likes Received:
    451
    Occupation:
    CTO, MD
    Location:
    Yorkshire, UK
    Ratings:
    +680 / 2
    Home Country:
    England England
    Show System Specs
    Replies: 2
    Views:253

    No-one??
    Confirmed problem!!!!!!!
     
  6. harryzwo

    harryzwo Portal Pro

    Joined:
    July 25, 2006
    Messages:
    711
    Likes Received:
    34
    Ratings:
    +64 / 1
    Home Country:
    Germany Germany
    Show System Specs
    i Confirm this Problem
     
  7. BlueMax1916
    • Super User

    BlueMax1916 Super User

    Joined:
    January 29, 2007
    Messages:
    693
    Likes Received:
    61
    Ratings:
    +123 / 1
    Home Country:
    Germany Germany
    Show System Specs
    Hi,

    I can confirm this too on both HTPC clients running MP 1.16.

    Cheers

    Blue Max
     
  8. SpudR
    • Team MediaPortal

    SpudR Documentation Group

    Joined:
    July 27, 2007
    Messages:
    2,609
    Likes Received:
    451
    Occupation:
    CTO, MD
    Location:
    Yorkshire, UK
    Ratings:
    +680 / 2
    Home Country:
    England England
    Show System Specs
    Thanks for the confirmation - now we just need as @Developers to take a look :)
     
  9. RicoHTPC
    • Super User

    RicoHTPC Super User

    Joined:
    February 4, 2011
    Messages:
    1,441
    Likes Received:
    97
    Location:
    Cuxhaven
    Ratings:
    +178 / 6
    Home Country:
    Germany Germany
    Show System Specs
    I can confirm this on mp 1.15 and 1.16


    I did this. It installed 0.69 correctly but the exension manager still says 0.68.1 installed with the same problem when trying to update.
     
  10. Edalex
    • Premium Supporter

    Edalex Community Plugin Dev

    Joined:
    January 3, 2008
    Messages:
    2,908
    Likes Received:
    713
    Gender:
    Male
    Location:
    Saratov
    Ratings:
    +1,229 / 9
    Home Country:
    Russian Federation Russian Federation
    Show System Specs
    Please rename KnownExtensions.xml file to smth (a.k.a. backup file) and run update again.
    I didn't find anything suspicious in mpei package online - description says 0.69, exe properties says 0.69 too.

    Nvm, I'm investigating the issue.
    Aha, I found smth.
    Link is right but looks what's going on.
    Downloading from browser
    Request is:
    Code (Text):
    1. GET https://www.team-mediaportal.com/index.php?option=com_mtree&task=att_download&link_id=162&cf_id=24 HTTP/1.1
    2. Host: www.team-mediaportal.com
    3. Connection: keep-alive
    4. Upgrade-Insecure-Requests: 1
    5. User-Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/58.0.3029.110 Safari/537.36
    6. Accept: text/html,application/xhtml+xml,application/xml;q=0.9,image/webp,*/*;q=0.8
    7. Accept-Encoding: gzip, deflate, sdch, br
    8. Accept-Language: ru-RU,ru;q=0.8,en-US;q=0.6,en;q=0.4
    9. Cookie:
    Response is:
    Code (Text):
    1. HTTP/1.1 200 OK
    2. Server: nginx
    3. Date: Tue, 30 May 2017 20:35:24 GMT
    4. Content-Type: application/octet-stream
    5. Content-Length: 10426235
    6. Connection: keep-alive
    7. X-Robots-Tag: noindex, nofollow
    8. Last-Modified: Tue, 30 May 2017 20:35:24 GMT
    9. Cache-Control: no-cache, must-revalidate
    10. Pragma: no-cache
    11. Content-Disposition: inline; filename="LAVFilters0.69.0.0.mpe1";
    12. Content-transfer-encoding: binary
    13. Strict-Transport-Security: max-age=15768000
    14. X-Content-Type-Options: nosniff
    15. X-Xss-Protection: 1; mode=block
    16. X-Frame-Options: SAMEORIGIN
    Downloading from MPEI
    Request
    Code (Text):
    1. GET http://www.team-mediaportal.com/index.php?option=com_mtree&task=att_download&link_id=162&cf_id=24 HTTP/1.1
    2. Accept-Encoding: gzip,deflate,gzip, deflate
    3. Host: www.team-mediaportal.com
    4. Connection: Keep-Alive
    5.  
    Response
    Code (Text):
    1. HTTP/1.1 302 Moved Temporarily
    2. Server: nginx
    3. Date: Tue, 30 May 2017 20:29:13 GMT
    4. Content-Type: text/html
    5. Content-Length: 154
    6. Connection: keep-alive
    7. Location: http://install.team-mediaportal.com/MP1/LAVFilters0.68.1.0.mpe1
    8.  
    9. <html>
    10. <head><title>302 Found</title></head>
    11. <body bgcolor="white">
    12. <center><h1>302 Found</h1></center>
    13. <hr><center>nginx</center>
    14. </body>
    15. </html>
    16.  
    So here's our 0.68.1
    Conclusion:
    site requires additional headers for direct downloading and in other cases in redirects request to previous MPEI.
     
    Last edited: May 30, 2017
    • Informative Informative x 2
    • Thank You! Thank You! x 1
  11. SpudR
    • Team MediaPortal

    SpudR Documentation Group

    Joined:
    July 27, 2007
    Messages:
    2,609
    Likes Received:
    451
    Occupation:
    CTO, MD
    Location:
    Yorkshire, UK
    Ratings:
    +680 / 2
    Home Country:
    England England
    Show System Specs
    :) Right over my head but glad you are working on it!
    lol
    THANKS!
     
Loading...

Users Viewing Thread (Users: 0, Guests: 0)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
  • About The Project

    The vision of the MediaPortal project is to create a free open source media centre application, which supports all advanced media centre functions, and is accessible to all Windows users.

    In reaching this goal we are working every day to make sure our software is one of the best.

             

  • Support MediaPortal!

    The team works very hard to make sure the community is running the best HTPC-software. We give away MediaPortal for free but hosting and software is not for us.

    Care to support our work with a few bucks? We'd really appreciate it!