Live TV Black Screen/Crash (1 Viewer)

Raveen

Portal Member
January 14, 2009
38
1
Home Country
United Kingdom United Kingdom
When I try to tune a TV channel I get a black screen and maybe a burst of audio. Haven't made any changes to MP in a long time but did run a windows update this morning.

I've attached the logs supplied by the watchdog. Any suggestions gratefully received.
 

vuego

Documentation Group
  • Team MediaPortal
  • August 5, 2006
    1,637
    764
    Göteborg
    Home Country
    Sweden Sweden
    Does preview work in TV-Server Configuration?
    Can you record anything and play it in MediaPortal or other players?
     

    Raveen

    Portal Member
    January 14, 2009
    38
    1
    Home Country
    United Kingdom United Kingdom
    I don't think recordings are working, they show in recorded TV a having a length of 0 minutes. Previously recorded TV works fine so I don't think it's a codec issue. I'll get back to you on the preview.

    Also I tried system restore to undo the updates and it worked for half an hour until a recording started and the picture froze. No joy since then.
     

    BillyTheFish

    Portal Pro
    September 5, 2008
    72
    12
    Home Country
    United Kingdom United Kingdom
    When did you system restore to? I've just done to the 23rd September restore point and it's working again. I have only just turned it on and haven't tested recordings but at least I can watch TV again. One of the Windows updates (Windows 7 64 bit) seems to break things for me at least...
     

    HomeY

    Test Group
  • Team MediaPortal
  • February 23, 2008
    6,475
    4,645
    48
    ::1
    Home Country
    Netherlands Netherlands
    Open TV Server config and rescan your channels. Your logs are showing some strange things:
    Code:
    22-09-2012 06:57:49.106 pmtgrabber: grab pmt:100 sid:1e7a
    22-09-2012 06:57:49.151 pmtgrabber: got pmt 100 sid:f33
    22-09-2012 06:57:49.154 pmtgrabber: serviceid mismatch f33 != 1e7a
    Code:
    22-09-2012 06:57:59.312 pmtgrabber: search pmt from PAT for sid:1e7a
    22-09-2012 06:57:59.316 PMT Pid wasn't found on the PAT. Channel may have moved, try a new channel scan.
    Not sure if it's gonna help, because i see those problems also in older TsWriter logs, but something isn't right.
    And please fill in your system specs ;)
     
    Last edited:

    Raveen

    Portal Member
    January 14, 2009
    38
    1
    Home Country
    United Kingdom United Kingdom
    Rescanning now. I've added my system details, sorry about that, it's changed since I last had an issue.
     

    HomeY

    Test Group
  • Team MediaPortal
  • February 23, 2008
    6,475
    4,645
    48
    ::1
    Home Country
    Netherlands Netherlands
    OK, problem seems to be related to SQL :(

    Code:
    2012-09-23 15:54:51.810625 [PowerScheduler poll thread(14)]: Exception   :Error: DatabaseUnavailableUnclassified
    Gentle.Common.GentleException: The database backend (provider MySQL) could not be reached.
    Check the connection string: Server=MediaPortal-PC;Database=MpTvDb;User ID=root;Password=MediaPortal;charset=utf8;Connection Timeout=30; ---> MySql.Data.MySqlClient.MySqlException: Unable to connect to any of the specified MySQL hosts. ---> System.Exception: Exception of type 'System.Exception' was thrown.
       at MySql.Data.MySqlClient.NativeDriver.Open()
       --- End of inner exception stack trace ---
       at MySql.Data.MySqlClient.NativeDriver.Open()
       at MySql.Data.MySqlClient.Driver.Create(MySqlConnectionStringBuilder settings)
       at MySql.Data.MySqlClient.MySqlPool.GetPooledConnection()
       at MySql.Data.MySqlClient.MySqlPool.GetConnection()
       at MySql.Data.MySqlClient.MySqlConnection.Open()
       at Gentle.Provider.MySQL.MySQLProvider.GetConnection()
       --- End of inner exception stack trace ---
       at Gentle.Common.Check.FailWith(Severity severity, Error error, Exception e, String msg)
       at Gentle.Common.Check.Fail(Exception e, Error error, Object[] args)
       at Gentle.Provider.MySQL.MySQLProvider.GetConnection()
       at Gentle.Framework.PersistenceBroker.RetrieveList[T](Key key, IList`1 result, IDbConnection conn, IDbTransaction tr)
       at Gentle.Framework.PersistenceBroker.RetrieveList[T](Key key, IList`1 result)
       at Gentle.Framework.Broker.RetrieveList[T](Key key, IList`1 result)
       at Gentle.Framework.Broker.RetrieveList[T]()
       at TvDatabase.Schedule.ListAll()
       at TvService.Scheduler.IsTimeToRecord(DateTime currentTime)
       at TvService.TVController.get_CanSuspend()
       at TvEngine.PowerScheduler.Handlers.ControllerActiveHandler.get_DisAllowShutdown()
       at TvEngine.PowerScheduler.PowerScheduler.DisAllowShutdown(Boolean refresh)
       at TvEngine.PowerScheduler.PowerScheduler.CheckForStandby(Boolean refresh)
       at TvEngine.PowerScheduler.PowerScheduler.PollThread()MySql.Data.MySqlClient.MySqlException: Unable to connect to any of the specified MySQL hosts. ---> System.Exception: Exception of type 'System.Exception' was thrown.
       at MySql.Data.MySqlClient.NativeDriver.Open()
       --- End of inner exception stack trace ---
       at MySql.Data.MySqlClient.NativeDriver.Open()
       at MySql.Data.MySqlClient.Driver.Create(MySqlConnectionStringBuilder settings)
       at MySql.Data.MySqlClient.MySqlPool.GetPooledConnection()
       at MySql.Data.MySqlClient.MySqlPool.GetConnection()
       at MySql.Data.MySqlClient.MySqlConnection.Open()
       at Gentle.Provider.MySQL.MySQLProvider.GetConnection()System.Exception: Exception of type 'System.Exception' was thrown.
       at MySql.Data.MySqlClient.NativeDriver.Open()

    Not sure if this is fixable or needs a new install...
     

    TommyGS

    New Member
    September 23, 2012
    2
    0
    59
    Home Country
    United Kingdom United Kingdom
    I don't know if this will help but I had something similar and it seems related to Microsoft Security Essentials (there is a post in 'Television'). I couldn't get any picture and recordings were corrupted. I have turned off live scanning in MSE and everything is back to normal. It does seem related to a Microsoft Update but I guess system restore won't roll back the anti malware bits as it were.

    now just have to sort out an alternative anti virus.

    Hope this helps.

    Tommy
     

    Users who are viewing this thread

    Top Bottom