Live TV crash with ESPN over Sky Germany (1 Viewer)

Status
Not open for further replies.

mm1352000

Development Group
  • Team MediaPortal
  • September 1, 2008
    21,571
    8,218
    New Zealand New Zealand
    Country flag
    Hello again Markus

    Okay, so now we have found the problem. It is indeed caused by no PCR being found.
    Hmmm...
    If you can find any way to get a full TS dump from this transponder/multiplex it would be of great assistance to me.
    Are there any other channels on that transponder that do work?
    If so, can you please follow the instructions here:
    http://wiki.team-mediaportal.com/1_MEDIAPORTAL_1/18_Contribute/4_Development/Debugging/TS_Dumps

    Start timeshifting on one of those other working channels. It will include the ESPN stream for me. 20 seconds should be enough.
    Please let me know if/when you have uploaded the file, and mention the file name.
    In the meantime, I will examine the code in further detail and I will try to give you an update/comment or solution in the next 24 to 48 hours.

    Please keep in mind it is 2am here so I will go to sleep shortly... but I would really like to look at the dump before I go to sleep, if you have the time to get it. Otherwise I toss and turn thinking about the problem. ;) :D

    mm
     

    mm1352000

    Development Group
  • Team MediaPortal
  • September 1, 2008
    21,571
    8,218
    New Zealand New Zealand
    Country flag
    Alright, I have to go to bed at this point.
    I can't see anything obviously wrong in the code so I really am relying on you to provide the dump file so that I can do full analysis.
    With that said, here is another TsWriter which will give one more piece of information which could be useful.

    Goodnight from NZ :)
    mm
     

    Attachments

    mm1352000

    Development Group
  • Team MediaPortal
  • September 1, 2008
    21,571
    8,218
    New Zealand New Zealand
    Country flag
    One last comment. :D
    It is bothering me that there have not been more reports of problems.
    I did a search, and so far these are the reports I found:
    https://forum.team-mediaportal.com/threads/2-probleme-mit-sky.101249/
    https://forum.team-mediaportal.com/threads/espn-on-sky-germany-not-working.101311/
    https://forum.team-mediaportal.com/...er-descrambles-channel-perfectly-fine.105478/

    All but one seem to come from you Markus.
    @C.44 seems to have the TsWriter side working, but problems with the TsReader side.
    @tringler said it is not working.
    @hase23 said it is working.

    I'm wondering if there could be some kind of very strange CAM compatibility issue here.
    Is there anybody else who has ESPN working or not working?
     

    mm1352000

    Development Group
  • Team MediaPortal
  • September 1, 2008
    21,571
    8,218
    New Zealand New Zealand
    Country flag
    Yet another comment... :D
    Markus, what is the CAM type that you are using, and also what settings have you got -->here<-- (especially for CAM type) in TV Server configuration?
    If you're using Astoncrypt, what happens if you switch to Default?

    mm
     

    cruse

    MP Donator
  • Premium Supporter
  • November 7, 2007
    166
    41
    Germany Germany
    Might be CAM related.

    Working here with FloppyDTV + Diablo Cam (official subscription smartcard inside, CAM model setting "default"). _But_ sometimes my football recordings (~4h) stop at a random point, I am still able to skip through the recording but no audio/video from that point onward which of course sucks. Hope you can help him with his problem mm, might help with mine as well.

    Big thanks to NZ.
     

    Freuli

    Portal Pro
    October 31, 2007
    391
    77
    Country flag
    Hello mm,

    hopefully I didn't caused a sleepless night for you. I uploaded right now the dump file. The name is: [Germany]_[Astra 19,2 E]_[12663]_[typeTSC]_[Servus TV Deutschland]_[scrambled].ts. I tuned to servus TV Deutschland.

    Regarding your question about my cam. I am using a unicam cam. My setting is default (see the screenshot).

    I am looking forward to get new infos.

    Thanks
    Markus
     

    Attachments

    mm1352000

    Development Group
  • Team MediaPortal
  • September 1, 2008
    21,571
    8,218
    New Zealand New Zealand
    Country flag
    Thanks cruse and Markus

    I'll examine the dump file when I get home from work.
    Do you have other software or an STB that you could try the CAM in?
    If the CAM works in other software then that could prove it is a problem somewhere in TsWriter... although at this point I'm not sure where that could be.
    If the CAM works in an STB but not in other software then it could be a compatibility issue between the tuner/CI slot and CAM.
    If I understand correctly, the Unicam also has firmware. It might also tell us more if you're able to try with different firmwares.

    Until this evening (~8 hours)...
    mm

    [Edit: I should read the first post! :oops:
    Sorry.
    Okay, so it works in your STB but not with MP in the HTPC. It would still help to try with other software.]
     
    Last edited:

    mm1352000

    Development Group
  • Team MediaPortal
  • September 1, 2008
    21,571
    8,218
    New Zealand New Zealand
    Country flag
    I have analysed the dump file as promised.
    It seems that ESPN are sending PCR timestamps every 110 packets or so.
    This seems pretty normal.
    So the question: why does TsWriter not receive those packets?
    Well, possibly the CAM blocks them or TsWriter thinks they are scrambled.
    One interesting thing about those packets - they do not contain any video (ie. they are no payload, adaption field only packets).
    Probably that doesn't make any sense to you, but it could be the problem for the CAM.
    I have one idea about how we could work around this issue.
    Please can you try the attached TsWriter... :)

    mm
     

    Attachments

    Freuli

    Portal Pro
    October 31, 2007
    391
    77
    Country flag
    Hello,

    currently I am on work but I will test it as soon as I will be at home (in case of getting the approval;-))

    Thanks a lot for your great support.

    Markus
     
    Status
    Not open for further replies.

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    torone Dritter versuch mit Mediaportal 2 Allgemeines Support- und Diskussionsforum 1
    W [solved] MP suddenly Crashes when starting live TV on most channels and on recordings from the same channels General Support 20
    W [solved] MP suddenly Crashes when starting live TV on some channels and on some recordings Television (MyTV frontend and TV-Server) 1
    amatesi MP2.2pre Client crash while streaming Live TV from remote MP2.2pre Server (both offline) 2.2 Archive 8
    K MP1.24 HDHomeRun Quatro DVT2 - Pixelation on live TV General Support 1
    S IPTV from online m3u8 for Aussie Live TV General Support 9
    K Flickering live TV playback Newcomers Forum 3
    H [solved] MP2 Wiedergabe von Aufnahmen und Live TV geht nicht Allgemeines Support- und Diskussionsforum 6
    vvulture UNKNOWN ERROR when starting live TV General Support 6
    H random black screen live tv and videos (amended) General Support 0
    404 [solved] Live TV...video and audio freeze General Support 20
    404 How to turn off narration on live tv General 2
    Volker MP2 Rewind / zurückspulen bei Live TV funktioniert nicht Allgemeines Support- und Diskussionsforum 3
    G Occasional Black screen on Live TV and Recorded TV Watch / Listen Media 5
    G Live Tv friert ein Allgemeines Support- und Diskussionsforum 47
    U [solved] Beginner needs help recording live TV General 19
    limpwhizkid 1.22.0 Stutter and or artifact problem when recording and watching the same live tv channel 1.22 2
    rbo Fehlermeldung im Live-TV TV / Streaming 6
    R Pixellation on live TV every few seconds General Support 11
    M After a while Live TV or Recorded TV doesn't play first time General Support 9
    S [solved] Live TV subtitle issue if not using 100% font General 31
    S [solved] Live TV playing stopped General 13
    S Mediaportal 1.22 Pre-Release remote live-tv freezes MediaPortal 1.22 Pre Release 0
    H Live TV info OSD not displaying number of audio channels General Support 3
    E [solved] No Live TV in MP2.2 Client - Can TEST Successfully in "MediaPortal 2 TV Configuration" utility General 8
    Similar threads

























    Top Bottom