MP2 - V2.3 Live TV is not possible if two clients are showing HD channels (Astra HD+) (1 Viewer)

Scheibes

Portal Pro
June 14, 2012
817
69
36
Home Country
Germany Germany
Country flag
Ok, then it is not possible for me to test if MP2 is the Problem.
Cause with JRiver i have the same Problem, that the channel scan won't start.

Then i am back on the beginning.
And don't know whats the problem. :(
 

Scheibes

Portal Pro
June 14, 2012
817
69
36
Home Country
Germany Germany
Country flag
Ok now i buyed for testing the DVB Viewer Pro Version and Media Server Plugin.
And installed on 2 Clients Kodi with thje DVBViewer Client Addon.

Same Problem like with MP2.

Client 1 starts the first HD Channel, all is fine
Client 2 starts the second HD Channel, Client 1 begins to jerk and freeze
Client 1 switch the another HD Channel, all is fine
Client 2 begins to jerk and freeze


Therefore it is no specific MediaPortal 2 issue.
Maybe a Hardware Problem or a network problem.

If it is a network problem, i don't know where i should begin to search, cause i have no special experience in this.
If it is a hardware problem, then i think i must change the TV Tuner/CI-Modul/CAM and that could be very expensive.
 

ge2301

Lead Design MP2
  • Team MediaPortal
  • January 11, 2014
    7,494
    2,669
    Stuttgart
    Home Country
    Germany Germany
    Country flag
    Ok now i buyed for testing the DVB Viewer Pro Version and Media Server Plugin.
    And installed on 2 Clients Kodi with thje DVBViewer Client Addon.

    Same Problem like with MP2.

    Client 1 starts the first HD Channel, all is fine
    Client 2 starts the second HD Channel, Client 1 begins to jerk and freeze
    Client 1 switch the another HD Channel, all is fine
    Client 2 begins to jerk and freeze


    Therefore it is no specific MediaPortal 2 issue.
    Maybe a Hardware Problem or a network problem.

    If it is a network problem, i don't know where i should begin to search, cause i have no special experience in this.
    If it is a hardware problem, then i think i must change the TV Tuner/CI-Modul/CAM and that could be very expensive.
    To me a network problem sounds not so realistic. Why should a network problem happen only, if two clients want to access the same channel? If a port is locked or similar, the issue would be always. Also the logs do not indicate something in this direction.
    I'd contact the hardware seller and explain that the issue could be produced with different software and you assume it's a hardware issue.
     

    Scheibes

    Portal Pro
    June 14, 2012
    817
    69
    36
    Home Country
    Germany Germany
    Country flag
    Yes, that would be my next step, that i contact DD again.

    I already have contacted Digital Devices and we tryed some things, but we doesn't found a solution.

    Gesendet von meinem SM-G950F mit Tapatalk
     

    Lehmden

    Retired Team Member
  • Premium Supporter
  • December 17, 2010
    12,361
    3,803
    Lehmden
    Home Country
    Germany Germany
    Country flag
    Hi.
    The "official" DD Software is "some sort of" DVB-Viewer, afaik. So if it even don't work with DVB-Viewer it most likely is a hardware issue, I fear...

    I still have a Cine S2 V6.5 laying around here. So if nothing else helps, you can send me your CI/CAM/Card and I can test it here with many different TV Solutions. You will get your stuff back asap after the test, for sure ;)
     

    Scheibes

    Portal Pro
    June 14, 2012
    817
    69
    36
    Home Country
    Germany Germany
    Country flag
    I still have a Cine S2 V6.5 laying around here. So if nothing else helps, you can send me your CI/CAM/Card and I can test it here with many different TV Solutions. You will get your stuff back asap after the test, for sure ;)

    Ok that sounds interesting for me.
    Now i will waiting for feedback from DD and if it is necessary, i will come back to that offer. (y)
     

    Scheibes

    Portal Pro
    June 14, 2012
    817
    69
    36
    Home Country
    Germany Germany
    Country flag
    Hello together,

    ok i made many testing with DD and we can exclude that it is a hardware problem, cause i switched my Serverhardware totaly the last few weeks.
    Now i have a brand new DD MAX SX8 TV Card, a new CI Interface with a own PCIe Connection and a new CAM Modul (Unicam EVO 4.0 with Troja 4.83).

    We have tested with MP2 and some testing tools from DD.
    The decrypt works fine and in the DD tools there are no problems when DD descramble 4 channels simultan.

    For me it seams to be a problem with the stream it self.
    Cause i have tested also with DVB Viewer (incl. DVB Media Server), with DVB Viewer it works a bit better then with MP2.
    In DVB Viewer the stream freeze only appear when the 2. Client....

    • started the stream
    • stoped the stream
    • switched to the same channel

    No matter which channel i start to stream or stop or switch.
    In MP2 are the same problems plus the problem, when a client switch to a scrambled channel the other client freeze the stream.

    Now i have no ideas to go on with testing.
    I have invested many money to solve this problem but nothing works.

    Any other ideas from everyone?
     

    morpheus_xx

    Lead Dev MP2
  • Team MediaPortal
  • March 24, 2007
    11,768
    7,121
    Home Country
    Germany Germany
    Country flag
    It is a long time since I touched TV part and descrambling support, so I might remember not correctly...

    There exists 2 kind of information to tell the CAM what it should decode:
    1. Either a PMT (Program main table), which contains a list of all PIDs to decode (stream IDs, video, audio, teletext...)
    2. Or a CaPMT, which is more a command to tell the CAM "add those streams to your decode list" or "remove those streams".
    The 1st way is probably used in TVE code for DD CAM: The tuner instances share one common CAM. This could explain why a 2nd tuner overwrites with its PMT the current descramble information.

    The 2nd way should work better, because it hands off the handling of PID lists to the CAM as the TVE code only sends differences and does not neccessary need to know the other tuner's requests.

    Could you maybe ask about the way it is working correctly inside the DD tools?
     

    Scheibes

    Portal Pro
    June 14, 2012
    817
    69
    36
    Home Country
    Germany Germany
    Country flag
    I will ask DD and gave you the feedback.

    Gesendet von meinem SM-G950F mit Tapatalk
     

    morpheus_xx

    Lead Dev MP2
  • Team MediaPortal
  • March 24, 2007
    11,768
    7,121
    Home Country
    Germany Germany
    Country flag
    I did some more digging into the TVE3 and TVE3.5 implementations. While TVE3 support looks very basic, there is a lot of logic to support MTD (Multi tuner decode) and MCD (Multi channel decode, I guess) in TVE3.5 implementation.
    The difference in architecture is huge. From my perspective investigation should be only done based on TVE3.5: morpheusxx/MediaPortal-1
     
    Last edited:

    Users who are viewing this thread

    Similar threads

    Ok, just done some more mucking around. turns out my logitech mouse seems to be extremely unresponsive in media portal. Can use my keyboard just fine (also lightspeed wireless). Suggestions?
    Ok, just done some more mucking around. turns out my logitech mouse seems to be extremely unresponsive in media portal. Can use my...
    Good evening, having just fresh installed media portal 2.3.2. Looking at trialing again as it now seems to support what I am...
    Replies
    1
    Views
    188
    I'm bad with TV-stuff. IMaybe @morpheus_xx has an idea. After that endless following errors:
    I'm bad with TV-stuff. IMaybe @morpheus_xx has an idea. After that endless following errors:
    Before you create this bug report: Make sure that your system (Windows, codecs and drivers) is up to date, matching the...
    Replies
    1
    Views
    479
    Having used MP1 since 15 years, these epg related problems occuring after a fresh install stumble me. Needed to change a system hdd and decided it was time for a clean install anyway. Other hardware (C2D, 8 Gb ram, no tv cards - IP only) unchanged. Was running an earlier Win10 version with MP 1.24 which had been updated for years...
    Having used MP1 since 15 years, these epg related problems occuring after a fresh install stumble me. Needed to change a system...
    Having used MP1 since 15 years, these epg related problems occuring after a fresh install stumble me. Needed to change a system...
    Replies
    0
    Views
    406
    Many thanks for your fast response. Hopefully I'll get to work through these items in the next few days. Kind regards.
    Many thanks for your fast response. Hopefully I'll get to work through these items in the next few days. Kind regards.
    Hi, I'm new to the world of HTPC and Media Portal but I've decided to give it a go since my Pioneer DVR-LX60D PVR failed and is...
    Replies
    2
    Views
    743
    We'll, again I have posted a problem then found the solution myself :whistle: I incorrectly used "Multi seat setup: use UNC paths" when I was setting up initially and having some trouble with paths. I had clicked help for that setting before I tried using it, but many of the help links in the config utility are broken. Today I...
    We'll, again I have posted a problem then found the solution myself :whistle: I incorrectly used "Multi seat setup: use UNC paths"...
    I've been a MP1 user for a very long time. I had been using Argus for OTA ATSC recording and viewing which has been flawless...
    Replies
    1
    Views
    2K
    Top Bottom