MP2 - V2.3 Long delay between stopping a movie/episode and replaying. (2 Viewers)

Lichloathe

MP Donator
  • Premium Supporter
  • July 25, 2007
    137
    100
    Home Country
    Australia Australia
    Greatly improved.

    Within plugins, Series, Movies and recordings, it now works as expected. I did multiple marks between watched and unwatched and no delays. (y)

    I have noticed now a lot of the time that going back to the home screen from the major plugins and returning, there seems to be a delay.
    In the logs I attached, at approx line 3406, the wait was about 90 seconds. I went into Series, back out to home again, then back into Series.
    Things are looking up though, thanks.

    I'll keep testing.
     

    Attachments

    • Client.zip
      350.7 KB
    • Server.zip
      2.5 MB

    henso

    Development Group
  • Team MediaPortal
  • February 16, 2012
    2,335
    824
    Home Country
    Denmark Denmark
    I have noticed now a lot of the time that going back to the home screen from the major plugins and returning, there seems to be a delay.
    That's the forced delay I was talking about. I don't know if that can be avoided, though. It seems the database queries required for that are slow.
     

    Timhoh1234

    Portal Pro
    September 29, 2015
    242
    77
    Home Country
    Germany Germany
    Thanks a lot for taking this. I just installed the new version and can also report a great improvement at least for the short time testing it. Sometimes I still have to wait longer when opening the share overview. Coming back to home has some delay, but far below 90 seconds for me. I’d say it’s between 10-20 seconds here. I’ll test further ...
     

    Lichloathe

    MP Donator
  • Premium Supporter
  • July 25, 2007
    137
    100
    Home Country
    Australia Australia
    Interesting.
    I am noticing the delay when returning into a plug-in after returning to home.
    Just a thought though, do I have a different case as I have 28 shares listed in configuration?
    I do remember that during a previous version install I chose to test the problem with less sources and thought the delays were decreased.
     

    Timhoh1234

    Portal Pro
    September 29, 2015
    242
    77
    Home Country
    Germany Germany
    Interesting.
    I am noticing the delay when returning into a plug-in after returning to home.
    Just a thought though, do I have a different case as I have 28 shares listed in configuration?
    I do remember that during a previous version install I chose to test the problem with less sources and thought the delays were decreased.
    I’ve only 6 sources, so that’s of course a difference. I could assume that more sources mean more access activities in the background, so longer delays. However I had/have the long delays also with a few sources, so there are other contributors.
    I could assume it’s a mixture of number of sources, number of media items and something else in the unknown fog ;)
     

    azzuro

    Test Group
  • Team MediaPortal
  • May 10, 2007
    9,918
    5,567
    France - IDF
    Home Country
    France France
    @ge2301
    i have delay up to 2-3 second for enter in audio section, big difference with 7/8 seconds previously.
    i will test to import my video section too, i remember the effect was more present after importing audio & video section
     

    azzuro

    Test Group
  • Team MediaPortal
  • May 10, 2007
    9,918
    5,567
    France - IDF
    Home Country
    France France
    sorry @ge2301 this don't improve times when i have video imported, délay is 10 seconds > 15 seconds to display audio list items. (1079 items to display )
     

    ge2301

    Lead Design MP2
  • Team MediaPortal
  • January 11, 2014
    8,205
    3,249
    Stuttgart
    Home Country
    Germany Germany
    sorry @ge2301 this don't improve times when i have video imported, délay is 10 seconds > 15 seconds to display audio list items. (1079 items to display )
    Thanks for testing anyway. For others including me it helps. We have several root causes overlapping leading to the delay. For you the number of media items seems dominant, so the changes help at other areas.
     

    Users who are viewing this thread

    Top Bottom